FlowframTk is subject to the GNU General Public License. See the file LICENSE for details.

DOCUMENTATION IS PROVIDED “AS IS” AND ALL EXPRESS OR IMPLIED CONDITIONS, REPRESENTATIONS AND WARRANTIES, INCLUDING ANY IMPLIED WARRANTY OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE OR NON-INFRINGEMENT, ARE DISCLAIMED, EXCEPT TO THE EXTENT THAT SUCH DISCLAIMERS ARE HELD TO BE LEGALLY INVALID.

This document is a user manual for FlowframTk. For information about Jdrview or jdrutils, see jdrview.pdf or jdrutils.pdf, respectively.

The latest version of FlowframTk can be downloaded from http://www.dickimaw-books.com/apps/flowframtk/

Occasionally the canvas doesn’t get redrawn correctly. To force a redraw, use F11.
CONTENTS

8 Selecting and Editing Objects 54
  8.1 Moving an Object .......................... 55
  8.2 Cut ..................................... 56
  8.3 Copy ..................................... 56
  8.4 Paste ..................................... 56
  8.5 Object Description .......................... 56
  8.6 Editing Control Points ........................ 56
  8.7 Symmetric Shapes ........................... 62
  8.8 Editing Text Areas ........................... 63
  8.9 Combining a Text Area and Path to Form a Text-Path ........................... 66
  8.10 Text Outlines ................................. 68
  8.11 Reducing to Grey Scale ......................... 68
  8.12 Colour Space Conversions ......................... 70
  8.13 Fade ..................................... 70
  8.14 Removing Transparency .......................... 71
  8.15 Moving an Object to the Front ..................... 71
  8.16 Moving an Object to the Back ...................... 71
  8.17 Rotating Objects ............................... 72
  8.18 Scaling Objects .................................. 73
  8.19 Shearing Objects ............................... 77
  8.20 Grouping and Ungrouping Objects ..................... 81
  8.21 Aligning Objects .................................. 82
  8.22 Reversing a Path’s Direction ....................... 84
  8.23 Merging Paths ................................... 84
  8.24 Path Union ..................................... 89
  8.25 Exclusive Or Function ........................... 90
  8.26 Path Intersection .................................. 93
  8.27 Path Subtraction ................................ 93
  8.28 Separating a Text-Path into a Text Area and Path ......................... 95
  8.29 Converting a Path or Text-Path into a Pattern ......................... 95
  8.30 Converting to a Path ................................ 103
     8.30.1 Converting a Text Area, Text-Path or Pattern to a Path ......................... 103
     8.30.2 Converting an Outline to a Path ................................ 103
  8.31 Splitting Text Areas ............................. 103

9 Path and Text Styles 107
  9.1 Line Colour .................................... 107
  9.2 Fill Colour .................................... 108
  9.3 Line Style ..................................... 109
     9.3.1 Line Thickness (or Pen Width) ......................... 109
     9.3.2 Dash Pattern .................................. 109
     9.3.3 Cap Style ................................... 109
     9.3.4 Join Style ................................... 111
     9.3.5 Markers ..................................... 111
     9.3.6 Winding Rule .................................. 120
  9.4 Text Colour ..................................... 120
  9.5 Text Style ..................................... 121
     9.5.1 Font Family .................................. 121
     9.5.2 Font Size ................................... 122
     9.5.3 Font Series .................................. 123
### List of Tables

<table>
<thead>
<tr>
<th></th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>2.1</td>
<td>Keyboard Accelerators and Menu Mnemonics</td>
<td>3</td>
</tr>
<tr>
<td>2.2</td>
<td>JavaHelp Viewer Shortcut Keys</td>
<td>6</td>
</tr>
<tr>
<td>3.1</td>
<td>Paper Size Identifiers</td>
<td>9</td>
</tr>
<tr>
<td>3.2</td>
<td>Available Values for the Normal Font Size</td>
<td>21</td>
</tr>
<tr>
<td>3.3</td>
<td>Hotspot Functions</td>
<td>27</td>
</tr>
<tr>
<td>9.1</td>
<td>Available Marker Styles and Dependencies for Arrow Style Markers</td>
<td>112</td>
</tr>
<tr>
<td>9.2</td>
<td>Available Marker Styles and Dependencies for Partial Arrow Style Markers</td>
<td>112</td>
</tr>
<tr>
<td>9.3</td>
<td>Available Marker Styles and Dependencies for Data Point Style Markers</td>
<td>113</td>
</tr>
<tr>
<td>9.4</td>
<td>Available Marker Styles and Dependencies for Bracket Style Markers</td>
<td>114</td>
</tr>
<tr>
<td>9.5</td>
<td>Available Marker Styles and Dependencies for Cap Style Markers</td>
<td>114</td>
</tr>
<tr>
<td>9.6</td>
<td>Available Marker Styles and Dependencies for Decorative Markers</td>
<td>116</td>
</tr>
<tr>
<td>A.1</td>
<td>Available Colour Types</td>
<td>239</td>
</tr>
<tr>
<td>A.2</td>
<td>Tool Identifiers</td>
<td>241</td>
</tr>
<tr>
<td>A.3</td>
<td>Paper Size Identifiers</td>
<td>242</td>
</tr>
<tr>
<td>A.4</td>
<td>Additional Paper Size Identifiers (JDR v1.3 onwards)</td>
<td>243</td>
</tr>
<tr>
<td>A.5</td>
<td>Marker IDs</td>
<td>250</td>
</tr>
<tr>
<td>A.6</td>
<td>Additional Marker IDs (JDR 1.4)</td>
<td>250</td>
</tr>
<tr>
<td>A.7</td>
<td>Additional Marker IDs (JDR 1.6)</td>
<td>250</td>
</tr>
</tbody>
</table>
## List of Figures

3.1 Available Regular Grids .................................. 12
3.2 Tschichold Grid ........................................ 13
3.3 Configuration Dialog Box (Control Point Settings) ........ 14
3.4 Configuration Dialog Box (Startup Directory Settings) .... 15
3.5 Configuration Dialog Box (JDR/AJR Settings) ............... 16
3.6 Configuration Dialog Box (Startup Settings) ............... 17
3.7 Configuration Dialog Box (Bitmap Settings) ............... 18
3.8 Configuration Dialog Box (Application Paths) ............. 19
3.9 Setting the Normal Font Size and (optionally) the Class ... 20
3.10 Flowframe Settings Tab .................................. 22
3.11 LaTeX-Related Text Settings ................................ 24
3.12 Adding a New Text Mapping ............................... 25
3.13 Configuration UI Dialog Box (Graphics Settings) ......... 26
3.14 Hotspots .................................................. 27
3.15 Configuration UI Dialog Box (Language Settings) ......... 28
3.16 Configuration UI Dialog Box (Accelerators) ............... 30
3.17 Changing a keyboard shortcut .............................. 31
3.18 Configuration UI Dialog Box (Ruler Settings) ............. 32
3.19 Configuration UI Dialog Box (Normalization) ............. 33
3.20 Configuration UI Dialog Box (TeX Editor Settings) ..... 35
4.1 The Main Window ......................................... 37
6.1 Path Attributes Are Only Set Once the Path is Completed . 44
6.2 Go To Co-ordinate Dialog Box ............................. 44
6.3 Text Area Popup Menu .................................... 48
6.4 Insert Symbol Dialog Box .................................. 49
7.1 Bitmaps Are Displayed in Draft Mode When There Is Insufficient Memory in the JRE .......................... 52
7.2 Bitmap Properties Dialog .................................. 53
8.1 Popup Menus in Select Mode Depend on What Objects Have Been Selected .......................... 55
8.2 Move Selected Objects Dialog Box .......................... 55
8.3 Setting an Object’s Description ............................. 56
8.4 Making the Join Between Segments Continuous ............. 59
8.5 Continuity Anchor ......................................... 60
8.6 Opening a Path ............................................ 60
8.7 Closing a Path ............................................. 61
8.8 Adding Symmetry to a Path ................................. 64
8.9 Closed Symmetric Path .................................... 65
8.10 Edit Text Dialog Box ...................................... 65
8.11 Combining a Text Area and Path to Form a Text-Path ...... 67
8.12 Symmetric Text-Paths ..................................... 69
8.13 Text Outline .............................................. 70
<table>
<thead>
<tr>
<th>Figure</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>8.14</td>
<td>Three Selected Objects Rotated by 90 Degrees</td>
<td>72</td>
</tr>
<tr>
<td>8.15</td>
<td>A Group Consisting of Three Objects Rotated by 90 Degrees</td>
<td>73</td>
</tr>
<tr>
<td>8.16</td>
<td>Rotating a Text-Path</td>
<td>74</td>
</tr>
<tr>
<td>8.17</td>
<td>Three Selected Objects Scaled by a Factor of 2</td>
<td>75</td>
</tr>
<tr>
<td>8.18</td>
<td>A Group Consisting of Three Objects Scaled by a Factor of 2</td>
<td>75</td>
</tr>
<tr>
<td>8.19</td>
<td>Scaling a Text-Path</td>
<td>76</td>
</tr>
<tr>
<td>8.20</td>
<td>Two Selected Objects Sheared Horizontally</td>
<td>78</td>
</tr>
<tr>
<td>8.21</td>
<td>A Group Consisting of Two Objects Sheared Horizontally</td>
<td>78</td>
</tr>
<tr>
<td>8.22</td>
<td>Shearing a Text-Path</td>
<td>79</td>
</tr>
<tr>
<td>8.23</td>
<td>Shearing a Pattern</td>
<td>80</td>
</tr>
<tr>
<td>8.24</td>
<td>Aligning a Group Consisting of Three Objects</td>
<td>83</td>
</tr>
<tr>
<td>8.25</td>
<td>Aligning a Wider Object Relative to a Thinner Object</td>
<td>85</td>
</tr>
<tr>
<td>8.26</td>
<td>Reversing the Direction of a Path</td>
<td>86</td>
</tr>
<tr>
<td>8.27</td>
<td>Reversing the Direction of a Text-Path</td>
<td>86</td>
</tr>
<tr>
<td>8.28</td>
<td>Merging Two Paths</td>
<td>86</td>
</tr>
<tr>
<td>8.29</td>
<td>Merging Two Text-Paths</td>
<td>87</td>
</tr>
<tr>
<td>8.30</td>
<td>Paths Are Merged According to the Stacking Order</td>
<td>88</td>
</tr>
<tr>
<td>8.31</td>
<td>Path Union</td>
<td>89</td>
</tr>
<tr>
<td>8.32</td>
<td>Text-Path Union</td>
<td>90</td>
</tr>
<tr>
<td>8.33</td>
<td>Pattern Union</td>
<td>91</td>
</tr>
<tr>
<td>8.34</td>
<td>Exclusive OR Function</td>
<td>92</td>
</tr>
<tr>
<td>8.35</td>
<td>Path Intersection Function</td>
<td>93</td>
</tr>
<tr>
<td>8.36</td>
<td>Path Subtraction Function</td>
<td>94</td>
</tr>
<tr>
<td>8.37</td>
<td>Subtracting From a Text-Path</td>
<td>94</td>
</tr>
<tr>
<td>8.38</td>
<td>Separating the Text and Path from a Text-Path</td>
<td>96</td>
</tr>
<tr>
<td>8.39</td>
<td>Separating the Text and Path from an Outline Text-Path</td>
<td>97</td>
</tr>
<tr>
<td>8.40</td>
<td>A Rotational Pattern</td>
<td>98</td>
</tr>
<tr>
<td>8.41</td>
<td>A Scaled Pattern</td>
<td>99</td>
</tr>
<tr>
<td>8.42</td>
<td>A Spiral Pattern</td>
<td>100</td>
</tr>
<tr>
<td>8.43</td>
<td>Patterns Can Either be Single or Multi-Mode</td>
<td>101</td>
</tr>
<tr>
<td>8.44</td>
<td>Text-Path Patterns</td>
<td>102</td>
</tr>
<tr>
<td>8.45</td>
<td>Converting a Text Area to a Path</td>
<td>103</td>
</tr>
<tr>
<td>8.46</td>
<td>Converting an Outline to a Path</td>
<td>104</td>
</tr>
<tr>
<td>8.47</td>
<td>Splitting a Text Area</td>
<td>105</td>
</tr>
<tr>
<td>8.48</td>
<td>Splitting a Text Path</td>
<td>106</td>
</tr>
<tr>
<td>9.1</td>
<td>Example Dash Patterns</td>
<td>109</td>
</tr>
<tr>
<td>9.2</td>
<td>Cap Styles</td>
<td>110</td>
</tr>
<tr>
<td>9.3</td>
<td>The Cap Style Is Affected by Whether the Path Is Open or Closed</td>
<td>110</td>
</tr>
<tr>
<td>9.4</td>
<td>Join Styles</td>
<td>111</td>
</tr>
<tr>
<td>9.5</td>
<td>Repeat Markers</td>
<td>117</td>
</tr>
<tr>
<td>9.6</td>
<td>Repeat Markers Are Placed Along the Gradient Vector</td>
<td>117</td>
</tr>
<tr>
<td>9.7</td>
<td>Reversed Markers</td>
<td>117</td>
</tr>
<tr>
<td>9.8</td>
<td>Examples of Composite Markers</td>
<td>118</td>
</tr>
<tr>
<td>9.9</td>
<td>Disabling the Marker Auto Offset</td>
<td>118</td>
</tr>
<tr>
<td>9.10</td>
<td>Changing a Marker’s Offset Moves It Along the Gradient Vector</td>
<td>118</td>
</tr>
<tr>
<td>9.11</td>
<td>Repeat Gap</td>
<td>119</td>
</tr>
<tr>
<td>9.12</td>
<td>Marker Colour May Be Independent of the Line Colour</td>
<td>119</td>
</tr>
<tr>
<td>9.13</td>
<td>Primary and Secondary Markers are Independent</td>
<td>120</td>
</tr>
<tr>
<td>9.14</td>
<td>Winding Rules</td>
<td>120</td>
</tr>
</tbody>
</table>
LIST OF FIGURES

9.15 Setting the Font Family .............................................. 121
9.16 Setting the Font Size ................................................. 122
9.17 Setting the Font Series .............................................. 123
9.18 Setting the Font Shape .............................................. 124
9.19 Text-Path Transformation Matrix ................................. 125
9.20 The Effect of Converting from Java Fonts to TeX Fonts ...... 126
9.21 The Font Used by the LaTeX Document may Result in Considerable Differences from the Original Image .... 127
9.22 Text Area Containing Maths ........................................ 128
9.23 The Text Area’s Transformation Matrix Will Also Be Applied to the Anchor .............................................. 129

10.1 The Preamble Editor ................................................ 131
10.2 Parshape (Using Outline) ........................................... 133
10.3 Parshape (Using Path) .............................................. 133
10.4 Shapepar Example .................................................... 135
10.5 Setting the Typeblock ............................................... 139
10.6 The typeblock is shown as a light grey rectangle .......... 140
10.7 Frame Attributes Dialog Box ....................................... 141
10.8 Layout Containing Six Circles .................................... 145
10.9 The Effects of Too Much and Too Little Text ................. 146

11.1 House Example—Creating a Rectangle ......................... 148
11.2 House Example—Creating a Triangle ......................... 148
11.3 House Example — Completed Image ............................. 149
11.4 House Example — Saving the Image ......................... 149
11.5 House Example—Exporting the Image to a LaTeX File .... 149
11.6 Lettuce on Toast Example—Brown Rectangle ............. 150
11.7 Lettuce on Toast Example—Editing the Rectangle ....... 150
11.8 Lettuce on Toast Example—Converting the Top Segment to a Curve .............................................. 151
11.9 Lettuce on Toast Example—Finish Editing the Curve .... 151
11.10 Lettuce on Toast Example — Adding a Closed Curve Path .... 152
11.11 Lettuce on Toast Example — Completed Image ............. 152
11.12 Cheese and Lettuce on Toast Example — A Filled Rectangle .................. 153
11.13 Cheese and Lettuce on Toast Example — Adding Ellipses ... 153
11.14 Cheese and Lettuce on Toast Example—Merging Paths .... 153
11.15 Cheese and Lettuce on Toast Example — Completed Image .... 154
11.16 Artificial Neuron Example — Adding a Rectangle ........ 154
11.17 Artificial Neuron Example — Adding a Circle ............. 154
11.18 Artificial Neuron Example—Creating a Sigmoidal Curve .... 155
11.19 Artificial Neuron Example — Setting the Current Line Style .... 156
11.20 Artificial Neuron Example — End Marker Dialog Box .... 156
11.21 Artificial Neuron Example — Adding Arrows ............... 156
11.22 Artificial Neuron Example — Adding Text ................... 156
11.23 Artificial Neuron Example — Editing Text ................... 157
11.24 Artificial Neuron Example — Insert Symbol Dialog Box .... 157
11.25 Artificial Neuron Example — Setting the Font Style ....... 158
11.26 Artificial Neuron Example—Setting the Equivalent LaTeX Symbol .............................................. 158
11.27 Artificial Neuron Example — Justifying Objects .......... 158
<table>
<thead>
<tr>
<th>Figure</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>11.28</td>
<td>Artificial Neuron Example — Image as it Appears in a LaTeX Document</td>
<td>159</td>
</tr>
<tr>
<td>11.29</td>
<td>Bus Example — Setting the Normal Font Size</td>
<td>160</td>
</tr>
<tr>
<td>11.30</td>
<td>Bus Example — Create a Circle</td>
<td>160</td>
</tr>
<tr>
<td>11.31</td>
<td>Bus Example — Editing the Path</td>
<td>160</td>
</tr>
<tr>
<td>11.32</td>
<td>Bus Example — Break the Path</td>
<td>161</td>
</tr>
<tr>
<td>11.33</td>
<td>Bus Example — Move and Rotate Top Semi-Circle</td>
<td>161</td>
</tr>
<tr>
<td>11.34</td>
<td>Bus Example — Adding Lines</td>
<td>161</td>
</tr>
<tr>
<td>11.35</td>
<td>Bus Example — Convert Line Segment to a Curve</td>
<td>162</td>
</tr>
<tr>
<td>11.36</td>
<td>Bus Example — Add Windows</td>
<td>162</td>
</tr>
<tr>
<td>11.37</td>
<td>Bus Example — Subtract Windows from Bus Outline and Set Fill Colour</td>
<td>162</td>
</tr>
<tr>
<td>11.38</td>
<td>Bus Example — Resulting Shaped Paragraph</td>
<td>163</td>
</tr>
<tr>
<td>11.39</td>
<td>Poster Example — The Typeblock</td>
<td>164</td>
</tr>
<tr>
<td>11.40</td>
<td>Poster Example — Adding Rectangles</td>
<td>165</td>
</tr>
<tr>
<td>11.41</td>
<td>Poster Example — Adding a Bitmap</td>
<td>165</td>
</tr>
<tr>
<td>11.42</td>
<td>Poster Example — Adding Some Colour</td>
<td>166</td>
</tr>
<tr>
<td>11.43</td>
<td>Poster Example — Assigning Frame Information</td>
<td>167</td>
</tr>
<tr>
<td>11.44</td>
<td>Poster Example — Adding Contents to a Static Frame</td>
<td>167</td>
</tr>
<tr>
<td>11.45</td>
<td>Poster Example — Frame Information Assigned</td>
<td>168</td>
</tr>
<tr>
<td>11.46</td>
<td>Poster Example — Adding Preamble Information</td>
<td>169</td>
</tr>
<tr>
<td>11.47</td>
<td>Poster Example — Export Frame Information to a LaTeX Package</td>
<td>169</td>
</tr>
<tr>
<td>11.48</td>
<td>Poster Example — Final Document</td>
<td>171</td>
</tr>
<tr>
<td>11.49</td>
<td>Newspaper Example — Setting the LaTeX Normal Font Size</td>
<td>172</td>
</tr>
<tr>
<td>11.50</td>
<td>Newspaper Example — Setting the Grid</td>
<td>172</td>
</tr>
<tr>
<td>11.51</td>
<td>Newspaper Example — Setting the Storage Unit</td>
<td>172</td>
</tr>
<tr>
<td>11.52</td>
<td>Newspaper Example — Setting the Typeblock</td>
<td>173</td>
</tr>
<tr>
<td>11.53</td>
<td>Newspaper Example — Title Frame</td>
<td>174</td>
</tr>
<tr>
<td>11.54</td>
<td>Newspaper Example — Assigning Flowframe Data to Title Frame</td>
<td>174</td>
</tr>
<tr>
<td>11.55</td>
<td>Newspaper Example — Left and Right Heading Frames Added</td>
<td>175</td>
</tr>
<tr>
<td>11.56</td>
<td>Newspaper Example — Assigning Flowframe Data to Left Heading Frame</td>
<td>175</td>
</tr>
<tr>
<td>11.57</td>
<td>Newspaper Example — Added L Shaped Frame</td>
<td>176</td>
</tr>
<tr>
<td>11.58</td>
<td>Newspaper Example — Assigning Flowframe Data to L Shaped Frame</td>
<td>177</td>
</tr>
<tr>
<td>11.59</td>
<td>Newspaper Example — Added Image</td>
<td>178</td>
</tr>
<tr>
<td>11.60</td>
<td>Newspaper Example — Assigning Flowframe Data to Bitmap</td>
<td>179</td>
</tr>
<tr>
<td>11.61</td>
<td>Newspaper Example — Added Right Hand Polygon</td>
<td>179</td>
</tr>
<tr>
<td>11.62</td>
<td>Newspaper Example — Assigning Flowframe Data to Right Hand Polygon</td>
<td>180</td>
</tr>
<tr>
<td>11.63</td>
<td>Newspaper Example — Added L Shaped Divider</td>
<td>181</td>
</tr>
<tr>
<td>11.64</td>
<td>Newspaper Example — Assigning Flowframe Data to L Shaped Divider</td>
<td>181</td>
</tr>
<tr>
<td>11.65</td>
<td>Newspaper Example — Added Horizontal Divider</td>
<td>182</td>
</tr>
<tr>
<td>11.66</td>
<td>Newspaper Example — Assigning Flowframe Data to Horizontal Divider</td>
<td>182</td>
</tr>
<tr>
<td>11.67</td>
<td>Newspaper Example — Added Lower Header</td>
<td>183</td>
</tr>
<tr>
<td>11.68</td>
<td>Newspaper Example — Assigning Flowframe Data to Lower Header</td>
<td>184</td>
</tr>
<tr>
<td>11.69</td>
<td>Newspaper Example — Added Lower Left and Right Rectangles</td>
<td>185</td>
</tr>
<tr>
<td>11.70</td>
<td>Newspaper Example — Assigning Flowframe Data to Lower Left Rectangle</td>
<td>185</td>
</tr>
<tr>
<td>Figure Number</td>
<td>Description</td>
<td>Page</td>
</tr>
<tr>
<td>--------------</td>
<td>-----------------------------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>11.71</td>
<td>Newspaper Example — Added Sheep Bitmap</td>
<td>186</td>
</tr>
<tr>
<td>11.72</td>
<td>Newspaper Example — Assigning Flowframe Data to Sheep Bitmap</td>
<td>186</td>
</tr>
<tr>
<td>11.73</td>
<td>Newspaper Example — Added Polygon Defining Text Region</td>
<td>187</td>
</tr>
<tr>
<td>11.74</td>
<td>Newspaper Example — Computing Parshape Parameters</td>
<td>188</td>
</tr>
<tr>
<td>11.75</td>
<td>Newspaper Example — Setting the Preamble Code</td>
<td>189</td>
</tr>
<tr>
<td>11.76</td>
<td>Newspaper Example — Constructing the Footer Frame</td>
<td>190</td>
</tr>
<tr>
<td>11.77</td>
<td>Newspaper Example — Assigning the Footer Frame Data</td>
<td>191</td>
</tr>
<tr>
<td>11.78</td>
<td>Newspaper Example — Final Document</td>
<td>193</td>
</tr>
<tr>
<td>11.79</td>
<td>The Normal Font Size Setting Affects Paragraph Shapes</td>
<td>194</td>
</tr>
<tr>
<td>11.80</td>
<td>Brochure Example — Setting the Grid</td>
<td>195</td>
</tr>
<tr>
<td>11.81</td>
<td>Brochure Example — Setting the Normal Font Size</td>
<td>195</td>
</tr>
<tr>
<td>11.82</td>
<td>Brochure Example — Setting the Storage Unit</td>
<td>196</td>
</tr>
<tr>
<td>11.83</td>
<td>Brochure Example — Draw a Rectangle</td>
<td>197</td>
</tr>
<tr>
<td>11.84</td>
<td>Brochure Example — Setting the Typeblock</td>
<td>198</td>
</tr>
<tr>
<td>11.85</td>
<td>Brochure Example — Setting the Main Flow Frame</td>
<td>199</td>
</tr>
<tr>
<td>11.86</td>
<td>Brochure Example — Draw a Circle</td>
<td>200</td>
</tr>
<tr>
<td>11.87</td>
<td>Brochure Example — Change the Circle into an Arc</td>
<td>201</td>
</tr>
<tr>
<td>11.88</td>
<td>Brochure Example — Move the Arc to the Bottom Right Corner</td>
<td>202</td>
</tr>
<tr>
<td>11.89</td>
<td>Brochure Example — Apply a Fill Paint to the Arc</td>
<td>203</td>
</tr>
<tr>
<td>11.90</td>
<td>Brochure Example — Setting The Odd Footer</td>
<td>204</td>
</tr>
<tr>
<td>11.91</td>
<td>Brochure Example — Arc is Now an Odd Footer</td>
<td>205</td>
</tr>
<tr>
<td>11.92</td>
<td>Brochure Example — Flipping the Duplicate Arc</td>
<td>206</td>
</tr>
<tr>
<td>11.93</td>
<td>Brochure Example — Setting the Even Footer</td>
<td>206</td>
</tr>
<tr>
<td>11.94</td>
<td>Brochure Example — Changing the Display Page</td>
<td>207</td>
</tr>
<tr>
<td>11.95</td>
<td>Brochure Example — Even Pages Display</td>
<td>208</td>
</tr>
<tr>
<td>11.96</td>
<td>Brochure Example — Moving the Even Footer</td>
<td>209</td>
</tr>
<tr>
<td>11.97</td>
<td>Brochure Example — “all pages” display mode shows all objects in their odd-page location</td>
<td>210</td>
</tr>
<tr>
<td>11.98</td>
<td>Brochure Example — Adding a Closed Polygon</td>
<td>211</td>
</tr>
<tr>
<td>11.99</td>
<td>Brochure Example — Setting The Odd Header</td>
<td>212</td>
</tr>
<tr>
<td>11.100</td>
<td>Brochure Example — Create a Duplicate Polygon</td>
<td>213</td>
</tr>
<tr>
<td>11.101</td>
<td>Brochure Example — Setting the Even Header</td>
<td>214</td>
</tr>
<tr>
<td>11.102</td>
<td>Brochure Example — Even Pages Display (Two Objects Hidden)</td>
<td>215</td>
</tr>
<tr>
<td>11.103</td>
<td>Brochure Example — Move Even Header</td>
<td>217</td>
</tr>
<tr>
<td>11.104</td>
<td>Brochure Example — All Pages View Again (All Frames Shown in their Odd Page Position)</td>
<td>217</td>
</tr>
<tr>
<td>11.105</td>
<td>Brochure Example — Double-Page Spread View of Brochure</td>
<td>218</td>
</tr>
<tr>
<td>11.106</td>
<td>No Mouse Example — Grid Settings Dialog Box</td>
<td>219</td>
</tr>
<tr>
<td>11.107</td>
<td>No Mouse Example — Storage Unit</td>
<td>219</td>
</tr>
<tr>
<td>11.108</td>
<td>No Mouse Example — Go To Co-Ordinate Dialog Box</td>
<td>220</td>
</tr>
<tr>
<td>11.109</td>
<td>No Mouse Example — Completed Rectangle</td>
<td>220</td>
</tr>
<tr>
<td>11.110</td>
<td>No Mouse Example — Set Fill Colour Dialog Box</td>
<td>221</td>
</tr>
<tr>
<td>11.111</td>
<td>No Mouse Example — Fill Colour Set</td>
<td>222</td>
</tr>
<tr>
<td>11.112</td>
<td>No Mouse Example — Completed Triangle</td>
<td>223</td>
</tr>
<tr>
<td>11.113</td>
<td>No Mouse Example — Triangle Fill Colour Set to Red</td>
<td>223</td>
</tr>
<tr>
<td>11.114</td>
<td>No Mouse Example — Windows Added</td>
<td>224</td>
</tr>
<tr>
<td>11.115</td>
<td>No Mouse Example — Window Fill Colour Set</td>
<td>225</td>
</tr>
<tr>
<td>11.116</td>
<td>No Mouse Example — Completed House</td>
<td>225</td>
</tr>
<tr>
<td>11.117</td>
<td>No Mouse Example — Move Dialog Box</td>
<td>225</td>
</tr>
<tr>
<td>11.118</td>
<td>No Mouse Example — Edit Mode</td>
<td>226</td>
</tr>
<tr>
<td>Figure</td>
<td>Description</td>
<td>Page</td>
</tr>
<tr>
<td>--------</td>
<td>-------------</td>
<td>------</td>
</tr>
<tr>
<td>11.119</td>
<td>No Mouse Example — Edit Path Menu</td>
<td>227</td>
</tr>
<tr>
<td>11.120</td>
<td>No Mouse Example — Control Point Co-Ordinates Dialog Box</td>
<td>227</td>
</tr>
<tr>
<td>11.121</td>
<td>No Mouse Example — Editing Finished</td>
<td>227</td>
</tr>
<tr>
<td>11.122</td>
<td>No Mouse Example — Creating a New Text Area</td>
<td>228</td>
</tr>
<tr>
<td>11.123</td>
<td>No Mouse Example — Editing Text Area</td>
<td>228</td>
</tr>
<tr>
<td>11.124</td>
<td>No Mouse Example — Text is Now Centred</td>
<td>229</td>
</tr>
<tr>
<td>11.125</td>
<td>Selecting a Radial Grid</td>
<td>230</td>
</tr>
<tr>
<td>11.126</td>
<td>The Underlying Path</td>
<td>231</td>
</tr>
<tr>
<td>11.127</td>
<td>Give the Path Symmetry Using the Popup Menu</td>
<td>231</td>
</tr>
<tr>
<td>11.128</td>
<td>De-anchoring the End Control Using the Popup Menu</td>
<td>231</td>
</tr>
<tr>
<td>11.129</td>
<td>Move the Line of Symmetry</td>
<td>232</td>
</tr>
<tr>
<td>11.130</td>
<td>Add a Joining Curve Between the Underlying Path and its Reflection</td>
<td>232</td>
</tr>
<tr>
<td>11.131</td>
<td>Adjust the Curvature Control of the Join Segment</td>
<td>233</td>
</tr>
<tr>
<td>11.132</td>
<td>Change the Path Style</td>
<td>234</td>
</tr>
<tr>
<td>11.133</td>
<td>The Symmetric Path</td>
<td>235</td>
</tr>
<tr>
<td>11.134</td>
<td>Setting the Pattern</td>
<td>235</td>
</tr>
<tr>
<td>11.135</td>
<td>The Pattern</td>
<td>236</td>
</tr>
<tr>
<td>11.136</td>
<td>Move the Control Governing the Rotational Anchor</td>
<td>236</td>
</tr>
<tr>
<td>11.137</td>
<td>Add a Circle Around the Pattern</td>
<td>236</td>
</tr>
<tr>
<td>11.138</td>
<td>The Completed Lute Rose</td>
<td>236</td>
</tr>
</tbody>
</table>
1 Introduction

FlowframTk\textsuperscript{1} is a vector graphics application written in Java, with a graphical user interface (GUI). The main purpose of FlowframTk is to generate \LaTeX\ packages that are based on the flowfram package, and to generate \texttt{pgf} picture drawing code. As a side-effect, it can also be used to generate \texttt{\parshape} and \texttt{\shapepar} or \texttt{\Shapepar} specifications. In order to run the application you must have the Java Runtime Environment (JRE) installed (at least version 1.7).

In FlowframTk, you can:

- construct shapes using line, move and cubic Bézier segments;
- edit paths by modifying the defining control points;
- incorporate text and bitmap images (for annotating and background effects);
- combine text and a path to form a text along path effect;
- apply replicas to a shape to form patterns;
- extract the parameters for \LaTeX\’s \texttt{\parshape} command and for the \texttt{\shapepar} (or \texttt{\Shapepar}) command defined in the shapepar package;
- construct frames for use with the flowfram package.

Pictures can be saved as or loaded from FlowframTk’s native JDR (binary) or AJR (ascii) file formats.

Additionally, images can be exported as:

- a \LaTeX\ file containing a \texttt{pgfpicture} environment for inclusion in a \LaTeX\ document;
- a single-paged complete \LaTeX\ document containing the image;
- a \LaTeX\ package based on the flowfram package;
- a PNG file;
- a PostScript file;
- a PDF file;
- A scalable vector graphics (SVG) file.

Note that the export to PS/PDF/SVG functions use external processes, such as \texttt{latex} and \texttt{dvips}.

\textsuperscript{1}This application is a replacement for the now-obsolete Jpgfdraw (Java \texttt{pgf}-code generating \texttt{drawing} application).
1.1 Installation

Ensure that you have the JRE installed. This can be downloaded from http://java.sun.com/j2se/. You must ensure that you use at least Java 7, as FlowframTk does not work with earlier versions.

- Windows Installation:
  Download and run the file `flowframtk-0.7-setup.exe`

- Generic Installation:
  Download the installer `flowframtk-0.7-installer.jar` and run it. This can be done from a terminal or command prompt using:
  ```
  java -jar flowframtk-0.7-installer.jar
  ```

  Depending on the setup of your operating system, you may also be able to double-click on the `.jar` file to run it.
2 Accessibility

Most of FlowframTk’s mouse functions can be emulated using the keyboard, however note that some systems do not allow applications to move the pointer, so keyboard functions that move the pointer are not guaranteed to work on every system. Keyboard accelerators and their menu mnemonic equivalents are listed in Table 2.1. These accelerators may be changed using the Accelerators Tab in the Configure User Interface window. In addition, there are also keyboard accelerators for the JavaHelp system. These are listed in Table 2.2 but are not configurable as far as I know. F10 switches the focus to the menu bar.

Within editable text fields, you can use Ctrl-A to select all the text, or Shift followed by the left or right arrow key to select a portion of the text. If some of the text has been selected, you can use Ctrl-C or Ctrl-X to copy or cut the text onto the clipboard, and you can use Ctrl-V to paste text from the clipboard into the text field.

Note that a few of the accelerators used by JpgfDraw have been changed in FlowframTk, as they caused a conflict. For example, Escape cancels a displayed menu, so if you use it to dismiss a menu while you had a path under construction, the entire path could be discarded, which is undesirable. Therefore the abandon path accelerator is now Shift-Escape.

<table>
<thead>
<tr>
<th>Accelerator</th>
<th>Function</th>
<th>Menu Mnemonic</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enter</td>
<td>Finish current path/text area or Close button in dialog boxes</td>
<td>Alt-O F</td>
</tr>
<tr>
<td>Shift-Enter</td>
<td>Select Okay button in dialog boxes</td>
<td></td>
</tr>
<tr>
<td>Shift-Escape</td>
<td>Abandon current path</td>
<td>Alt-O A</td>
</tr>
<tr>
<td>Escape</td>
<td>Select Cancel button in dialog boxes or close displayed menu</td>
<td></td>
</tr>
<tr>
<td>Delete</td>
<td>Delete selected control point</td>
<td>F3 Alt-D</td>
</tr>
<tr>
<td>Backspace</td>
<td>Delete last segment (path construction mode)</td>
<td></td>
</tr>
<tr>
<td>Insert</td>
<td>Add control point or Display symbol dialog box</td>
<td>F3 Alt-A F3 Alt-I</td>
</tr>
<tr>
<td>Tab</td>
<td>Move focus to next focusable component</td>
<td></td>
</tr>
<tr>
<td>Space</td>
<td>Select component with current focus</td>
<td></td>
</tr>
<tr>
<td>PageUp</td>
<td>Scroll up by one screen full</td>
<td></td>
</tr>
<tr>
<td>PageDown</td>
<td>Scroll down by one screen full</td>
<td></td>
</tr>
<tr>
<td>Ctrl-PageDown</td>
<td>If in a tabbed pane:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Move to the next tab</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Otherwise:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Scroll right by one screen full</td>
<td></td>
</tr>
<tr>
<td>Ctrl-PageUp</td>
<td>If in a tabbed pane:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Move to the previous tab</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Otherwise:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Scroll left by one screen full</td>
<td></td>
</tr>
<tr>
<td>Arrow Keys</td>
<td>If left mouse button pressed:</td>
<td></td>
</tr>
</tbody>
</table>

*Functions that move the pointer

Continued on next page
<table>
<thead>
<tr>
<th>Accelerator</th>
<th>Function</th>
<th>Mnemonics</th>
</tr>
</thead>
<tbody>
<tr>
<td>F1</td>
<td>Display Handbook</td>
<td>Alt-H H</td>
</tr>
<tr>
<td>F2</td>
<td>Show/hide grid</td>
<td>Alt-S G S</td>
</tr>
<tr>
<td>F3</td>
<td>Show popup menu (if available for current mode)</td>
<td></td>
</tr>
<tr>
<td>F4</td>
<td>Emulate single mouse click in construction mode</td>
<td></td>
</tr>
<tr>
<td>F5</td>
<td>†Go to coordinate</td>
<td>Alt-N G</td>
</tr>
</tbody>
</table>
| F6          | Select mode: 
* move mouse by one pixel in given direction 
Otherwise: 
* scroll by one tick mark in given direction | Alt-N K |
|             | select next object in the stack | |
|             | Edit mode: 
* select next control point | F3 Alt-N |
| F7          | Select mode: 
* Move selected objects | Alt-E M |
|             | Edit mode: 
* Move selected control point | F3 Alt-R |
| F8          | Undo | Alt-E U |
| F9          | Redo | Alt-E R |
| F11         | Repaint canvas | |
| Ctrl-F11    | Saves all images to configuration directory | |
| Shift-F2    | Lock/unlock grid | Alt-S G L |
| Shift-F5    | Select next object in the stack (from the front), and deselect all others | Alt-N S |
| Shift-F6    | Select mode: 
* Add next object in the stack (from the front) to selection | Alt-N A |
|             | Edit mode: 
* select previous control point | F3 Alt-V |
| Shift-F7    | †Find selected objects | Alt-N F |
| Shift-F11   | Displays debugging information | |
| Ctrl+Shift-F11 | Writes log file in the configuration directory | |
| Alt-F4      | Quit | Alt-F Q |
| Ctrl-A      | Select all objects | Alt-E A |
| Ctrl-B      | Move selected objects to the back | Alt-E B |
| Ctrl-C      | Copy selected objects to clipboard | Alt-E C |
| Ctrl-D      | Convert outline to a path | Alt-T C |
| Ctrl-E      | Switch to ellipse tool | Alt-O E |
| Ctrl-F      | Select mode: 
* Move selected objects to the front | Alt-E F |

†Functions that move the pointer

Continued on next page
### CHAPTER 2. ACCESSIBILITY

Table 2.1: Keyboard Accelerators and Menu Mnemonics (Continued)

<table>
<thead>
<tr>
<th>Accelerator</th>
<th>Function</th>
<th>Mnemonics</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl-G</td>
<td>Find text</td>
<td>Alt-S F</td>
</tr>
<tr>
<td>Ctrl-G</td>
<td>Select mode:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Group selected objects</td>
<td>Alt-T G</td>
</tr>
<tr>
<td>Ctrl-G</td>
<td>TeX editor:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Find again</td>
<td>Alt-S A</td>
</tr>
<tr>
<td>Ctrl-H</td>
<td>Select mode:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Shear selected objects</td>
<td>Alt-T H</td>
</tr>
<tr>
<td>Ctrl-H</td>
<td>TeX editor:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Find and Replace text</td>
<td>Alt-S R</td>
</tr>
<tr>
<td>Ctrl-I</td>
<td>Edit selected path</td>
<td>Alt-E H E</td>
</tr>
<tr>
<td>Ctrl-J</td>
<td>Merge selected paths</td>
<td>Alt-T M</td>
</tr>
<tr>
<td>Ctrl-K</td>
<td>Switch to open curve tool</td>
<td>Alt-O C</td>
</tr>
<tr>
<td>Ctrl-L</td>
<td>Switch to open line tool</td>
<td>Alt-O L</td>
</tr>
<tr>
<td>Ctrl-M</td>
<td>Gap function</td>
<td>Alt-O G</td>
</tr>
<tr>
<td>Ctrl-N</td>
<td>New canvas</td>
<td>Alt-F N</td>
</tr>
<tr>
<td>Ctrl-O</td>
<td>Open JDR or AJR file</td>
<td>Alt-F O</td>
</tr>
<tr>
<td>Ctrl-P</td>
<td>Switch to select tool</td>
<td>Alt-O S</td>
</tr>
<tr>
<td>Ctrl-Q</td>
<td>Quit</td>
<td>Alt-F Q</td>
</tr>
<tr>
<td>Ctrl-R</td>
<td>Switch to rectangle tool</td>
<td>Alt-O R</td>
</tr>
<tr>
<td>Ctrl-S</td>
<td>Save current image</td>
<td>Alt-F S</td>
</tr>
<tr>
<td>Ctrl-T</td>
<td>Switch to text tool</td>
<td>Alt-O T</td>
</tr>
<tr>
<td>Ctrl-U</td>
<td>Ungroup selected groups</td>
<td>Alt-T U</td>
</tr>
<tr>
<td>Ctrl-V</td>
<td>Paste objects from clipboard</td>
<td>Alt-E P</td>
</tr>
<tr>
<td>Ctrl-W</td>
<td>Rotate selected objects</td>
<td>Alt-T R</td>
</tr>
<tr>
<td>Ctrl-X</td>
<td>Cut selected objects</td>
<td>Alt-E T</td>
</tr>
<tr>
<td>Ctrl-Y</td>
<td>Edit the selected paths’ line styles</td>
<td>Alt-E H S A</td>
</tr>
<tr>
<td>Ctrl-Z</td>
<td>Scale selected objects</td>
<td>Alt-T S</td>
</tr>
<tr>
<td>Ctrl-Shift-A</td>
<td>Deselect all</td>
<td>Alt-E D</td>
</tr>
<tr>
<td>Ctrl-Shift-B</td>
<td>Move selected object down the stack</td>
<td>Alt-E W</td>
</tr>
<tr>
<td>Ctrl-Shift-F</td>
<td>Move selected object up the stack</td>
<td>Alt-E V</td>
</tr>
<tr>
<td>Ctrl-Shift-I</td>
<td>Edit selected text</td>
<td>Alt-E X E</td>
</tr>
<tr>
<td>Ctrl-Shift-K</td>
<td>Switch to closed curve tool</td>
<td>Alt-O U</td>
</tr>
<tr>
<td>Ctrl-Shift-L</td>
<td>Switch to closed line tool</td>
<td>Alt-O I</td>
</tr>
<tr>
<td>Ctrl-Shift-T</td>
<td>Switch to maths mode tool</td>
<td>Alt-O M</td>
</tr>
</tbody>
</table>

Alt-1 . . . Alt-8 Linear gradient paint direction selectors
Alt-1 . . . Alt-9 Radial gradient paint start location selectors

See also:

- §3.2.10 User Interface Settings Dialog
- §8 Selecting and Editing Objects
- §6 Creating New Objects
- §11.9 Step-by-Step Example: A House With No Mouse
### Table 2.2: JavaHelp Viewer Shortcut Keys

<table>
<thead>
<tr>
<th>Key</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl-F1</td>
<td>Displays alternative text for the toolbar button that currently has the focus.</td>
</tr>
<tr>
<td>F6</td>
<td>Moves the focus between the navigation pane and content pane.</td>
</tr>
<tr>
<td>Tab</td>
<td>Traverses through the viewer.</td>
</tr>
<tr>
<td>Shift-Tab</td>
<td>Traverses backwards through the viewer.</td>
</tr>
<tr>
<td>Space</td>
<td>Activates the toolbar button with the current focus.</td>
</tr>
<tr>
<td>Ctrl-Space</td>
<td>Follows a link in the content pane.</td>
</tr>
<tr>
<td>F8</td>
<td>Selects the splitter bar between the navigator pane and the content pane.</td>
</tr>
<tr>
<td>Left/Right Arrow</td>
<td>If the splitter bar is selected:</td>
</tr>
<tr>
<td></td>
<td>Moves the splitter bar to the left/right</td>
</tr>
<tr>
<td></td>
<td>If in the navigator pane:</td>
</tr>
<tr>
<td></td>
<td>Moves to another navigator tab</td>
</tr>
<tr>
<td></td>
<td>If in the viewer’s toolbar:</td>
</tr>
<tr>
<td></td>
<td>Moves the focus to the next toolbar button</td>
</tr>
<tr>
<td></td>
<td>If in the content pane:</td>
</tr>
<tr>
<td></td>
<td>Moves one character to the left/right.</td>
</tr>
<tr>
<td>Up/Down Arrow</td>
<td>If the splitter bar is selected:</td>
</tr>
<tr>
<td></td>
<td>Moves the splitter bar to the left/right</td>
</tr>
<tr>
<td></td>
<td>If in the navigator pane:</td>
</tr>
<tr>
<td></td>
<td>Selects the previous/next item in the list</td>
</tr>
<tr>
<td></td>
<td>If in the content pane:</td>
</tr>
<tr>
<td></td>
<td>Moves the focus to the previous/next line.</td>
</tr>
<tr>
<td>Home</td>
<td>Selects the first item in the navigator list.</td>
</tr>
<tr>
<td>End</td>
<td>Selects the last item in the navigator list.</td>
</tr>
<tr>
<td>Ctrl-Home</td>
<td>Selects the first line in the content pane.</td>
</tr>
<tr>
<td>Ctrl-End</td>
<td>Selects the last line in the content pane.</td>
</tr>
<tr>
<td>Ctrl-T</td>
<td>Shifts focus to the next link in the content pane.</td>
</tr>
<tr>
<td>Ctrl+Shift-T</td>
<td>Shifts the focus to the previous link in the content pane.</td>
</tr>
</tbody>
</table>
3 Settings

You can customise the appearance of FlowframTk’s main window either using the command line arguments or using the settings menu.

3.1 Command Line Arguments

FlowframTk can be invoked from a command prompt using:

```
flowframtk ⟨option-list⟩ ⟨filename⟩
```

(You’ll need to add FlowframTk’s bin subdirectory to your PATH environment variable.)

Note that ⟨option-list⟩ and ⟨filename⟩ may be omitted. Only one filename is permitted, and it must be either a JDR or an AJR file. This script uses the environment variable JDR_JVMOPTS to pass options to the Java Virtual Machine (JVM). For example, if you want to run FlowframTk with a maximum size of 128Mb for the memory allocation pool, you can set JDR_JVMOPTS to -Xmx128m:

```
setenv JDR_JVMOPTS -Xmx128m
```

The flowframtk script also uses the environment variable FLOWFRAMTK_OPTS to pass options to FlowframTk.¹ For example, if you always want FlowframTk to start up with the grid showing, you can set FLOWFRAMTK_OPTS to -show_grid:

```
setenv FLOWFRAMTK_OPTS -show_grid
```

Note that these environment variables only have an effect if you use the flowframtk script to run the JRE.

If you can’t use the flowframtk script, you can invoke FlowframTk from the command line using (no line breaks):

```
java ⟨java options⟩ -jar flowframtk.jar ⟨flowframtk options⟩ ⟨filename⟩
```

(You may need to include the full pathname to flowframtk.jar.)

The following options are provided:

- **-disable_print** Don’t request printer attributes on startup.
- **-nodisable_print** Request printer attributes on startup (default).
- **-show_grid** Show the grid.
- **-noshow_grid** Don’t show the grid.
- **-grid_lock** Set the grid lock on.
- **-nogrid_lock** Don’t set the grid lock.
- **-toolbar** Show the toolbars.

¹If you have previously used Jpgfdraw, the JPGFDRAW_OPTS environment variable will also be recognised, but any settings in FLOWFRAMTK_OPTS will override those in JPGFDRAW_OPTS.
3.2 THE SETTINGS MENU

-notoolbar Don’t show the toolbars.

-statusbar Show the status bar.

-nostatusbar Don’t show the status bar.

-rulers Show the rulers.

-norulers Don’t show the rulers.

-paper Set the paper size. This option must be followed by a string identifying the paper size. Known paper sizes are listed in Table 3.1. Custom sizes can be specified using -paper user (width) (height), where (width) and (height) must be positive dimensions. Recognised units: pt, bp, in, mm, cm, pc, dd and cc. If the unit is omitted, bp is assumed. Examples:

- -paper a4r
- -paper user 8.5in 12in
- -paper user 600 1000

-experimental Enables experimental functions for testing purposes. These functions don’t work properly and are not documented.

-noexperimental Disables experimental functions. (Default.)

-debug Enables the debug menu. This menu provides the functions: Debug → Object Info (which displays diagnostic information about the currently selected objects), Debug → Write Log (which writes diagnostic information for all currently open images to a log file in the configuration directory) and Debug → Dump All (which saves all current images to a subdirectory of the configuration directory).

-nodebug Disables the debug menu (default). However you can still use Shift-F11 and Ctrl-F11 to do the same action as Debug → Write Log and Debug → Dump All, respectively.

-version Prints the current version to standard output. (Synonyms -v and --version are also available.)

-help Prints available command line options to standard output. (Synonyms -h and --help are also available.)

3.2 The Settings Menu

While FlowframTk is running, you can change the current settings using the Settings menu. Most of the settings will be remembered next time you use FlowframTk, but may be overridden either by command line arguments or by settings specified in any JDR or AJR file that you load.

If you have selected Use default settings on start up in the Startup Settings tab of the Configure Image Settings dialog, then most of the settings will not be remembered.
Table 3.1: Paper size identifiers for use with \texttt{paper} command line switch.

<table>
<thead>
<tr>
<th>Paper size</th>
<th>Portrait</th>
<th>Landscape</th>
</tr>
</thead>
<tbody>
<tr>
<td>a10</td>
<td>A10</td>
<td>a10r</td>
</tr>
<tr>
<td>a9</td>
<td>A9</td>
<td>a9r</td>
</tr>
<tr>
<td>a8</td>
<td>A8</td>
<td>a8r</td>
</tr>
<tr>
<td>a7</td>
<td>A7</td>
<td>a7r</td>
</tr>
<tr>
<td>a6</td>
<td>A6</td>
<td>a6r</td>
</tr>
<tr>
<td>a5</td>
<td>A5</td>
<td>a5r</td>
</tr>
<tr>
<td>a4</td>
<td>A4</td>
<td>a4r</td>
</tr>
<tr>
<td>a3</td>
<td>A3</td>
<td>a3r</td>
</tr>
<tr>
<td>a2</td>
<td>A2</td>
<td>a2r</td>
</tr>
<tr>
<td>a1</td>
<td>A1</td>
<td>a1r</td>
</tr>
<tr>
<td>a0</td>
<td>A0</td>
<td>a0r</td>
</tr>
<tr>
<td>b10</td>
<td>B10</td>
<td>b10r</td>
</tr>
<tr>
<td>b9</td>
<td>B9</td>
<td>b9r</td>
</tr>
<tr>
<td>b8</td>
<td>B8</td>
<td>b8r</td>
</tr>
<tr>
<td>b7</td>
<td>B7</td>
<td>b7r</td>
</tr>
<tr>
<td>b6</td>
<td>B6</td>
<td>b6r</td>
</tr>
<tr>
<td>b5</td>
<td>B5</td>
<td>b5r</td>
</tr>
<tr>
<td>b4</td>
<td>B4</td>
<td>b4r</td>
</tr>
<tr>
<td>b3</td>
<td>B3</td>
<td>b3r</td>
</tr>
<tr>
<td>b2</td>
<td>B2</td>
<td>b2r</td>
</tr>
<tr>
<td>b1</td>
<td>B1</td>
<td>b1r</td>
</tr>
<tr>
<td>b0</td>
<td>B0</td>
<td>b0r</td>
</tr>
<tr>
<td>c10</td>
<td>C10</td>
<td>c10r</td>
</tr>
<tr>
<td>c9</td>
<td>C9</td>
<td>c9r</td>
</tr>
<tr>
<td>c8</td>
<td>C8</td>
<td>c8r</td>
</tr>
<tr>
<td>c7</td>
<td>C7</td>
<td>c7r</td>
</tr>
<tr>
<td>c6</td>
<td>C6</td>
<td>c6r</td>
</tr>
<tr>
<td>c5</td>
<td>C5</td>
<td>c5r</td>
</tr>
<tr>
<td>c4</td>
<td>C4</td>
<td>c4r</td>
</tr>
<tr>
<td>c3</td>
<td>C3</td>
<td>c3r</td>
</tr>
<tr>
<td>c2</td>
<td>C2</td>
<td>c2r</td>
</tr>
<tr>
<td>c1</td>
<td>C1</td>
<td>c1r</td>
</tr>
<tr>
<td>c0</td>
<td>C0</td>
<td>c0r</td>
</tr>
<tr>
<td>letter</td>
<td>Letter</td>
<td>letterr</td>
</tr>
<tr>
<td>legal</td>
<td>Legal</td>
<td>legalr</td>
</tr>
<tr>
<td>executive</td>
<td>Executive</td>
<td>executiver</td>
</tr>
</tbody>
</table>
3.2.1 Styles
Settings → Styles can be used to set the current path and text area attributes. New paths and text areas will use these attributes when they are created. The attributes for existing paths and text areas are changed using the Edit menu. These settings are discussed in more detail in chapter 9.

3.2.2 Show Tools
Settings → Show Tools will toggle between showing and hiding the toolbars.

See also:
• §4 Toolbar and Ruler Settings

3.2.3 Show Rulers
Settings → Show Rulers will toggle between showing and hiding the rulers.

See also:
• §4 Toolbar and Ruler Settings

3.2.4 Show Status Bar
Settings → Show Status Bar will toggle between showing and hiding the status bar.

3.2.5 Grid
The Settings → Grid submenu allows you to change the grid settings:

- Settings → Grid → Show Grid will toggle between displaying the grid on the canvas and hiding it. If there is enough memory available, the grid will be stored as a bitmap in order to improve redraw speed.

- Settings → Grid → Lock Grid will toggle between locking and unlocking the grid. If the grid is locked, mouse clicks will be translated to the nearest tick mark. This means that if you use a mouse click to set the location of a control point when constructing a path, the point will be placed at the nearest tick mark. This also means that when you move a point while in edit mode, the point will be moved in intervals of the gap between tick marks. Note that locking the grid does not affect the keyboard or menu driven functions, such as Navigate → Go To (F5) or emulate a mouse click (F4).

When the grid is locked, the status bar will show the image ⬤ ⬤ otherwise it will show the image ⬤ .

Warning: if you lock the grid, you will be unable to use the mouse to select narrow paths that lie between tick marks as mouse clicks will be translated to the nearest tick mark, unless you use the drag rectangle (which may select other objects as well). Similarly, if the size of the control points is less than the gap between the tick marks, you will not be able to select control points using the mouse whilst in edit mode. (You will however be able to select them using the Next Control (F6) of Previous Control (Shift-F6) popup menu item.)
3.2.6 ZOOM

- **Settings → Grid → Grid Settings** will produce a dialog box in which you can specify the position of the tick marks and the units used. Available grid types:
  - a rectangular grid with the origin at the top left hand corner of the canvas (Figure 3.1(a));
  - a radial grid with the origin at the centre of the canvas (Figure 3.1(b));
  - an isometric grid with the origin at the top left hand corner of the canvas where the major divisions indicate the length of each side of the equilateral triangles forming the grid (Figure 3.1(c));
  - a typesetting grid after Tschichold (see [3, p. 40]). This is the only grid that checks the display page setting. If an even numbered page is displayed, the verso grid is shown (Figure 3.2(a)), otherwise the recto grid is shown (see Figure 3.2(b)). The recto grid is used for the default All Pages setting. Note that you are limited to only fourteen locations if you have the grid lock on. The settings for this grid style are the same as for the rectangular grid and are only applied to the rulers. The origin is the top left corner of the canvas for both the recto and verso displays.

*Note:* the grid unit is independent of the storage unit. However, it’s a good idea to choose a grid unit and storage unit that have a convenient conversion factor between them. For example, mm storage unit and cm grid unit. Regardless of the grid used, co-ordinates are always stored as left-handed rectangular co-ordinates where the origin is at the top left. This may cause slight rounding errors in the conversion between rectangular and radial co-ordinates. If you are using a radial grid and you change the paper size or orientation, the grid origin will shift but the objects will maintain their original positions relative to the top left corner of the canvas.

### 3.2.6 Zoom

The **Settings → Zoom** submenu allows you to change the magnification. You can choose one of the predefined settings or you can specify an arbitrary setting using **Settings → Zoom → User Defined**. This dialog box should have the actual magnification factor entered, not the percentage. For example, 300% magnification should be entered as 3.

### 3.2.7 Paper

The **Settings → Paper** submenu allows you to change the paper size and orientation. In addition, **Settings → Paper → Show Margins** toggles between showing and hiding the printer margins, but note that this facility is not available if you use the `disable_print` command line argument.

The predefined paper sizes A0 to A5, letter, legal and executive can be selected from the **Settings → Paper** menu. Other paper sizes can be selected from the dialog box displayed using **Settings → Paper → Other**. Select the radio button labelled Predefined to enable a list of additional known paper sizes or select the radio button labelled User to enter a custom size.
3.2.7 PAPER

Figure 3.1: Available regular grids: (a) rectangular grid; (b) radial grid; (c) isomorphic grid
3.2.8 Image Settings Dialog

The Settings → Configure Image Settings menu item opens the Configure Image Settings dialog box, which can be used to change image settings. (§3.2.9 TeX Settings Dialog covers \TeX/\LaTeX related settings and §3.2.10 User Interface Settings Dialog covers settings related to the user interface.)

Control Point Settings

The Control Points tab (Figure 3.3) allows you to:

- set the size of the control points;
- specify whether the control point size should be affected by the zoom setting;
- set the storage unit.

It’s best to set the storage unit before you start creating an image. If the selected canvas isn’t empty, all objects will have their co-ordinates recomputed in terms of the new unit, which may take a while if there are many objects or paths with many segments.

Startup Directory

The Startup Directory tab (Figure 3.4) allows you to choose which directory FlowframTk should use as the current working directory when it starts up. You have a choice of:

- the current working directory that you were in when you started up FlowframTk;
- the directory you were using when you last used FlowframTk;
- a specific directory. In this case, type in the path in the box labelled Use this directory: or use the Browse button to select the required directory.

Figure 3.2: Tschichold grid: (a) verso (even pages); (b) recto (odd pages)
If you change the storage unit, all coordinates in the current frame will be converted to the new storage unit. This may take a while if you have a large or complex image, so it's generally best to set the storage unit before you start your image. The storage unit is independent of the grid unit. Some settings, such as line width or font size, are independent of the storage unit.

Figure 3.3: Configuration Dialog Box (Control Point Settings)
Figure 3.4: Configuration Dialog Box (Startup Directory Settings)
3.2.8 IMAGE SETTINGS DIALOG

**JDR/AJR Settings**

![Configuration Dialog Box (JDR/AJR Settings)](image)

You can use the JDR/AJR Settings tab (Figure 3.5) to specify whether or not you want the current canvas settings stored in the JDR or AJR file when you save your image. You can also choose whether or not you want to apply any canvas settings information stored in any JDR or AJR file that you load. The canvas settings consist of: grid show/hide, grid locked/not locked, rulers displayed/not displayed, the tool in use, the LaTeX normal size, the paper size, the grid style, the size of the control points and whether they should be affected by the magnification setting.

**Startup Settings**

You can use the Startup Settings tab (Figure 3.6) to choose whether you want FlowframTk to start with its default settings, or whether to restore the settings from the last time you used FlowframTk, or whether to use the settings that are currently in use. If you choose the default settings option, the only settings that will be remembered are: the dictionary language, the language setting for the manual, whether or not the robot is enabled (the function that allows the pointer to be moved without the mouse), the application paths for the external applications needed by some of the export functions, and the Unicode blocks for the symbol selector. These settings are all saved in the file flowframtk.conf in the configuration directory.

Mappings, accelerators and the recent file list aren’t governed by the startup setting.
3.2.8 IMAGE SETTINGS DIALOG

Figure 3.6: Configuration Dialog Box (Startup Settings)
### 3.2.8 IMAGE SETTINGS DIALOG

#### Bitmap Settings

![Figure 3.7: Configuration Dialog Box (Bitmap Settings)](image)

You can use the Bitmaps tab (Figure 3.7) to choose whether included bitmaps should be saved using their full path name or a path name relative to the file being saved. Relative names allow for greater portability, but if you move the saved file to a different location, you will need to remember to move the bitmap files relative to the new location or they won’t be found.

You can also use this tab to specify your preferred default image command, which may be either `\pgfimage` or `\includegraphics`.

#### Application Paths

If you export your image to PDF, EPS or SVG, FlowframTk will first save the image as an encapsulated \LaTeX document and will then run external applications to create the desired file format. In order to do this, FlowframTk needs to know the correct paths to these applications. It will try to find them from your system’s PATH environment variable, but if it can’t find them you can use the Application Paths tab (Figure 3.8) to set their locations. The `libgs` library is needed by dvisvgm, so you only need it if you intend to export to SVG.

To reduce the chance of zombie processes, each process is run with a timer that will kill the process if it exceeds the value specified in the box labelled Time-out.
Figure 3.8: Configuration Dialog Box (Application Paths)
3.2.9 TeX Settings Dialog

The menu item Settings → Configure TeX/LaTeX Settings will open up a dialog box in which you can adjust the TeX/LaTeX settings. (§3.2.8 Image Settings Dialog covers image settings and §3.2.10 User Interface Settings Dialog covers user interface settings.)

Setting the Document Class and Normal Font Size

Most of FlowframTk’s TeX/LaTeX related functions (including the export function) require a value corresponding to \texttt{\textbackslash normalsize} (the LaTeX command that sets the normal font size). A text area needs to know the normal font size to determine the appropriate font size declaration (see §9.5.2 Font Size). In addition, both the \texttt{parshape} and \texttt{shapepar} functions use the value of \texttt{\textbackslash baselineskip} for the normal font size in order to determine the location of the scan lines used to compute the required parameters. This also means that any static or dynamic frames that use a non-standard paragraph shape also require this information.

![TeX/LaTeX Settings Dialog](image)

Figure 3.9: Setting the Normal Font Size and (optionally) the Class

The normal font size can be set using the Document Settings tab (Figure 3.9). Select the required value from the drop-down list and select Okay to set it. Note that you must remember to use this value in your document. For example, if you set the normal size as 20, your document will need to use one of the extsizes class files, e.g. \texttt{extarticle}, and specify \texttt{20pt} as one of the optional arguments:
Note that the largest normal size listed (25pt\textsuperscript{2}) is for use with the a0poster class file. Remember that for very large or very small fonts, you will need to use scalable fonts in your document to prevent font size substitutions. Available values, along with the corresponding value of $\backslash$baselineskip and the file in which they are defined, are listed in Table 3.2.

Table 3.2: Available values for the normal font size, the corresponding value and the file in which they are defined (relative to the TEXMF tree).

<table>
<thead>
<tr>
<th>Normal size value</th>
<th>$\backslash$baselineskip value</th>
<th>Relevant File</th>
</tr>
</thead>
<tbody>
<tr>
<td>8</td>
<td>9.5</td>
<td>tex/latex/extsizes/size8.clo</td>
</tr>
<tr>
<td>9</td>
<td>11</td>
<td>tex/latex/extsizes/size9.clo</td>
</tr>
<tr>
<td>10</td>
<td>12</td>
<td>tex/latex/base/size10.clo</td>
</tr>
<tr>
<td>11</td>
<td>13.6</td>
<td>tex/latex/base/size11.clo</td>
</tr>
<tr>
<td>12</td>
<td>14.5</td>
<td>tex/latex/base/size12.clo</td>
</tr>
<tr>
<td>14</td>
<td>17</td>
<td>tex/latex/extsizes/size14.clo</td>
</tr>
<tr>
<td>17</td>
<td>22</td>
<td>tex/latex/extsizes/size17.clo</td>
</tr>
<tr>
<td>20</td>
<td>25</td>
<td>tex/latex/extsizes/size20.clo</td>
</tr>
<tr>
<td>25</td>
<td>30</td>
<td>tex/latex/a0poster/a0poster.sty</td>
</tr>
</tbody>
</table>

If the checkbox labelled Update all LaTeX font size declarations in current image is selected, changing the normal size setting in this dialog will update the $\LaTeX$ font size settings for all the text areas in the current image.

If you want to export your image to a complete $\LaTeX$ document, the document class will default to:

- article, if the normal size is set to 10, 11 or 12;
- a0poster, if the normal size is set to 25;
- extarticle, otherwise.

If you want to use a different document class, select the radio button Use class: , which will enable the field where you can type the require class name (without the .cls extension). You need to ensure the class supports your specified normal font size (as a standard option, not a key=value option).

The document class is also used as the base class with the export to document function, and is used for all export functions that use the export to encapsulated $\LaTeX$ document function as an intermediate step.

The Use relative font size declarations checkbox governs the suggested $\LaTeX$ font size command when you change the font size setting for text areas. If this checkbox is selected, FlowframTk will attempt to select a font size declaration, such as $\backslash$large, according to the current normalsize setting. Otherwise, $\backslash$setfontsize will be used. If the font size is significantly larger than the largest available declaration, $\backslash$setfontsize will be used regardless of this setting.

The Add $\backslash$pdffinfo to exported $\LaTeX$ documents checkbox governs whether or not to add $\backslash$pdffinfo to exported $\LaTeX$ documents. If the image has a description, this will be added to the /Title attribute. The only other attribute that is set is the /CreationDate attribute. This setting is not used for the export to PostScript or SVG functions as they use latex rather than pdflatex.

\footnote{this value is actually 24.88pt, but FlowframTk lists it as 25pt.}
3.2.9 TEX SETTINGS DIALOG

Flowframe Settings

The Flowframe Settings tab (Figure 3.10) allows you to adjust the flowfram related settings.

![Flowframe Settings Tab](image)

Figure 3.10: Flowframe Settings Tab

The flowfram package now allows you to use absolute pages numbers in the page list rather than using the value of the page counter. For example, if your document pages are numbered a, b, i, ii, iii, 1, 2, 3, then with the absolute setting page number 3 refers to the page labelled i whereas with the relative setting page number 3 refers to both the page labelled iii and the page labelled 3. (See the flowfram documentation for further details.) If you want to use the absolute setting, select the button labelled absolute otherwise select the button labelled relative.

The shapepar package now has a command called \Shapepar that behaves slightly differently to \shapepar. Since \Shapepar works better than \shapepar when used with the flowframe package, FlowframTk defaults to using \Shapepar for the TeX/LaTeX → Shapepar function or when a static or dynamic frame has the shape set to Shapepar. However, if you prefer the original \shapepar command, selected the appropriate shapepar command: radio button. If you want to use \Shapepar, you need to ensure you have up-to-date versions of the flowfram and shapepar packages. This setting applies both to frames with the Shapepar shape setting and to the TeX/LaTeX → Shapepar function.
3.2.9 TEX SETTINGS DIALOG

Text Settings

The LaTeX Text Settings tab (Figure 3.11) allows you to adjust the text-related settings.

- If the Auto Adjust Anchor checkbox is selected, whenever you justify a group, any text areas in that group will have their anchors automatically adjusted.

- FlowframTk can’t implement paint shadings for text when exporting to pgf. (This includes the export functions that use latex or pdflatex, such as the export to PDF function.) You can choose how FlowframTk should export shaded text using the When exporting text with shadings: dropdown box. Available options:
  
  **Average Colours** The text will be given the colour obtained by averaging the shading’s start and end colour.
  
  **Use Start Colour** Just the shading’s start colour will be used.
  
  **Use End Colour** Just the shading’s end colour will be used.

- FlowframTk can’t implement the text outline option for text-paths when exporting to pgf. (Again, this includes the export functions that use latex or pdflatex.) You can choose how FlowframTk should export text-path outlines using the When exporting text-paths with outlines: dropdown box. Available options:
  
  **Convert to Path** The text-path will be exported as a path rather than a text-path. This means that the \LaTeX alternative text attribute will be ignored. This is equivalent to applying the convert to path, ungroup and merge path functions (without actually changing your image).

- FlowframTk has two tools for creating text areas: the regular text mode tool (Tools → Text) and the maths mode tool (Tools → Maths). Each text area has an associated \LaTeX alternative text which, if set, is used during the pgf export operations in place of the text displayed on the canvas. (This includes the export functions that use latex or pdflatex, such as the export to PDF function.) The maths mode tool automatically inserts the maths-shift dollar symbols $ at the start and end of the alternative text. In addition, certain Unicode symbols present in the text when a new text area is constructed can be mapped to a \LaTeX command.

  The mappings applied depend on which tool has been selected. With the regular text mode tool, all the ten \TeX special characters are mapped to commands. In addition, there are some other characters, such as currency symbols, that are also mapped. These are listed in the table shown in the Text Mode area of the LaTeX Text Settings tab. If you don’t want these mappings applied, deselect the Auto escape text symbols checkbox. With the maths mode tool, the hash # and percent % characters are the only two of the ten \TeX special characters that are mapped. However there are many other mappings of maths-related Unicode characters and these are listed in the table shown in the Maths Mode area of the LaTeX Text Settings tab. If you don’t want these mappings applied, deselect the Auto escape maths symbols checkbox.

Figure 3.11: LaTeX-Related Text Settings
You can add, delete or modify any of these text or maths mode mappings. To add a new mapping, click on the green plus button to the side of the relevant table. This will open the add new mapping dialog. Enter the character you want mapped in the Symbol box or type the hexadecimal value in the Code Point box and then enter the replacement command in the Command box. If the command is defined in a package, enter the package name (without the .sty extension) in the Package box. If the mapping requires multiple commands from different packages, you can specify a comma-separated list of packages in the Package box. If the replacement command is available in the \LaTeX kernel, you can leave this box blank. (These packages will be automatically added to the image’s preamble code, whenever the mapping is applied.)

For example, in Figure 3.12 the new mapping dialog is being used to define a new text mapping from the Unicode dagger † symbol (U+2020) to the \textdagger command. Since this command is defined in the \LaTeX kernel, the package field can be left empty. The Unicode symbol can be specified either by typing the hexadecimal code into the Code Point field or by typing the actual symbol into the Symbol field.

![Add new text mapping](image)

Figure 3.12: Adding a New Text Mapping

To edit an existing mapping, double-click on the second and third columns of the mapping table. The first two columns can’t be edited. You can delete a mapping by selecting the appropriate row of the mapping table and clicking on the red minus button to the side of the table. To restore all the original mappings, quit FlowframTk and delete or rename the files mathmappings.prop and textmappings.prop in the configuration directory.

The mapping tables can be sorted by clicking on their column headers.

### 3.2.10 User Interface Settings Dialog

The menu item Settings → Configure User Interface will open up a dialog box in which you can adjust the user interface settings. (§3.2.8 Image Settings Dialog covers image settings and §3.2.9 TeX Settings Dialog covers \TeX/\LaTeX related settings.)

#### Graphics Settings

The Graphics tab (Figure 3.13) allows you to:

- choose between using or not using anti-aliasing to display the graphics;
- choose between speed or quality in the rendering;
- set the colour for the different types of control points;
- set the font used for annotating frames or draft bitmaps.
Figure 3.13: Configuration UI Dialog Box (Graphics Settings)
You can also use this tab to choose between enabling and disabling hotspots along the bounding boxes. If hotspots are enabled, you can scale, rotate or shear objects by dragging the appropriate hotspot. (Note that transforming composite shapes applies the transformation to the underlying shape not to the shape as a whole.)

You may want to disable this option when you want to move small objects, or you may end up transforming them instead of moving them. When this option is enabled, the cursor will change shape\(^3\) when you move it over the edge of the bounding box. Figure 3.14(a) shows how the bounding box is displayed when hotspots are enabled and Figure 3.14(b) shows how the bounding box is displayed when the hotspots have been disabled. Each hotspot is represented by a small square. Available functions are listed in Table 3.3.

Table 3.3: Hotspot Functions

<table>
<thead>
<tr>
<th>Hotspot</th>
<th>Function</th>
<th>Cursor Appearance</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bottom left</td>
<td>rotate</td>
<td>hand</td>
</tr>
<tr>
<td>Bottom centre</td>
<td>scale vertically</td>
<td>South arrow</td>
</tr>
<tr>
<td>Bottom right</td>
<td>scale both directions</td>
<td>South-East arrow</td>
</tr>
<tr>
<td>Middle right</td>
<td>scale horizontally</td>
<td>East arrow</td>
</tr>
<tr>
<td>Top right</td>
<td>shear vertically</td>
<td>North arrow</td>
</tr>
<tr>
<td>Top left</td>
<td>shear horizontally</td>
<td>West arrow</td>
</tr>
</tbody>
</table>

Note that even if you have more than one object selected, only the object whose hotspot you are dragging will be transformed. As may be predicted, using hotspots is not as precise as using the transformation dialog boxes described in chapter 8.

Language Settings

You can use the Languages tab (Figure 3.13) to set which language to use for the application resources (menus, messages etc) and which language to use for the manual. These settings will not be applied until you quit and restart FlowframTk. Currently the only available resource languages are: en-GB, en-US and zh, and the only available manual languages are: en-GB and en-US.

---

\(^3\)The actual cursor appearance depends on the look and feel of the platform you are using. On some systems the South and North arrows may look the same, and similarly for the East and West arrows.
Figure 3.15: Configuration UI Dialog Box (Language Settings)
You can also use the Languages tab to specify the Unicode blocks to display in the symbol selector. By default, only a limited subsection of Unicode characters are available because it would significantly slow FlowframTk’s startup process to provide all possible Unicode characters. To add a new block, click on the green plus button next to the table. To remove an unwanted block, select the appropriate row in the table and click on the red minus button. The start and end values don’t need to match a complete Unicode block and may span multiple blocks. For example, suppose you regularly want to enter musical symbols into your image, then you can add a block starting from 1D100 and ending at 1D1DD. You need to quit and restart FlowframTk for the changes to take effect. If you want to restore the defaults, quit FlowframTk, open the file flowframtk.conf in the configuration directory and remove the line starting with unicode=

See also:

• §B Multilingual Support

Accelerator Settings

You can use the Accelerators tab (Figure 3.16) to change the default accelerators (keyboard shortcuts). It’s possible to use the same keystroke for different actions provided the actions are never both enabled at the same time. (For example, F6 selects the next control in path edit mode or adjust the selection select mode.)

Note: Java’s accessibility API uses F10 to switch the focus to the menu bar, so avoid using this key for an accelerator.

Suppose you want to change the accelerator for the Undo function from the default F8 to, say, Ctrl+Shift-U. Find the appropriate row in the accelerator table and double-click on it to open the Set Accelerator dialog box (Figure 3.17).

There are two ways to change the keystroke. If the Use Selector button is selected, you can select or deselect the required modifiers (such as Shift) and use the drop-down box to select the keystroke. So to change the keystroke to Ctrl+Shift-U, select the Shift and Ctrl buttons and set the drop-down box to pressed U. Alternatively, if the Use Key Stroke button is selected you can type the required keystroke in the Enter Key Stroke: field. Care must be taken with this option. You need to make sure you release the main key before releasing the modifiers. For example, press down the control, shift and U keys but release the U key before releasing the control and shift keys. Note that the Tab key retains its usual function of moving the focus to the next component in the window, and so can’t be typed in the Enter Key Stroke: field. (Neither can certain other keys that are always intercepted by the operating system.) The Enter key, on the other hand, will be picked up by the Enter Key Stroke: field if it has the focus, so you need to ensure you move the focus to a different component if you want to use Enter to activate the “Okay” button.

The accelerator settings are written to a file called accelerators.prop in the configuration directory when FlowframTk quits normally. You may edit this file using your preferred text editor to change the settings as long as FlowframTk isn’t currently running. For example, if you want to change all the keystrokes that require the control key to be pressed to requiring the meta key pressed instead, you may find it easier to do a global search and replace in accelerators.prop of ctrl with meta. If you do edit this file, make sure you only edit the values to the right of the = sign. To restore the default accelerators, delete or rename this file (when FlowframTk isn’t running).
### USER INTERFACE SETTINGS DIALOG

Figure 3.16: Configuration UI Dialog Box (Accelerators)
3.2.10 USER INTERFACE SETTINGS DIALOG

Figure 3.17: Changing a keyboard shortcut.

**Toolbar and Ruler Settings**

You can use the Rulers and Toolbar tab to change the appearance of the rulers and toolbar. The vertical toolbar is located on the left of FlowframTk’s main window by default, but can be switched to the right by selecting the Right radio button. You will need to quit and restart for the change to take effect.

The width (in pixels) of the vertical ruler can be specified in the Vertical Ruler Width: field, and the height (in pixels) of the horizontal ruler can be specified in the Horizontal Ruler Height: field. For example, if you find that the \( y \) co-ordinates don’t fit on the vertical ruler, you can make the ruler wider, say, to 30 pixels. The way the co-ordinates appear on the rulers is governed by the Number format: field. The pattern syntax is as for java.text.DecimalFormat, described in the Java API ([http://docs.oracle.com/javase/7/docs/api/java/text/DecimalFormat.html](http://docs.oracle.com/javase/7/docs/api/java/text/DecimalFormat.html)). You can also set the locale governing the pattern, but this pattern is only applied to the rulers, not to the co-ordinate dialog boxes or status bar.

Any of these changes made to the rulers will apply to new canvases, but not to images that are already open.

**Normalization**

When an image is drawn on the canvas via Java’s painting methods, the co-ordinates of all the objects are converted into PostScript points (including any scaling applied by the zoom settings). However, it is rare for any display device, such as a standard monitor, to have pixels that are exactly one PostScript point square in size. This means that a 1in (or 72bp) line drawn on the screen at 100% magnification may not actually measure 1in if you hold a ruler up against the screen. This is fairly typical for most graphical applications however, if it bothers you, you can adjust the horizontal and vertical normalization factors used by FlowframTk in the Normalization tab (Figure 3.19).

If you happen to already know the normalization factors for your device, you can enter them in the X Normalize Factor: and Y Normalize Factor: fields. If you don’t know them, FlowframTk can compute them for you. To do this, you need to hold a ruler against the Unnormalized Horizontal line, enter the measurement in the length field below the line and click on the Compute X Norm button. This will insert the
Figure 3.18: Configuration UI Dialog Box (Ruler Settings)
Due to the varied nature of display units, 1 inch (or 72 PostScript points) displayed on the screen at 100% magnification may not actually measure 1 inch if you hold a ruler up to your screen. You can compensate for this by setting the horizontal and vertical normalization factors. If you already know these factors you can type them into the boxes below (or set them both to 1 to remove normalization):

- **X Normalize Factor**: 1.0
- **Y Normalize Factor**: 1.0

Alternatively, you can hold your ruler up against the unnormalized horizontal and vertical lines, enter their measurements in the boxes and click on the 'Compute' buttons below.

Unnormalized Horizontal  Unnormalized Vertical

- **Unnormalized Horizontal**: 1.0 in
- **Unnormalized Vertical**: 1.0 in

**Compute X Norm**  **Compute Y Norm**

Normalized Lines

Figure 3.19: Configuration UI Dialog Box (Normalization)
normalization factor into the \texttt{X Normalize Factor:} field. Next, hold the ruler against the \texttt{Unnormalized Vertical line}, enter the measurement in the length field below that line and click on the \texttt{Compute Y Norm} button. This will insert the normalization factor into the \texttt{Y Normalize Factor:} field. You then need to click on the \texttt{okay} button to set these normalization factors.

\textbf{TeX Editor Settings}

\texttt{FlowframTk} has a small text editor that’s opened when you want to edit the preamble text or the contents of a static or dynamic frame. The font used by this editor can be changed in the \texttt{TeX Editor} tab (Figure \ref{fig:settings}). You can also set the default width (in terms of approximate number of characters per line) and the default height (in terms of lines) for the editor when it’s first created at startup. You can also enable or disable syntax highlighting by selecting or deselecting the button marked Syntax highlighting. If selected, you can also set the colour used for comments (indicated by \LaTeX’s \texttt{\%} comment character) or for commands. The editor currently doesn’t have any spell-checking support.

\section{Configuration Directory}

When you quit \texttt{FlowframTk}, the settings will be saved in \texttt{FlowframTk}’s configuration directory. This directory is determined (and created if necessary) as follows:

- If the environment variable \texttt{JDRSETTINGS} exists and is a directory, that directory is used.
- If \texttt{FlowframTk} detects the existence of Jpgfdraw’s configuration directory, that will be used. If the file \texttt{jpgfdraw.conf} exists in that directory but the file \texttt{flowframtk.conf} doesn’t exist, \texttt{FlowframTk} will load the settings from \texttt{jpgfdraw.conf} and then save the new settings to \texttt{flowframtk.conf}. If you like, after you have quit \texttt{FlowframTk}, you can remove the file \texttt{jpgfdraw.conf} and rename the directory \texttt{.flowframtk} or \texttt{flowframtk-settings}, as appropriate.
- If the directory \texttt{\langle home\rangle/.flowframtk} exists and is a directory, that directory is used (where \texttt{\langle home\rangle} indicates the user’s home directory as given by the Java \texttt{user.home} property).
- If the directory \texttt{\langle home\rangle/flowframtk-settings} exists and is a directory, that directory is used.
- If the operating system is a version of Windows and the directory \texttt{\langle home\rangle/flowframtk-settings} can be created, that directory is used.
- For other operating systems, if the directory \texttt{\langle home\rangle/.flowframtk} can be created, that directory is used.
- If the directory \texttt{settings/\langle user\rangle} or \texttt{settings} can be created in \texttt{FlowframTk}’s installation directory, that directory will be used (where \texttt{\langle user\rangle} is the current user’s user name). This is sub-optimal and not recommended as it may be removed when upgrading to a new version.
The (La)TeX editor is used by the edit preamble function and the edit frame contents function.

- **Font**: Monospaced
- **Font Size**: 12
- **Default Width**: 8
- **Default Height**: 10
- **Syntax highlighting**
- **Comment colour**
- **Control Sequence colour**

Figure 3.20: Configuration UI Dialog Box (TeX Editor Settings)
If none of the above, an error will occur and you will need to set the environment variable JDRSETTINGS to a sensible location with read and write permissions.

The configuration directory may also contain:

- the list of recent files (written by FlowframTk when it quits normally);
- the accelerator settings aerators.prop (written by FlowframTk when it quits normally);
- the maths-mode and text-mode character mapping files, mathmappings.prop and textmappings.prop (written by FlowframTk when it quits normally);
- the preamble file preamble.tex (created by you, if you want it, in any text editor) used by some of the export functions;
- the latexfontmap.prop\(^4\) file (created by you, if you want it, in any text editor) that contains any font mappings (see subsection 9.5.1).

In addition, the configuration directory is used to save the log file, flowframtk.log, in the event that Shift-F11 is used (or Debug \(\rightarrow\) Write Log if the command line option -debug is used). The emergency save all function Ctrl-F11 (or Debug \(\rightarrow\) Dump All if the command line option -debug is used) will create a subdirectory (using the current date and time to construct the name) and will save all open images to that directory with filenames of the form image\((n)\).jdr.

\(^4\)or simply latexfontmap without an extension for compatibility with Jpgfdraw
4 The Basics

The main FlowframTk window is shown in Figure 4.1. FlowframTk uses a multiple-document interface (MDI). This means that you can have multiple images loaded in separate child windows, without having to start up new instances of FlowframTk. Most of the buttons and menu items will only be applied to the child window that currently has the focus. If there are no child windows, or if they have all been minimized, then the relevant buttons and menu items will be disabled. The only exceptions are the non-canvas specific items.

4.1 The Canvas

The canvas is the white area in each of FlowframTk’s child windows on which you create your picture.
4.2 The Toolbars

There are two toolbars. The horizontal toolbar positioned at the top of the main window, which allows you to manipulate objects on the canvas (as well as the save, load and new buttons) and the vertical toolbar positioned to the left of the main window, which you can use to create new paths and text areas. If a toolbar is too wide/tall, scroll buttons will appear.

You can show or hide the toolbars using the menu item Settings → Show Tools. You can change the location of the vertical toolbar so that it appears on the right of FlowframTk’s main window using the Rulers and Toolbar tab of the Configure User Interface dialog box (see §4 Toolbar and Ruler Settings).

4.3 The Rulers

There are two rulers. The horizontal ruler positioned above the canvas which marks out the x-ticks, and the vertical ruler positioned to the left of the canvas which marks out the y-ticks. The gap between tick marks can be changed using the Settings → Grid → Grid Settings menu item.

You can show or hide the rulers using the menu item Settings → Show Rulers. You can adjust their size and number format using the Rulers and Toolbar tab in the Configure User Interface dialog box.

4.4 The Status Bar

The status bar is positioned along the bottom of the main window. The left hand corner shows the current position of the pointer (or the pointer’s last position before it was moved away from the canvas). Next to that is the storage unit. After that is the file status area. If the current picture has been modified, it will display the word “Modified”, otherwise it will be blank. Following that is an image that indicates whether the grid lock is on or off and next to that there is some brief information as to what you can do with the currently selected tool.

You can show or hide the status bar using the menu item Settings → Show Status Bar.
5 The File Menu

You can use the File menu to create a new picture, load a picture from a JDR or AJR file, save the current picture, export the current picture to a supported format (such as a \LaTeX{} file), assign a description to the current picture, print the current picture or quit FlowframTk.

5.1 New

To start a new picture, select File → New. This will open a new child window. You can switch between child windows using the Window menu.

5.2 Open

To load a JDR or AJR file, select File → Open. If there is already a picture in the current child window, a new child window will open to display the file. Note that although FlowframTk can export to other formats, it can only load JDR and AJR files.

If you load an image that contains a link to a bitmap and the bitmap is no longer in the same location, you will be prompted for a new link or you can discard the link. Note that if you select a new link, the \LaTeX{} link will also be updated. If there is insufficient memory in the JRE to load a bitmap, FlowframTk will revert to draft mode for that bitmap.

5.3 Recent Files

To load a recently used JDR or AJR file, use the sub menu File → Recent Files. A maximum of ten files, starting with the most recently used are listed. Note that loading a file from this list will change the open file chooser directory to that file’s directory.

5.4 Image Description

You can use the File → Image Description dialog box to give the image a description. The description is not visible in the image, but is saved as a comment when you export the image to a \LaTeX{} document. If you have the Add \pdfinfo to exported \LaTeX{} documents option selected in the Document Settings tab of the TeX/LaTeX Configure Settings dialog box, the image description will be added to an exported \LaTeX{} document in the /Title attribute of the \pdfinfo argument.

5.5 Save and Save As

You can save the current picture in FlowframTk’s native JDR or AJR format using either File → Save (if it already has a name) or File → Save As (if you want to specify the filename). I strongly recommend that you save your work frequently. There is no auto-save function.
5.6 Export

The File → Export menu allows you to export your image as:

- A LaTeX file containing a `pgfpicture` environment, which can then be included into a LaTeX document using `\input`. The start of the file will include comments with code between an `\iffalse` ... `\fi` block that may be required in your preamble. If necessary, copy that block into your document’s preamble.

- A single-paged LaTeX document containing the image, where the page size is set to the canvas page size.

- A single-paged encapsulated LaTeX document containing the image, where the page size is set to the image’s bounding box. (If the bounding box is smaller than the baselineskip, the page height is set to the baselineskip, according to the given normal size for the image.) Take care with this as changes in font sizes can cause the image to be clipped if the bounding box has been underestimated.

- A PNG file. (All colours are converted to RGB and LaTeX settings are ignored.)

- A PostScript file.

- A PDF file.

- An SVG file.

- A LaTeX package or class that loads the flowfram package. The `pgf` package is also used to create borders and backgrounds, where required. Note that only the objects that have been identified as static, flow or dynamic frames will be exported. Any `image preamble text` is added before the start of the package option declarations, which provides a means to add extra package options, if required. Remember that you can use `\AtEndOfPackage/\AtEndOfClass` if you want to add code that needs to be deferred until after the options have been processed. (Or `\AtBeginDocument`.) Any occurrences of `\usepackage` in the image preamble will be converted to `\RequirePackage` on export.

If the file name has the extension `.cls`, a class is assumed, otherwise a package will be created. If a class file is created, the underlying class (loaded with `\LoadClass`) is as indicated by the document class setting, as described in §3.2.9 Setting the Document Class and Normal Font Size.

Note that FlowframTk can’t load the files that it can export, so I strongly recommend that you first save the picture as a JDR or AJR file before exporting it, in case you wish to edit it later.

If the file `preamble.tex` exists in the configuration directory, its contents will be included in the document preamble for the export to a complete single-paged LaTeX document, export to PostScript, PDF or SVG. This is in addition to the contents of the image’s `preamble`. For the export to a LaTeX package or class, the image’s preamble is used, as described above, but the `preamble.tex` file won’t be used. For example, I have created a file called `preamble.tex` in my configuration directory that contains the lines:
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{lmodern}

I recommend that at the very least you have the \texttt{inputenc} and \texttt{fontenc} packages in your \texttt{preamble.tex} file.

In the case of export to PostScript, PDF or SVG, the resulting file is created by first implementing the export to an encapsulated \LaTeX\ document, and then running \texttt{pdflatex} (for the PDF export), or \texttt{latex} and \texttt{dvips} (for the PostScript export), or \texttt{latex} and \texttt{dvisvgm} (for the SVG export). If the exported file has unexpected results or fails to be created, try exporting to an encapsulated \LaTeX\ document and then manually running \texttt{pdflatex} or \texttt{latex}, as the issue may be due to the conversion process or it may be due to an unrecognised command or syntax error in a text area or text-path. \textbf{Note that PostScript does not support transparency.}

If your image includes \LaTeX\ commands that require a particular package, you will need to add these packages to the \texttt{image preamble}. (Except in the case of export to PNG,) \texttt{FlowframTk} will automatically add \texttt{\usepackage{pgf}} to the preamble and other packages such as \texttt{geometry} and \texttt{ifpdf}. It will also add \texttt{\usepgflibrary{decorations.text}} in case the image contains any text-paths. If the maths-mode or text mappings are enabled, the mappings may also add packages to the image preamble. For further details, see §10.1 Adding Commands to the Preamble.

\texttt{FlowframTk} was tested with version 3.0.0 of the \texttt{pgf} package, version 1.16 of the \texttt{flowfram} package and version 2.2 of the \texttt{shapepar} package. Files created by \texttt{FlowframTk} may not work with earlier versions of those packages. Note that some DVI viewers may not understand PGF specials. I strongly recommend that you read the user manuals for those packages.

See also:

- §3.2.8 Image Settings Dialog
- §3.2.9 \TeX\ Settings Dialog
- §10.1 Adding Commands to the Preamble
- §10.4 Creating Frames for Use with the \texttt{flowfram} Package
- §11.1 Step-by-Step Example: A House
- §11.4 Step-by-Step Example: An Artificial Neuron
- §11.6 Step-by-Step Example: A Poster
- §11.7 Step-by-Step Example: A Newspaper

5.7 Print

You can print the current image using File → Print which will open the printer dialog box. If no printer is found, the error message “No printer services found” will be displayed. If this happens, check that the printer is switched on and connected to the computer. The print function uses the canvas’s rendering hints.
5.8 Message Window

You can display the message window using the File → Show Messages item. This usually just lists the files that have been opened, saved or exported, but warnings are sometimes written there as well. This window is opened during a read or write operation, but is closed on successful completion. If it doesn’t close, this is usually an indication of some warning, which will be displayed in the message area. However, occasionally it doesn’t automatically close when there are no issues. If this happens, you can simply close it using the close button. When an external application is spawned, the abort button becomes enabled, which you can use to kill the spawned process if required.

5.9 Close

You can close the current child window, either by clicking on the child window’s close icon or by selecting File → Close. If there is any unsaved data, FlowframTk will ask for confirmation before discarding the window. An image will only be marked as unmodified if it has been saved as a JDR or AJR file. If you have exported your image to another file type, I recommend that you also save it as a JDR file as well, in case you want to edit it later.

Note that you must finish or discard any path that is under construction before you can close an image.

5.10 Quit

To quit FlowframTk either use the menu item File → Quit or click on the close icon on the main window. All child frames will be closed. If any child frame contains unsaved data, you will be asked for confirmation before the window is discard.
6 Creating New Objects

New paths and text areas can be created using FlowframTk’s construction mode, which can be obtained using any tool except the select tool. The tools can be selected using either the vertical toolbar or the Tools menu. Once paths and text areas have been created they can then be edited or transformed or combined to form a text-path object. You can also apply patterns to paths or text-paths.

Whilst constructing a line path or curve path, you can:

- Finish the path by pressing the Enter key or by double-clicking (instead of single-clicking) on the final vertex or by selecting Tools → Finish or by clicking on the finish button. Note that transferring the focus to another FlowframTk child window or selecting a new tool whilst you are constructing a path, will complete the current path.

- Cancel the current path by pressing the Shift-Escape key or by selecting Tools → Abandon or by clicking on the cancel button.

- Make a gap in the current path: once you have clicked on the vertex where you want the gap to start, select Tools → Gap or click on the gap button or press Ctrl-M, then click on the canvas where you want the gap to end.

The undo/redo mechanism is disabled while you are constructing a path, however while you are creating a line path or a curve path, you can delete the previous segment using the Backspace key.

Note that FlowframTk won’t allow you to create a path whose total width and height are both less than 1.002bp. This is to prevent accidentally creating a tiny path that can’t be seen but contributes to the total image dimensions. This restriction only applies when creating paths and does not apply to editing paths.

Note that the path attributes will only be set once the path has been completed. Whilst the path is under construction you will only see a draft version (see Figure 6.1). If you want a path with a mixture of line and curve segments, first construct a path with only one type of segment (e.g. lines), and then use the edit path function to convert the required segments.

If you are unable to use the mouse, you can move the pointer using Navigate → Go To which will display the dialog box shown in Figure 6.2. Enter the x and y coordinates in the x and y fields if you are using a rectangular grid, or enter the angle and radius in the Angle and Radius fields, if you are using a radial grid. The function key F4 will emulate a single mouse click in construction mode.

See also:

- §8.6 Editing Control Points
- §8.7 Symmetric Shapes
- §8.29 Converting a Path or Text-Path into a Pattern
6.1 Line Paths

To construct an open line path, select the open line tool, either by clicking on the open line button or by selecting Tools → Open Line (Ctrl-L).

To construct a closed line path, select the closed line tool, either by clicking on the closed line button or by selecting Tools → Closed Line (Ctrl+Shift-L).

Use the left mouse button to click on each vertex defining the path. To complete the path, do one of the following:

- Double-click instead of single-clicking on the final vertex: this performs the combined function of defining the vertex and finishing the path. If you use this method, be careful not to accidentally create two coincident vertices at the end point, or it will cause a problem for any mid or end marker that you apply.

- Single-click on the final vertex and then complete the path by pressing the Enter key or by clicking on the finish button or by selecting Tools → Finish.

If you have used the closed line tool, the path will automatically be closed by inserting a line between the end vertex and the initial vertex.

See also:
6.2 Curve Paths

To construct an open curve path, select the open curve tool, either by clicking on the open curve button or by selecting Tools → Open Curve (Ctrl-K).

To construct a closed curve path, select the closed curve tool, either by clicking on the closed curve button or by selecting Tools → Closed Curve (Ctrl+Shift-K).

Use the left mouse button to click on each vertex in the path. There is no way to specify the location of the control points defining the curvature of the path whilst the path is under construction, however, once the path has been completed, it is possible to move these control points using the edit path function.

To complete the path, do one of the following:

- Double-click instead of single-clicking on the final vertex: this performs the combined function of defining the vertex and finishing the path. If you use this method, be careful not to accidentally create two coincident vertices at the end point, or it will cause a problem for any mid or end marker that you apply.

- Single-click on the final vertex and then complete the path by pressing the Enter key or by clicking on the finish button or by selecting Tools → Finish.

If you have used the closed curve tool, the path will automatically be closed by inserting a curve between the end vertex and the initial vertex.

See also:

- §6.4 Ellipses
- §9.1 Line Colour
- §9.2 Fill Colour
- §9.3 Line Style
- §8.6 Editing Control Points
- §11.4 Step-by-Step Example: An Artificial Neuron

1You may, of course, want to do this intentionally, in which case ignore this caveat.
6.3 Rectangles

To construct a rectangle, select the rectangle tool either by clicking on the rectangle button or by selecting Tools → Rectangle (Ctrl-R).

Use the left mouse button to click where you want the first corner to go, then move (not drag) the mouse to the opposite corner, and click or press the Enter key to complete the path.

Note that this function is just a shortcut to using the closed line function. Once the rectangle is created, it is simply another closed path, and can be edited in exactly the same way.

See also:

- §6.1 Line Paths
- §9.1 Line Colour
- §9.2 Fill Colour
- §9.3 Line Style
- §8.6 Editing Control Points
- §11.1 Step-by-Step Example: A House
- §11.4 Step-by-Step Example: An Artificial Neuron

6.4 Ellipses

To construct an ellipse, select the ellipse tool either by clicking on the ellipse button or by selecting Tools → Ellipse (Ctrl-E).

Use the left button to click on the centre point of the ellipse, and then move (not drag) the mouse until the ellipse has reached the desired dimension, and click or press the Enter key to complete the path. If you want to create a circle, I recommend that you first lock the grid or use the Navigate → Go To menu item.

Note that this function is just a shortcut to using the closed curve function. Once the ellipse is created, it is simply another closed path, and can be edited in exactly the same way.

See also:

- §6.2 Curve Paths
- §9.1 Line Colour
- §9.2 Fill Colour
Text areas can be created to annotate images. Each text area has text that’s displayed on the canvas but may have alternative text to use when exporting to a \LaTeX file. (This includes the export functions that create a temporary \LaTeX file, such as the export to PDF function.) There are two tools to create a text area: the text tool and the maths tool. These affect the default alternative text for the new text area in different ways. You can later edit the alternative text, if the default isn’t suitable.

The maths tool (which can be selected either by clicking on the maths tool button or by selecting Tools → Maths) will automatically insert the maths shift $ symbol at the start and end of the alternative text. In addition, if the Auto escape maths symbols setting is on, certain characters will be replaced by a command (or commands) in the alternative \LaTeX text.

The text tool (which can be selected either by clicking on the text tool button or by selecting Tools → Text) will only create an alternative \LaTeX text if the Auto escape text symbols setting is on and there is an appropriate mapping.

Once you have selected the required tool, click with the left mouse button at the position where you want the text to start. This will produce a shaded area with a cursor in which you can type no more than a single line of text. Clicking inside this shaded area will move the cursor around the text area under construction.

When you want to complete a text area, press Enter (which will start a new text area on the line below) or click anywhere on the canvas outside of the current text area (which will start a new text area at the new location) or use the finish button or Tools → Finish. Selecting another tool whilst a text area is under construction will finish the current text area, unless you’re switching between the text and maths tools. (If you do switch between the text and maths tools, the alternative \LaTeX text is only created when you finish the text area, so the mappings applied will be governed by the tool currently selected when you completed the text area.)

Once a text area has been completed, the only way to edit it is via the edit text function. If you click the mouse on the location of a completed text area (while the text/maths tool is selected) you will simply create a new overlapping text area.

Whilst a text area is under construction, you can activate the text area popup menu, illustrated in Figure 6.3. (This is usually done with a right mouse click but depends on your system. The function key F3 has the same effect.)

The text area popup menu provides the following functions:

**Copy (Ctrl-C)**

Copies selected text to the clipboard.

**Cut (Ctrl-X)**

Cuts selected text to the clipboard.
Paste (Ctrl-V)
   Pastes text from the clipboard.

Select All (Ctrl-A)
   Selects all the text.

Insert Symbol (Insert)
   Opens the Insert Symbol dialog box if you want to enter a symbol that doesn’t appear on your keyboard.

   The Insert Symbol dialog box (see Figure 6.4) has a field at the top which contains the text currently in the text area. If you know the hexadecimal Unicode value for the character you want to insert, you can type the number into the Unicode box and press the Select button to insert it into the text area.

   On the right hand panel below the Unicode field there is an enlarged image of the selected character. If there’s an associated mapping it will be displayed below the enlarged image (see Figure 6.4).

   Alternatively, you can use the button panels on the left to select the character you want to insert into the text field. Use the left hand list to display the require Unicode block and either click on the button to insert and display the symbol or hold the shift key down while you click to just display the symbol in the right hand panel without inserting it into the text field.

   The button panels can be customized to include more symbols via the Configure User Interface dialog (see §4 Language Settings).

   Note that the text in your \texttt{pgfpicture} environment may not look exactly the same as in \texttt{FlowframeTk} due to font differences as well as the translation of \LaTeX\ commands. See subsection 9.5.6 for more details.

See also:

- §9.4 Text Colour
- §9.5 Text Style
- §8.8 Editing Text Areas
Figure 6.4: Insert Symbol Dialog Box
• §8.30.1 Converting a Text Area, Text-Path or Pattern to a Path
• §8.31 Splitting Text Areas
• §3.2.9 Setting the Document Class and Normal Font Size
• §3.2.9 TeX Settings Dialog
• §11.4 Step-by-Step Example: An Artificial Neuron
• §11.9 Step-by-Step Example: A House With No Mouse
7 Bitmaps

FlowframTk is primarily a vector graphics application, however it is possible to insert a raster graphics image (bitmap) into your picture for background effects or if you want to annotate a bitmap (as was done in Figure 6.4 in the previous section). Note that FlowframTk does not save the actual raster graphics data in either the JDR or the AJR file, but instead it creates a link to the original file. You can’t edit the actual bitmap data in FlowframTk. However you can scale, rotate or shear the link. If you change the location of the file containing the bitmap, when FlowframTk reloads the JDR or AJR file it will prompt you for the new location or discard the link.

If you use another application to edit the bitmap whilst you have a picture with a link to it displayed in FlowframTk, you will need to select Bitmap → Refresh to update the image.

To insert a bitmap into your picture, first make sure you are using the select tool, and then select the menu item Bitmap → Insert Bitmap and a dialog box will appear in which you can choose the required bitmap. The bitmap will initially appear in the top left hand corner of the canvas but can be moved to a new location.

If there is insufficient memory in the JRE to load a bitmap, FlowframTk will revert to draft mode to display that bitmap. For example, in Figure 7.1 several photos have been inserted into an image. Since photos tend to be quite large, there is insufficient memory to load the final photo, so it is displayed in draft mode instead. Note that draft mode will also be used when printing or exporting to PNG. Since \LaTeX files only contain a link to the bitmap, draft mode should not affect exporting to \LaTeX files or to formats that use \texttt{latex} or \texttt{pdflatex} as an intermediate step.

Note that the amount of memory available to any Java application is set at startup. The default maximum value is usually around 64Mb but can be changed via the JRE command line options. If you run FlowframTk from the shell script \texttt{flowframtk}, then you can set the environment variable \texttt{JDR_JVMOPTS} to change the default configuration. See section 3.1 for further details. If you are running FlowframTk from Windows, you will need to check the JRE documentation.

7.1 Properties

To change a bitmap’s properties, select the required bitmap and select the Bitmap → Properties menu item. This will open up a dialog box shown in Figure 7.2. If you want to change the path name to the bitmap, you can either type it directly into the Filename field or click on the Browse button. You can also change the transformation matrix applied to the bitmap link.

If you want to export your picture to a \LaTeX file or to a format that uses \texttt{latex} or \texttt{pdflatex} as an intermediate step, the \LaTeX command can either be \texttt{\pgfimage} or \texttt{\includegraphics} and is specified in the \LaTeX Command field. The command argument in either case must use a forward slash / as the directory divider. If the Auto checkbox is selected, this substitution will be performed automatically by the export function. Alternatively, you can unselect the Auto checkbox which will enable the \LaTeX image path field in which you can enter the argument to be used by the image command. If you use the export to PostScript or SVG function, FlowframTk will attempt to create an EPS version of the bitmap (if it doesn’t already exist) since \texttt{latex} (as opposed to \texttt{pdflatex}) can’t include bitmap formats, such as PNG and JPEG.
Figure 7.1: Bitmaps are displayed in draft mode when there is insufficient memory in the JRE. The area taken up by the image is displayed as a semi-transparent light grey rectangle with the bitmap’s file name in square brackets.
Figure 7.2: Bitmap Properties Dialog

See also:

- §3.2.8 Bitmap Settings
8 Selecting and Editing Objects

In order to edit an object, you must be in select mode. To do this either click on the select button or use the menu item Tools → Select (Ctrl-P). An object can be selected using any of the following methods:

- Click on it with the left mouse button.
- Double-click the left mouse button to select the object behind the current object.
- Use Control-click (i.e. click whilst holding down the control key) if you want to add an object to the current selection.
- Click on an empty part of the canvas and drag. A dashed rectangle will appear. When you release the mouse button, any objects within that region will be selected. (If you have the shift key depressed, only those objects which are completely inside the dashed rectangle will be selected, but make sure you release the mouse button before releasing the shift key.)
- Use Navigate → Select (Shift-F5) to select the next object in the stack. (Starting from the frontmost object and heading towards the back.) This will cycle back to the start when it reaches the end of the stack.
- Use Navigate → Skip (F6) to deselect the selected object closest to the backmost object, and select the next object in the stack (heading towards the back). This will cycle back to the start when it reaches the end of the stack. If you have more than one object selected, the remaining objects will stay selected.
- Use Navigate → Add Next (Shift-F6) to add the next object in the stack to the selection (starting from the front and heading towards the back). This will cycle back to the start when it reaches the end of the stack.
- Use Navigate → Find By Description or Navigate → Add By Description to select an object by its description. (If an object hasn’t been given a description, a generic description will be supplied instead.) The former will deselect all other objects, the latter will add the object to the current selection.
- Use Edit → Select All (Ctrl-A) to select all objects.

When an object is selected, a dashed red/grey rectangle will be displayed around it. (This rectangle may optionally have hotspot regions.) Note that individual elements of a group can not be selected independently of the group. When you select a group, you will only see a dashed red/grey rectangle around the bounding box of the group, not around the individual elements of the group.

To deselect an individual object, click on that object whilst depressing the shift key. To deselect all objects, click on an empty part of the canvas, or use Edit → Deselect All (Ctrl-Shift-A). Selecting another tool will also deselect all objects.

In select mode, you can also use the select popup menu. (This is usually done with a right mouse click, but depends on your system. The function key F3 has the same effect.) The contents of this menu vary according to what types of objects have been selected, if any (see Figure 8.1).
8.1 MOVING AN OBJECT

To move an object or objects, first select the objects you want to move and then do one of the following:

- Depress the left mouse button somewhere inside the selection, and drag the mouse. Release the mouse button when the objects have reached their required location. If you only want to move the object by a very small amount, and your mouse is very sensitive or you have difficulties with fine motor co-ordination, depress the mouse button and instead of dragging use the arrow keys to move the pointer.

- Use Edit → Move By to show the Move By dialog box (Figure 8.2). In the field marked $x$ enter the horizontal displacement, and in the field marked $y$ enter the vertical displacement. For example, to move the selected objects 10 units to the right and 20 units down, type 10 in the $x$ field and 20 in the $y$ field. To move left or up, use a negative value.

Figure 8.2: Move Selected Objects Dialog Box

**Figure 8.1:** Popup menus in select mode depend on what objects have been selected: (a) no objects selected; (b) only text-paths have been selected; (c) only paths have been selected; (d) only text areas have been selected; (e) only bitmaps have been selected; (f) groups or a selection of different object types have been selected.

8.1 Moving an Object
8.2 Cut

To cut a selection of objects to the clipboard, use Edit → Cut. Note that it will be stored on the clipboard as a JDRGroup Java object, not as text or raster graphics, so you won’t be able to paste it into a different application. If you want to cut a piece of text from a text area, you will need to use the edit text area function.

8.3 Copy

To copy a selection of objects to the clipboard, use Edit → Copy. Note that it will be stored on the clipboard as a JDRGroup Java object, not as text or raster graphics, so you won’t be able to paste it into a different application. If you want to copy a piece of text from a text area, you will need to use the edit text area function.

8.4 Paste

To paste a selection of objects from the clipboard, use Edit → Paste. If you want to copy text from another application, and paste it into a text area in FlowframTk, you will have to create a new text area, and use the text area popup menu to paste the text into the text area. If you want to paste plain text into an existing text area, you will need to use the edit text area function.

8.5 Object Description

You can assign a description to an object using the Edit → Object Description menu item. This will display the dialog box shown in Figure 8.3. Type the description into the text field, and click on Okay or press Enter.

![Figure 8.3: Setting an Object’s Description](image)

The description will not appear in the image, but it can be used to locate and select objects on the canvas using the Navigate → Find By Description or Navigate → Add By Description menu items. The description may also be used as a comment when exporting images, depending on the file type. Note that if you assign a description to a group, you will lose the description if you later ungroup it.

8.6 Editing Control Points

To move, delete or add control points, open or close paths, or to convert segments from one form (line, gap, cubic Bézier) to another, first select the
path, and then either click on the edit path icon or select Edit → Path → Edit Path (Ctrl-I). (Note that you should not have any other objects selected.) The path will then be displayed in draft format. The currently selected control point and the currently selected segment will appear in red. The other control points will be orange.

A text-path object can have its underlying path edited in the same way as a normal path, but in edit mode you will also see the text (without anti-aliasing).

Use one of the following methods to select a control point:

- Click on the control point. (If two or more points coincide with the location of the mouse, the point with the lowest index will be selected.) Remember that if the grid lock is on, mouse clicks will be translated to the nearest tick mark, so even if the pointer is positioned over a control point, the nearest tick mark may be outside the control point. In which case the required control point won’t be selected, and you will either exit edit mode or select a neighbouring point that coincides with the nearest tick mark. If you want to use the mouse to select and move a control point, make sure that you first click to change the selection before initiating a drag or you may move the wrong control.

- Press F6 or Shift-F6 until the required control point is selected. (You will need to use this method if two or more control points are in the same location and you don’t want the one with the lowest index. You will also need to use this method if the grid lock is on and the control point’s bounding box doesn’t lie on a tick mark.)

Use one of the following methods to move a control point:

- Use the mouse to drag the point to its new location. (You can initiate dragging outside of the selected control point.)

- Use the edit path popup menu (F3) and select Co-ordinates (F7). Enter the new co-ordinates in the dialog box. (You will need to use this method if the grid lock is on and you want to move the point by an interval that is not a multiple of the gap between tick marks.)

- Use the edit path popup menu and select Snap To Grid to move the control point to the nearest tick mark.

To exit edit mode either deselect the edit path tool (Ctrl-I) or click on the canvas somewhere outside of the control points. Note that you can not edit a path if it belongs to a group; you must first ungroup it.

Whilst a path is in edit mode, you can use the edit path popup menu which provides functions to select or edit control points or the segments that they define. The following functions are available:

**Next Control (F6)**

Select the next control point. This is an alternative to using the mouse to select the point.

**Previous Control (Shift-F6)**

Select the previous control point.

**Delete Point (Delete)**

Delete the currently selected control point. (This function is not available for
8.6 **EDITING CONTROL POINTS**

control points that govern the curvature of Bézier segments, the controls on the line of symmetry for symmetric paths or the pattern adjustment controls.) If the control point is the first or last point in an open path it will delete the corresponding segment, otherwise it will replace two adjacent segments with a single segment. If the path is open and only has one segment, or if the path is closed and has two segments, deleting a control point will delete the path or the text-path object.  

**Add Point (Insert)**

Add a new control point in the middle of a segment (thus replacing a single segment with two segments). This will actually add three new points if the segment is a Bézier curve as it will also create the required curvature control points.

**Convert To Line**

Convert a curve segment or a gap to a line segment.

**Convert To Curve**

Convert a line segment or a gap to a curve segment. The curvature control points will be positioned so that the segment forms a straight line. These can then be moved as required.

**Convert To Move**

Convert a line or curve segment to a gap.

**Path Symmetry**

This submenu can be used to add symmetry to the selected shape. (See §8.7 Symmetric Shapes for further details.)

**Continuity**

If the currently selected segment is a Bézier segment this submenu provides functions that adjust the curvature control point to ensure that the gradient at the nearest join is continuous. This menu isn’t available if it’s not possible to do this (for example, if the nearest join is an end point).

There are two items in this submenu that are only enabled if the current selected control point is a curvature control. The Continuity → Equidistant function will move the control point so that it has the same gradient direction and magnitude as the gradient vector on the other side of the join. The Continuity → Relative function will move the selected curvature control so that it has the same direction as the gradient on the other side of the join, but its magnitude will remain unchanged.

For example, in Figure 8.4 the path was originally an open line path with three line segments. The middle segment was selected and converted to a Bézier curve using the Convert To Curve function (Figure 8.4(a)). The Continuity → Relative function was then used to change the starting gradient of the Bézier segment to make a smooth join between the first two segments (Figure 8.4(b)). The Bézier curve’s third control point, which governs the end curvature, was selected, and the Continuity → Relative function was again used to change the end gradient of the Bézier segment to make a smooth join between the last two segments (Figure 8.4(c)).

---

1 The text will also be lost.
8.6 EDITING CONTROL POINTS

Figure 8.4: Making the join between segments continuous: (a) the middle segment of an open line path has been converted into a Bézier curve; (b) the gradient at the start of the curve is now the same as the gradient at the end of the previous segment; (c) the gradient at the end of the curve is now the same as the gradient at the start of the next segment.
The toggle menu item Anchor is only available when a control point on the join between two Bézier curves has been selected. If this item is selected, when you adjust one of the adjacent curvature control points, the corresponding curvature control on the other segment will be adjusted to maintain continuity. An anchor image will appear in the control joining the two segments when this setting is on (as shown in Figure 8.5).

Figure 8.5: Continuity Anchor

Open Path Menu
Open a closed path. There are two options available:

Remove Last Segment
Opens the path, removing the last segment (Figure 8.6(b)).

Keep Last Segment
Opens the path, but keeps the last segment (Figure 8.6(b)).

Figure 8.6: Opening a path: (a) the original closed path; (b) the path in (a) was opened, removing the final segment; (c) the path in (a) was opened, keeping the last segment.

Close Path Menu
Close an open path. There are three options available:
8.6 Editing Control Points

Close With Line
Close the path with a line between the last and first control points of the original path (Figure 8.7(a)).

Close With Curve
Close the path with a Bézier curve between the last and first control points such that the curve is continuous at the join between the first and last segments of the original path (Figure 8.7(b)).

Merge Ends
Close the path, merging the last control point of the original path with the first control point (Figure 8.7(c)).

Figure 8.7: Closing a path: (a) the original path; (b) the path in (a) was closed with a line; (c) the path in (a) was closed with a curve continuous at the join between adjacent segments; (d) the path in (a) was closed, merging the end points

Co-ordinates (F7)
This menu item will display a dialog box in which you can set the control point’s x and y values (instead of dragging the point to the required location). Note that rounding errors may occur if the unit used in this dialog doesn’t have a convenient conversion factor with the storage unit.

Snap To Grid (Ctrl+Shift-S)
Move the currently selected control point to the nearest tick mark.

Break path
Break the path into two separate paths at the end of the currently selected segment (not at the currently selected control point). If the object is a text-path, the new text-paths will both have the same text (that is, the text is not broken between them).
8.7 SYMMETRIC SHAPES

See also:

- §8.22 Reversing a Path’s Direction
- §8.23 Merging Paths
- §8.24 Path Union
- §8.25 Exclusive Or Function
- §8.26 Path Intersection
- §8.27 Path Subtraction
- §8.30 Converting to a Path
- §9.1 Line Colour
- §9.2 Fill Colour
- §9.3 Line Style
- §11.2 Step-by-Step Example: Lettuce on Toast
- §11.5 Step-by-Step Example: Bus
- §11.9 Step-by-Step Example: A House With No Mouse

8.7 Symmetric Shapes

A shape can have symmetry added to it using the Path Symmetry submenu of the edit path popup menu described in the previous section.

Take care with closed symmetric paths. Unexpected results may occur, particularly if the path contains any gaps. This may cause the stroked or filled shape to appear unsymmetric.

The Path Symmetry submenu provides the following functions:

**Has Symmetry**

If this menu item is selected, symmetry will be added to the path. For example, Figure 8.8(a) shows a path in edit mode, and Figure 8.8(b) shows the path with symmetry applied to it. There are now two extra control points (coloured blue). These points govern the line of symmetry\(^2\). In Figure 8.8(c), these two controls have been moved.

If you later decide to remove the symmetry, deselect Path Symmetry → Has Symmetry.

Adding symmetry to a closed shape may cause unexpected results as the shape will be first opened (without removing the last segment), the symmetry will be added, and then the symmetric shape will be closed, merging the end points.

\(^2\)The line of symmetry extends infinitely though the two controls, but only the part of the line between the two points is actually displayed in edit mode.
8.8 Editing Text Areas

Anchor Join
When you add symmetry to a path, the final control point of the underlying path is anchored to the line of symmetry. That is, it can only move along the line defined by the two blue control points. To remove the constraint, deselect this menu item. In Figure 8.8(d), the Anchor Join item was deselected, and the end control was then moved away from the line of symmetry.

Note that this function places a gap (move) segment between the end control and its symmetric counterpart, which will produce an unsymmetric effect if the path is then closed. This gap can be changed to a line or curve, using Convert To Line or Convert To Curve, as described in §8.6 Editing Control Points. In Figure 8.8(e), the join has been changed to a curve. Unlike the Bézier curves in the non-symmetric paths, this curve only has one curvature control.

Anchor Start Control
This menu item is only available for closed symmetric paths. If you close a symmetric path using the Merge Ends function, the first control point of the underlying path will be anchored to the line of symmetry. The Path Symmetry → Anchor Start Control menu item will remove this constraint.

For example, Figure 8.9(a) shows a closed symmetric path (a closed version of Figure 8.8(e)). The anchor constraint on the first control was then removed and the control was moved to the left (Figure 8.9(b)). As with the join segment (above) the closing segment between the start control and its reflection can be changed to a curve with one curvature control (Figure 8.9(c)).

See also:
- §8.29 Converting a Path or Text-Path into a Pattern
- §11.10 Step-by-Step Example: A Lute Rose

8.8 Editing Text Areas
To insert or delete characters from a text area or text-path first select the text area or text-path, and then select Edit → Text → Edit text (Ctrl+Shift-I). (Note that you should not have any other objects selected.) This will display the Edit Text dialog box (Figure 8.10(a)) in which you can modify the text as appropriate. If you are editing the text of a text-path, there will be an extra panel visible, shown in Figure 8.10(b).

Note that you can not edit a text area or text-path if it belongs to a group. Deleting all the characters within a text area or text-path isn’t permitted and will result in the error message “Empty string”.

The text area popup menu is available in the top text field allowing you to Select All the text, Cut or Copy selected text to the clipboard, Paste text from the clipboard, or insert a symbol using the Insert Symbol menu item. This is the same as the popup menu used when creating a new text area.

If you want to specify alternative text to appear in a \LaTeX document, click on the button marked Different, and enter the alternative in the bottom field (see Figure 8.10(b)). The text area popup menu is not available in this field, but you can still use Ctrl-A, Ctrl-C, Ctrl-X and Ctrl-V to select all the text, copy to the clipboard, cut to the clipboard or paste from the clipboard, respectively. Note that the exported text may
Figure 8.8: Adding Symmetry to a Path: (a) original path; (b) symmetry added to path in (a) the two blue controls govern the line of symmetry; (c) the line of symmetry has been moved, altering the overall appearance of the shape; (d) the end anchor constraint has been removed and the end control has been moved away from the line of symmetry; (e) the joining segment has been converted to a curve with only one curvature control.
8.8 EDITING TEXT AREAS

Figure 8.9: Closed symmetric path: (a) the symmetric path in Figure 8.8(e) has been closed — the first control is now anchored to the line of symmetry; (b) deselecting the close anchor constraint allows the start control to be moved away from the line of symmetry; (c) the segment closing the symmetric path has been changed to a curve.

Figure 8.10: Edit Text Dialog Box: (a) regular text area; (b) text-path
occupy a larger or smaller area in the \LaTeX document than it does in FlowframTk, so you may also need to change the anchor.

You can use the Re-Map button to generate the alternative text in the bottom field by applying mappings to the text in the top field. If the original alternative text starts and ends with a dollar \$ symbol, the maths-mode mappings will be used, otherwise the text-mode mappings will be used. If the original alternative text is empty, you can just type a dollar symbol in it and click on the Re-Map button to generate a maths-mode mapping.

The \LaTeX export functions use the \texttt{pgf} text decoration to implement text-paths. This allows you to insert declarations, such as \texttt{\textbackslash large}, part way through the text by placing them between delimiters. By default these delimiters are the vertical bar (pipe) character | but this can be changed in the Left Delimiter and Right Delimiter fields (see Figure 8.10(b)). Note that the vertical anchor setting is ignored by the \LaTeX export functions. It’s best to avoid maths in text-paths. See the \texttt{pgf} manual for further details about text decorations.

The alternative text may not be used by export functions if the text-path has been made an outline or the text area/text-path has a gradient paint. The export behaviour under those circumstances is dependent on your \LaTeX text settings.

See also:

- §3.2.9 TeX Settings Dialog
- §9.4 Text Colour
- §9.5 Text Style
- §8.31 Splitting Text Areas
- §8.30.1 Converting a Text Area, Text-Path or Pattern to a Path
- §3.2.9 Setting the Document Class and Normal Font Size
- §11.4 Step-by-Step Example: An Artificial Neuron

### 8.9 Combining a Text Area and Path to Form a Text-Path

A text area and a path can be combined to form a text-path. The underlying path will not be visible (except in path edit mode) and the text will run along the path. If the original text area was in outline mode, the new text-path will also be in outline mode, possibly with a fill colour, depending on the original text area and path fill colours. (If the original text area didn’t have a fill colour, the path fill colour will be applied.)

The horizontal anchor determines whether the text should start at the first control point of the underlying path or if it should be centred along the path or if it should be right aligned at the end control point. The vertical anchor determines whether the base, bottom, top or middle of the text should be aligned on the path. However, the vertical
anchor isn’t implemented by the \LaTeX\ export functions. Note that if the text is longer than the path, the text will be truncated.

For example, the text area and path in Figure 8.11(a) are combined to form a text-path. The original text area’s horizontal anchor was set to left, so the text along the path starts at the first control point in Figure 8.11(b). In Figure 8.11(c) the horizontal anchor has been changed to centre, and in Figure 8.11(c) the horizontal anchor has been changed to right.

Figure 8.11: Combining a text area and path to form a text-path: (a) the original text area and path; (b) the resulting text-path with left horizontal anchor; (c) centred anchor; (d) right anchor. (The text-paths are in edit mode to show the underlying path.)

Once a path has been combined with a text area, the path line style attributes are lost as the path is only used as a guide to position the text. Most path functions, such as path union, are applied to the underlying path and the text is adjusted to follow the new path. Transformations using the rotate, scale and shear functions are applied to the underlying path not the text. You can either transform the text using the transformation functions before combining it with a path or transform it after combining by changing the text transformation matrix.

Note there is a difference between applying symmetry to a text-path and converting a text area and symmetric shape to a text-path. For example, consider the text area and
8.10 TEXT OUTLINES

path in Figure 8.12(a). If you first combine them to form a text-path (Figure 8.12(b)) and then add symmetry (Figure 8.12(c)), the result is a text-path where the text is reflected across the line of symmetry. Conversely, applying symmetry to the path first (Figure 8.12(d)) and then combining with the text area yields a text area where only the underlying path has symmetry (Figure 8.12(e)).

A similar effect applies with other types of composite shapes.

Restrictions apply to text-paths with the export functions as some text-path effects aren’t emulated in \LaTeX, such as the vertical anchor, gradient paint and outlines. You can determine the behaviour on export via the TeX Configuration settings.

See also:
• §8.8 Editing Text Areas
• §8.28 Separating a Text-Path into a Text Area and Path
• §8.29 Converting a Path or Text-Path into a Pattern

8.10 Text Outlines

A text area or text-path can be rendered as an outline by selecting it and then using the Edit → Text → Outline menu item. For example, Figure 8.13(a) shows a standard text area and Figure 8.13(b) shows that text area rendered as an outline. If the outline mode is set, you can apply a fill colour using Edit → Fill Colour.

Note that although text-paths can be rendered with an outline in FlowframTk, the \LaTeX export functions can’t emulate this and will either export the text-path without the outline setting or will export it as a path (in which case the alternative text will be ignored) depending on your TeX Configuration Setting.

8.11 Reducing to Grey Scale

Line colours, fill colours and text colours can be reduced to grey scale using Edit → Adjust Colour → Reduce to Grey Scale. Only selected paths and text areas will be affected. If you want to reduce a bitmap to grey scale you will need to use a bitmap editor.

See also:
• §8.13 Fade
• §8.12 Colour Space Conversions
• §8.11 Reducing to Grey Scale
• §8.14 Removing Transparency
• §9.1 Line Colour
• §9.2 Fill Colour
Figure 8.12: Symmetric text-paths: (a) original text area and path; (b) text area and path in (a) have been combined to form a text-path; (c) the text-path in (b) has had symmetry applied to it in edit path mode; (d) the path in (a) has had symmetry applied to it; (e) the text area and symmetric path in (d) have been combined to form a text-path.
8.12 Colour Space Conversions

Line colours, fill colours and text colours can have their colours converted to a different colour space using the functions Edit → Adjust Colour → Convert to CMYK, Edit → Adjust Colour → Convert to RGB and Edit → Adjust Colour → Convert to HSB.

Note that colour space conversions are not exact. You may not end up with the desired effect.

See also:
- §8.13 Fade
- §8.12 Colour Space Conversions
- §8.11 Reducing to Grey Scale
- §8.14 Removing Transparency
- §9.1 Line Colour
- §9.2 Fill Colour
- §9.4 Text Colour

8.13 Fade

Line colours, fill colours and text colours can be faded (transparency increased) using Edit → Adjust Colour → Fade Alpha. Only selected paths and text areas will be affected. If you want to fade a bitmap you will need to use a bitmap editor that provides that function.

See also:
- §8.11 Reducing to Grey Scale
- §8.12 Colour Space Conversions
- §8.14 Removing Transparency
- §9.1 Line Colour
- §9.2 Fill Colour
- §9.4 Text Colour
8.14 Removing Transparency

Line colours, fill colours and text colours can have the transparency removed using Edit → Adjust Colour → Remove Alpha. Only selected paths and text areas will be affected. This function sets the paint to none if the alpha value is less than 0.5 otherwise it sets the alpha value to 1. For example, if you have a path with blue fill colour and alpha set to 25%, then the fill colour for that path will be changed to none. Whereas, if you have a path with blue fill colour and alpha set to 75%, then the fill colour for that path will be changed to blue with 100% alpha.

Note that PostScript doesn’t support transparency so the alpha channel will be ignored if you export to PostScript.

See also:
- §8.13 Fade
- §8.11 Reducing to Grey Scale
- §8.12 Colour Space Conversions
- §9.1 Line Colour
- §9.2 Fill Colour
- §9.4 Text Colour

8.15 Moving an Object to the Front

Objects are painted on the page according to the stacking order. This means that objects can partially or wholly obscure other objects in the same location. Each new object is automatically added to the front when it is created, but objects can also be moved to the front either using the move to front button or by selecting Edit → Move to Front (Ctrl-F). Alternatively you can move an object up the stacking order using Edit → Move Up.

See also:
- §8.16 Moving an Object to the Back.

8.16 Moving an Object to the Back

A selected object can be moved to the back of the stack (so that other objects in the same location obscure it) either by clicking the move to back button or by selecting Edit → Move to Back (Ctrl-B). Alternatively you can move an object down the stacking order using Edit → Move Down.

See also:
- §8.15 Moving an Object to the Front.
8.17 Rotating Objects

Selected objects can be rotated either by clicking on the rotate button or by selecting Transform $\rightarrow$ Rotate (Ctrl-W). This will display a dialog box in which you can specify the angle of rotation.

Notes:

- Individual objects will be rotated relative to the centre of the object.
- Objects within a group will be rotated relative to the centre of the group.
- Rotating a text-path will rotate the path and the text will adjust to follow the transformed path.
- Rotating a text area and path and then combining them to form a text-path is not the same as first combining and then rotating.

To illustrate this, in Figure 8.14(a) there are three objects selected. The selection is then rotated $90^\circ$. The result is shown in Figure 8.14(b).

In Figure 8.15, the three objects in Figure 8.14 were first grouped (Figure 8.15(a)) and then rotated $90^\circ$ (Figure 8.15(b)).

In Figure 8.16, the path and text area in Figure 8.16(a) are combined into a text-path, shown in Figure 8.16(b). This text-path is then rotated by $90^\circ$ resulting in Figure 8.16(c). Note that this is different from first rotating the original path and text area, shown in Figure 8.16(d), and then combining them to form a text-path, shown in Figure 8.16(e).

If you prefer to rotate an object using the mouse, you first need to enable the hotspots. Then drag the bottom left hotspot to rotate. Note that even if you have more than one object selected, only the object whose hotspot you are dragging will be transformed.

See also:

- §8.20 Grouping and Ungrouping Objects
8.18 SCALING OBJECTS

Selected objects can be scaled either by clicking on the scale button or by selecting Transform → Scale (Ctrl-Z). This will open up a dialog box in which you can specify the scale factor. (There is a choice of scaling just the x dimension, just the y dimension or both dimensions.)

Notes:

- Individual objects will be scaled relative to the top left corner of the object’s bounding box.
- Objects within a group will be scaled relative to the top left corner of the group’s bounding box.
- Scaling a text-path will scale the path and the text will adjust to follow the transformed path. Note that the text itself will not be scaled.
- Scaling a text area and path and then combining them to form a text-path is not the same as first combining and then scaling.

To illustrate this, in Figure 8.17(a) there are three objects selected. The selection is then scaled by a factor of 2. The result is shown in Figure 8.17(b).

In Figure 8.18, the three objects in Figure 8.17 were first grouped (Figure 8.18(a)) and then scaled by a factor of 2 (Figure 8.18(b)).
8.18 SCALING OBJECTS

Figure 8.16: Rotating a text-path: (a) original text area and path; (b) text area and path in (a) combined to form a text-path; (c) text-path in (b) rotated by 45 degrees; (d) text area and path in (a) rotated by 45 degrees; (e) rotated text area and path in (d) combined to form a text-path.
In Figure 8.19, the path and text area in Figure 8.19(a) are combined into a text-path, shown in Figure 8.19(b). This text-path is then scaled by a factor of 2 resulting in Figure 8.19(c). Note that this is different from first scaling the original path and text area, shown in Figure 8.19(d), and then combining them to form a text-path, shown in Figure 8.19(e).

![Figure 8.17: Three selected objects scaled by a factor of 2: (a) before, (b) after.](image)

![Figure 8.18: A group consisting of three objects scaled by a factor of 2: (a) before, (b) after.](image)

If you prefer to scale an object using the mouse, you first need to enable the hotspots. Then drag the bottom centre hotspot to scale vertically, the bottom right hotspot to scale in both directions or the middle right hotspot to scale horizontally. Note that even if you have more than one object selected, only the object whose hotspot you are dragging will be transformed.

See also:
- §8.20 Grouping and Ungrouping Objects
Figure 8.19: Scaling a text-path: (a) original text area and path; (b) text area and path in (a) combined to form a text-path; (c) text-path in (b) scaled by a factor of 2; (d) text area and path in (a) scaled by a factor of 2; (e) scaled text area and path in (d) combined to form a text-path.
Selected objects can be sheared either by clicking on the shear button or by selecting Transform → Shear (Ctrl-H). This will open up a dialog box in which you can specify the shear factors. The shearing transformation is given by:

\[
\begin{pmatrix}
1 & s_x \\
 s_y & 1
\end{pmatrix}
\begin{pmatrix}
x \\
y
\end{pmatrix}
= 
\begin{pmatrix}
x + s_y y \\
y + s_x x
\end{pmatrix}
\]

Notes:

- Individual objects will be sheared relative to the bottom left corner of the object’s bounding box.
- Objects within a group will be sheared relative to the bottom left corner of the group’s bounding box.
- Shearing a text-path will shear the path and the text will adjust to follow the transformed path. Note that the text itself will not be sheared.
- Shearing a text area and path and then combining them to form a text-path is not the same as first combining and then shearing.
- Shearing a pattern will shear the underlying path not the complete shape.

To illustrate this, in Figure 8.20(a) there are three objects selected. The selection is then sheared with shear factors \( s_x = 1 \) and \( s_y = 0 \). The result is shown in Figure 8.20(b).

In Figure 8.21, the three objects in Figure 8.20 were first grouped (Figure 8.21(a)) and then sheared with shear factors \( s_x = 1 \) and \( s_y = 0 \) (Figure 8.21(b)).

In Figure 8.22, the path and text area in Figure 8.22(a) are combined into a text-path, shown in Figure 8.22(b). This text-path is then sheared with shear factors \( s_x = 1 \) and \( s_y = 0 \) Figure 8.22(c). Note that this is different from first shearing the original path and text area, shown in Figure 8.22(d), and then combining them to form a text-path, shown in Figure 8.22(e).

In Figure 8.23(a), a path created using the ellipse tool has been converted into a rotational pattern with two replicas. This pattern is then sheared with shear factors \( s_x = 1 \) and \( s_y = 0 \), shown in Figure 8.23(b). This is different from the effect obtained by applying the same shear factors to a complete path rather than a pattern. Figure 8.23(c) is a full path version of Figure 8.23(d). This path is then sheared using the same factors and the result is shown in Figure 8.23(d).

If you prefer to shear an object using the mouse, you first need to enable the hotspots. Then drag the top right hotspot to shear vertically or the top left hotspot...
8.19 SHEARING OBJECTS

Figure 8.20: Two selected objects sheared horizontally: (a) before, (b) after.

Figure 8.21: A group consisting of two objects sheared horizontally: (a) before, (b) after.
Figure 8.22: Shearing a text-path: (a) original text area and path; (b) text area and path in (a) combined to form a text-path; (c) text-path in (b) sheared horizontally; (d) text area and path in (a) sheared horizontally; (e) sheared text area and path in (d) combined to form a text-path.
8.19 SHEARING OBJECTS

Figure 8.23: Shearing a pattern: (a) a pattern consisting of an ellipse that has 2 rotational replicas; (b) the pattern in (a) has been sheared horizontally; (c) the pattern in (a) has been converted to a full path; (d) the path in (c) has been sheared horizontally.
to shear horizontally. Note that even if you have more than one object selected, only the object whose hotspot you are dragging will be transformed.

See also:

- §8.20 Grouping and Ungrouping Objects
- §8.17 Rotating Objects
- §8.18 Scaling Objects
- §8.19 Shearing Objects
- p27 Hotspots
- §8.9 Combining a Text Area and Path to Form a Text-Path

### 8.20 Grouping and Ungrouping Objects

A group is a collection of objects that are treated as though they are a single entity. When you select a group, you will only see the bounding box of the entire group, not the bounding boxes of each individual object within the group. If a group is rotated, scaled or sheared, each object within the group will maintain its relative position. Objects within a group may also be aligned. Note that a group can not be edited. Grouping and ungrouping objects may change the stacking order.

To group objects, first select all the objects you want in the group, and then either click on the group button or select the menu item Transform → Group.

To ungroup a group, first select the group, and then either click on the ungroup button or select the menu item Transform → Ungroup. Note that this function is not recursive: if a group contains other groups when you ungroup the outer group, the inner groups will remain. Any description assigned to a group will be lost when it’s ungrouped.

Note that if you ungroup an object containing flowframe related data, the flowframe information will be lost. If you group objects containing flowframe data, and then assign that group flowframe data, any flowframe data assigned to the contents of that group will be removed.

See also:

- §8.17 Rotating Objects
- §8.18 Scaling Objects
- §8.19 Shearing Objects
- §8.21 Aligning Objects
8.21 Aligning Objects

It is only possible to align objects that form part of a group. Objects within a group can be aligned vertically or horizontally using the sub menu Transform → Justify.

Note that alignment is not recursive: if a group contains another group, the contents of the sub group will not be aligned, each element in the sub group will be moved by the same amount.

**Transform → Justify → Left**
Move all objects within the group so that the left edge of each object’s bounding box lies along the left edge of the group’s bounding box. (See Figure 8.24(b).)

**Transform → Justify → Centre**
Move all objects within the group so that they are centred horizontally within the group’s bounding box. (See Figure 8.24(c).)

**Transform → Justify → Right**
Move all objects within the group so that the right edge of each object’s bounding box lies along the right edge of the group’s bounding box. (See Figure 8.24(d).)

**Transform → Justify → Top**
Move all objects within the group so that the top of each object’s bounding box lies along the top of the group’s bounding box.

**Transform → Justify → Middle**
Move all objects within the group so that they are centred vertically within the group’s bounding box.

**Transform → Justify → Bottom**
Move all objects within the group so that the bottom of each object’s bounding box lies along the bottom of the group’s bounding box.

If the Auto Adjust Anchor checkbox in the TeX Configuration Settings Dialog is selected, any text areas that are contained in a group that is justified will automatically have their anchors changed. For example, in Figure 8.24 one of the objects is a text area. If the auto anchor update facility is enabled, the text area in Figure 8.24(b) will have its horizontal anchor changed to Left, in Figure 8.24(c) it will have its horizontal anchor changed to Centre and in Figure 8.24(d) it will have its horizontal anchor changed to Right. Similarly, applying a vertical alignment will change the vertical anchor to one of: Top, Centre or Bottom. Note that there is no way of aligning text areas along their baseline.3

**Tip:** Sometimes you might want to centre an object relative to another thinner object. In this case it’s better to create a rectangle centred on the thin object that encompasses all the objects you want to justify. Include this rectangle in the group, justify, ungroup and then delete the rectangle. For example, the image shown in Figure 8.25(a) has a text area below the middle line. It would look better if the text was centred below the line, so I grouped the middle line and text area and justified them using Transform → Justify → Centre. The result is shown in Figure 8.25(b). Although the text and line are now centred relative to each other, the line was moved to the centre of the text area, not the other way round. This was not what was intended. Instead, in Figure 8.25(c), I

---

3 However it is possible that the baseline may coincide with the bottom of the text area if the text area doesn’t contain any characters with descenders.
Figure 8.24: Aligning a group consisting of three objects: (a) before; (b) left justified; (c) centre justified; (d) right justified.
created a new rectangle that is centred on the line. Since the line is on a tick mark and the grid lock is on, it is relatively easy to create this rectangle (much easier than trying to move the text area to manually align it). I then grouped the rectangle, the middle line and the text area and justified them using Transform → Justify → Centre. The result is shown in Figure 8.25(d). The justified objects were then ungrouped and the rectangle was deleted to produce Figure 8.25(e).

See also:
• §8.20 Grouping and Ungrouping Objects
• §3.2.9 TeX Settings Dialog
• §11.4 Step-by-Step Example: An Artificial Neuron

8.22 Reversing a Path’s Direction
The direction of a path or text-path can be reversed using Transform → Reverse Path. For example, the path in Figure 8.26 has a bar start marker, pointed arrow mid-markers and a \LaTeX{} style arrow end marker. Figure 8.26(a) shows the original path, and Figure 8.26(b) shows the reversed path. Note that all the control points are in the same place, but their ordering has changed.

In Figure 8.27, the text-path in Figure 8.27(a) is reversed to form Figure 8.27(b). Note that the text now starts from the right instead of the left, since the first control point is now on the right, and it is upside-down.

8.23 Merging Paths
Multiple shapes can be merged into a single shape using the menu item Transform → Merge Paths. Note that this is not the same as grouping. Moves (gaps) will be placed between the last control point of one path and the first control point of the next path. Any pattern in the selection will be first converted to a full path before merging.

Once the shape has been merged, it can then be edited. If the original shapes had different styles, the new shape will retain the style of the first shape (the lowest one in the stack). For example, in Figure 8.28(a) there are two paths with different styles. Figure 8.28(b) shows the single path created from merging the two original paths. Since the first path used the even-odd winding rule, the new shape has a hole in it.

The same applies if one or more of the selected objects is a text-path. For example, in Figure 8.29(a) there are two text-paths. These are merged to form a single text-path shown in Figure 8.29(b). Note that the text from the second text-path is lost. The resulting path is shown in edit mode in Figure 8.29(c) to illustrate the underlying path. A mixture of paths and text-paths can be merged. The resulting object will be a text-path if the first object to be merged is a text-path, otherwise it will be a path.

Paths are merged according to their stacking order. For example, in Figure 8.30(a) there are two paths, both with a bar start marker, and an arrow end marker. The path on the right is further back in terms of the stacking order. (That is, it gets painted on the canvas before the other path.) Figure 8.30(b) shows the result of merging the two paths — the left hand path has been appended to the right hand path. Figure 8.30(c) shows the same two paths as in Figure 8.30(a) except that now the left path is the backmost object. There is no visible difference between Figure 8.30(a) and Figure 8.30(c),
Figure 8.25: Aligning a wider object relative to a thinner object: (a) original image; (b) middle line and text area have been grouped and justified; (c) rectangle added to original image centred on the middle line; (d) rectangle, middle line and text area have been grouped and justified; (e) justified objects have been ungrouped and the rectangle has been deleted.
Figure 8.26: Reversing the direction of a path: (a) original path; (b) reversed path — the vertices are in the same location, but the order has been reversed.

Figure 8.27: Reversing the direction of a text-path: (a) original text-path; (b) reversed text-path — the vertices are in the same location, but the order has been reversed so the text starts from the other end.

Figure 8.28: Merging two paths: (a) the first path has a solid line pattern, a green fill colour and even-odd winding rule, and the second path has a dashed line pattern and a yellow fill colour; (b) resulting merged path has a solid line pattern, green fill colour and even-odd winding rule.
8.23 MERGING PATHS

Figure 8.29: Merging two text-paths: (a) the first path is on the left and the second path is on the right; (b) resulting merged path; (c) resulting merged path in edit mode to illustrate the underlying path.
but the result of merging the paths in Figure 8.30(c) (see Figure 8.30(d)) is different to Figure 8.30(b) — the right hand path has been appended to the left hand path.

Figure 8.30: Paths are merged according to the stacking order: (a) two straight line paths where the path on the right is at the back of the stack; (b) new single path resulting from merging the two paths in (a); (c) same as (a) but the path on the left is at the back of the stack; (d) new single path resulting from merging the two paths in (c).

See also:

- §8.24 Path Union
- §8.25 Exclusive Or Function
- §8.26 Path Intersection
- §8.27 Path Subtraction
- p61 Breaking a Path
- §8.22 Reversing a Path’s Direction
- §11.3 Step-by-Step Example: Cheese and Lettuce on Toast
8.24 Path Union

Multiple shapes can be combined into a single shape by performing a union on all the selected shapes using the menu item Transform → Path Union. At least two shapes must be selected to perform this function. As with the merge path function, the new shape has the same styles as the backmost path in the selection.

For example, in Figure 8.31(a), there are three overlapping paths. In Figure 8.31(b) the paths have been replaced by a single path created using the path union function. For comparison, the same three paths in Figure 8.31(a) were replaced using the merge function. The result is shown in Figure 8.31(c).

![Figure 8.31: Path union: (a) original paths (the rear path has an orchid fill colour, 2bp line width and round join style); (b) the three paths in (a) have been replaced by a single path using the path union function; (c) for comparison, the three paths in (a) have been replaced by a single path using the merge paths function.](image)

In Figure 8.32, a text-path and a path are combined: Figure 8.32(a) shows the original objects and Figure 8.32(b) shows the resulting object. In this case, the resulting object is a text-path since the backmost path in Figure 8.32(a) was the text-path object.

Any pattern in the selection will first be converted to a full path before the union is applied. For example, in Figure 8.33, two patterns are combined: Figure 8.33(a) shows the original patterns (both have a rotational pattern with 2 replicas) and Figure 8.33(b) shows the resulting path. This path is illustrated in edit mode in Figure 8.33(c) to show that it is now a full path.

See also:

• §8.23 Merging Paths
8.25 Exclusive Or Function

Multiple shapes can be combined into a single shape by performing an exclusive or (XOR) operation on all the selected shapes using the menu item Transform → XOR Paths. At least two shapes must be selected to perform this function. As with the merge path function, the new shape has the same styles as the backmost path in the selection and patterns will be converted to full paths.

For example, in Figure 8.34(a), there are three overlapping paths. The rear path has a non-zero winding rule. In Figure 8.34(b) the paths have been replaced by a single path created using the exclusive OR function. For comparison, the same three paths in Figure 8.34(a) were replaced using the merge function. The result is shown in Figure 8.34(c). Both paths in Figure 8.34(b) and Figure 8.34(c) use a non-zero winding rule, since that was used by the rear path in Figure 8.34(a).

See also:

- §8.23 Merging Paths
- §8.24 Path Union
- §8.26 Path Intersection
- §8.27 Path Subtraction
8.25 EXCLUSIVE OR FUNCTION

Figure 8.33: Pattern union: (a) original patterns; (b) patterns in (a) have been combined to form a full path; (c) result shown in edit mode.
Figure 8.34: Exclusive OR function: (a) original paths (the rear path has a non-zero winding rule, orchid fill colour and round join style); (b) the three paths in (a) have been replaced by a single path using the exclusive OR function; (c) for comparison, the three paths in (a) have been replaced by a single path using the merge paths function.
8.26 Path Intersection

Multiple shapes can be combined into a single shape by performing an intersection on all the selected shapes using the menu item Transform → Path Intersect. At least two shapes must be selected to perform this function (or one of each), and at least two of the shapes (or underlying path in the case of a text-path) must overlap. As with the merge path function, the new shape has the same styles as the backmost path in the selection and patterns are converted to full paths.

For example, in Figure 8.35(a), there are three overlapping paths. In Figure 8.35(b) the paths have been replaced by a single path created using the path intersect function.

![Figure 8.35: Path intersection function: (a) original paths (the rear path has an orchid fill colour and round join style); (b) the three paths in (a) have been replaced by a single path using the path intersect function.](image)

See also:
- §8.23 Merging Paths
- §8.24 Path Union
- §8.25 Exclusive Or Function
- §8.27 Path Subtraction
- p61 Breaking a Path
- §8.22 Reversing a Path’s Direction

8.27 Path Subtraction

Multiple shapes can be combined into a single shape by performing a subtraction on all the selected shapes using the menu item Transform → Subtract Paths. At least two shapes must be selected to perform this function. The new shape is the backmost
selected shape with the other selected shapes subtracted from it. Any patterns in the selection will be converted to full paths.

For example, in Figure 8.36(a), there are three overlapping paths. In Figure 8.36(b) the paths have been replaced by a single path created using the path subtraction function.

The new path will be a text-path if the backmost selected object was a text-path and the text will adjust to fit the new underlying path. For example, in Figure 8.37(a), there is a text-path and a path. The text-path is the backmost path. In Figure 8.37(b), the two objects have been replaced by a single text-path using the path subtraction function.

![Figure 8.36: Path subtraction function: (a) original paths (the rear path has an orchid fill colour and round join style); (b) the three paths in (a) have been replaced by a single path using the path subtraction function.](image)

![Figure 8.37: Subtracting from a text-path: (a) original text-path and path; (b) the path has been subtracted from the underlying path of the text-path.](image)

See also:

- §8.23 Merging Paths
- §8.24 Path Union
- §8.25 Exclusive Or Function
8.28 Separating a Text-Path into a Text Area and Path

A text-path can be separated into a group containing the text area and path that made up the text-path. Note that any line styles that were applied to the path before combining it with the text area will be lost, and the resulting path will use the default styles with the line colour the same as the text colour from the text-path.

For example, in Figure 8.38 the text area and path in Figure 8.38(a) are combined to form the text-path in Figure 8.38(b). The text-path is the separated into a group containing a text area and a path. Note that the new path has lost the line style shown in Figure 8.38(a) and is now the same colour as the text.

You may have noticed from Figure 8.38 that the fill colour has been retained. This is because it may be needed if the outline mode is on. If a non-outline text-path is switched to outline mode with a filled interior, that colour will be applied to the new path, as illustrated in Figure 8.39.

See also:

• §8.9 Combining a Text Area and Path to Form a Text-Path
• §8.31 Splitting Text Areas
• §8.30.1 Converting a Text Area, Text-Path or Pattern to a Path

8.29 Converting a Path or Text-Path into a Pattern

A path or text-path can be converted into a pattern using Transform → Pattern. You need to specify the number of replicates and whether or not the original path or text-path should be displayed. For example, if you specify 4 replicates and show the original, there will be 5 versions of the shape: the original and the 4 replicas. The following pattern types are available:

Rotational The replicates will be rotated around the original shape. For example, if you specify an angle of 90° and 4 replicas, the first replicate with be created by rotating a copy of the original by 90°, the second replicate by 180°, the third by 270° and the fourth replicate by 360°, which will superimpose it over the original.

The point of rotation is initially set to the centre of the original shape, but can be moved to a different location when the shape is in edit mode. (See Figure 8.40.)

Scaled The replicates will be scaled versions of the original shape. There are two control points that govern the pattern: the anchor, which can be freely moved, and the offset, which is constrained to lie along the scaling axis. (See Figure 8.41.)
Figure 8.38: Separating the text and path from a text-path: (a) original path and text area; (b) path and text area in (a) combined to form a text-path; (c) text-path in (b) separated into a group containing a text area and a path.
8.29 CONVERGING A PATH OR TEXT-PATH INTO A PATTERN

Figure 8.39: Separating the text and path from an outline text-path: (a) original path and outline text area; (b) path and outline text area in (a) combined to form an outline text-path; (c) outline text-path in (b) separated into a group containing an outline text area and a path.
8.29 CONVERTING A PATH OR TEXT-PATH INTO A PATTERN

Figure 8.40: A rotational pattern: (a) original path; (b) the path in (a) has a rotational pattern applied with 3 replicas, 90° angle of rotation, with the original path visible; (c) the pattern in (b) in edit path mode: the green control indicates the point of rotation; (d) the point of rotation has been move to the right, changing the shape of the pattern.
8.29 CONVERTING A PATH OR TEXT-PATH INTO A PATTERN

Figure 8.41: A scaled pattern. The original path is the same as in Figure 8.40(a): (a) the path has a scaled pattern applied with two replicas, the horizontal scale factor set to 2 and the vertical scale factor set to 1.5; (b) the pattern in (a) in edit path mode: the green control is the anchor and the cyan control is the offset; (c) the anchor has been moved to the left.
8.29 CONVERTING A PATH OR TEXT-PATH INTO A PATTERN

**Spiral** The replicates will be placed in a spiral around the original with the given incremental angle. There are again two control points that govern the pattern: the anchor and offset, which can both be moved freely. (See Figure 8.42.)

![Figure 8.42: A spiral pattern. The original path is the same as in Figure 8.40(a): (a) the path has a spiral pattern applied with ten replicas, the increment angle set to 60° and a gap of 50bp; (b) the pattern in (a) in edit path mode: the green control is the anchor and the cyan control is the offset; (c) the anchor has been moved down. All patterns have two modes: **Single** the pattern is drawn as a single path (see Figure 8.43(b)). **Multi** the original and each replicate are drawn as separate independent shapes (see Figure 8.43(c)).

Note that a text-path created by applying text to a multi-mode pattern produces a different result to applying the same multi-mode pattern to a text-path. (See Figure 8.44.)

See also:
- §8.9 Combining a Text Area and Path to Form a Text-Path
Figure 8.43: Patterns can either be single or multi-mode: (a) original path has a bar start marker, a triangle end-marker and a gradient fill paint; (b) the path in (a) has a rotational pattern applied with single mode set; (c) the same pattern as (b) but with multi-mode.
Figure 8.44: Text-path multi-mode patterns: (a) original text area and path; (b) text area and path in (a) combined to form a text-path; (c) a scaled multi-mode pattern is applied to the text-path with 2 replicas and scale factors 2.0 and 1.5; (d) the path in (a) has the same scaled multi-mode pattern applied; (e) the text area and pattern in (d) have been combined to form a text-path; (f) the pattern in (b) has been changed from multi-mode to single-mode.
8.30 CONVERTING TO A PATH

§11.10 Step-by-Step Example: A Lute Rose

8.30 Converting to a Path

It is possible to convert the outline of a shape, text area or text-path to a path using the menu item Transform \rightarrow Convert Outline To Path. Note that the convert to path function cannot be applied to groups or bitmaps.

8.30.1 Converting a Text Area, Text-Path or Pattern to a Path

To convert the outline of a text area, text-path or pattern to a path, first select the text area, text-path or pattern and select the menu item Transform \rightarrow Convert Outline To Path. The text will then be converted to a group of paths where each path approximates the shape of the corresponding character. Converting a text area or text-path to a path allows you to:

- include the image in \LaTeX document when you don’t have the equivalent \LaTeX font;
- make a \texttt{\parshape} or \texttt{\shapepar} from the text’s outline.

Note that you will have to ungroup the paths before you can edit them. If you had a gradient paint text colour, the gradient will be applied to each path. You can however, merge the paths, which will apply a single gradient resembling the original text area (see Figure 8.45).

\begin{center}
\begin{tabular}{ccc}
Sample & Sample & Sample \\
(a) & (b) & (c)
\end{tabular}
\end{center}

Figure 8.45: Converting a text area to a path: (a) original text area; (b) converted to a path; (c) ungroup and merge paths.

8.30.2 Converting an Outline to a Path

To convert the outline of a path to a path, first select the path and select the menu item Transform \rightarrow Convert Outline To Path. For example, consider the path in Figure 8.46(a). This has a line width of 10bp, a circle start marker, a triangle end arrow, a gradient line colour and a yellow fill colour. Figure 8.46(b) shows this path in edit mode to show the path’s defining control points. In Figure 8.46(c), the path’s outline has been converted to a path. This new path now has a gradient fill colour with a line width of 1bp and no start or end arrows. The new path’s defining control points are shown in Figure 8.46(d).

8.31 Splitting Text Areas

A text area or text-path can be split into a group containing text areas each consisting of a single character. The original alternative \LaTeX text will be lost. (No mappings will be used.)
8.31 SPLITTING TEXT AREAS

Figure 8.46: Converting an outline to a path: (a) the original path; (b) the original path’s defining control points; (c) the new path; (d) the new path’s defining control points.
For example, in Figure 8.47(a) there is a single text area containing the seven characters that make up the word “Rainbow”. This text area was then converted into a group of seven text areas using Transform → Split Text. The group was then ungrouped (see Figure 8.47(b)) and each text area was then given a different text colour resulting in the image shown in Figure 8.47(c).

Note that if you split a text-path, you will lose the underlying path as the result will be a group of text areas. For example, the text-path shown in Figure 8.48(a) was split to create a group containing seven text areas.
8.31 SPLITTING TEXT AREAS

Figure 8.48: Splitting a text path: (a) original text path; (b) split and ungroup; (c) apply separate colours to each of the new text areas.
9 Path and Text Styles

The way a path is displayed is governed by the line colour, the fill colour, the line styles (such as pen width and markers) and the winding rule. The way a text area is displayed is governed by the text colour, font, transformation matrix and (if exporting to a \LaTeX file) the anchor. The way a text-path is displayed is governed by the text colour, font, anchor, transformation matrix and the underlying path. (A text area or text-path may also be rendered as an outline optionally with a fill colour, see §8.10 Text Outlines.)

The current path colours and styles can be set using the Settings → Styles dialog box. This dialog box has a tabbed pane with five tabs. The tabs for setting the current path attributes are labelled: Line Colour, Fill Colour and Line Style. There is a sample panel on the right hand side illustrating the effects of the path settings you choose. The tabs for setting the current text area attributes are labelled: Text Colour and Font. There is a sample panel along the top illustrating the effects of the text area attributes you choose. Any subsequent new paths or text areas will be given the styles specified by the Settings → Styles dialog box. The current styles are saved when you exit FlowframTk, and will be in effect next time you use FlowframTk, unless you change the startup settings (see subsection 3.2.8). To restore the default settings, click on the Default button.

To change the style of an existing path, first select the path, and then use the Edit → Path sub menu: the line colour can be changed using the Edit → Path → Line Colour dialog box. The fill colour can be changed using the Edit → Fill Colour dialog box. The line style can be changed using the Edit → Path → Line Styles sub menu. If you have more than one path selected, the chosen attributes will be applied to all the paths in the selection. This is applied recursively through all paths within each selected group. Note that the Edit → Path dialog boxes only affect selected paths and do not affect new paths. You must use the Settings → Styles dialog box to set the current styles.

To change the style of an existing text area, first select the text area, and then use the Edit → Text sub menu: the text colour can be changed using Edit → Text → Text Colour and the text attributes can be changed using the Edit → Text → Font Style sub menu. If you have more than one text area selected, the chosen attributes will be applied to all the text areas in the selection. This is applied recursively through all text areas within each selected group. Note that the Edit → Text dialog boxes only affect selected text areas and do not affect new text areas. You must use the Settings → Styles dialog box to set the current styles.

9.1 Line Colour

The line colour is the colour used to draw the path’s outline. You can specify one of the following:

**Transparent**  No colour (the outline is not drawn).

**Colour**  A single colour is used for the outline. This can be specified as RGB (red green blue), CMYK (cyan magenta yellow black), HSB (hue saturation brightness) or grey scale. The alpha value changes the opacity (maximum value is solid, zero is completely transparent and a value in between produces a semi-transparent effect).
9.2 Fill Colour

The fill colour is the colour used to fill the path’s interior (the interior is defined by the winding rule). It’s also used to fill a text area or text-path outline.

You can specify one of the following:

- **Transparent** No colour (the path or outline is not filled).
- **Colour** A single colour is used to fill the path or outline. This can be specified as RGB (red green blue), CMYK (cyan magenta yellow black), HSB (hue saturation brightness) or grey scale. The alpha value changes the opacity (maximum value is solid, zero is completely transparent and a value in between produces a semi-transparent effect).
- **Gradient** A two-tone gradient is used for the outline. This requires a start colour and an end colour. The shading may be linear or radial: if linear, you need to specify a direction using one of the direction buttons; if radial, you need to specify the starting location using one of the buttons provided.

Note that the colours you see on the screen may not exactly match colours produced by your printer due to the non-invertible mapping between colour spaces.

The colours are specified as integer values between 0 and 100, or between 0 and 359 in the case of hue. You can type in the number in the appropriate box or use the slider bars or you can click on one of the predefined colour buttons.

If you use one of the export functions, note:

- Gradient paint line colour will be implemented by exporting the line as a filled outline. There may be slight differences in the resulting shading. In particular, the \LaTeX export functions will average the start and end colour alpha channels over the whole shading.
- PostScript doesn’t support transparency
- All colours will be converted to RGB when exporting to a PNG file, and the background will be set to white.
9.3 **LINE STYLE**

The line style is made up of the following attributes: line thickness, dash pattern, cap style, join style, markers and winding rule.

### 9.3.1 Line Thickness (or Pen Width)

The line thickness is the width of the line defining the path’s border. This value is specified in the **Pen Width** box.

### 9.3.2 Dash Pattern

A path can be drawn either as a solid line or with a dash pattern. Select the **Solid Line** button for a solid line or select the **Dashed Line** button for a dash pattern. The latter will enable the Offset, Dash and Gap fields. The offset is the distance from the starting vertex of the path to the start of the first dash. The dash pattern will then repeat line and gap pairs, where the line length is given by the Dash field and the gap length is given by the Gap field.

A dash-dot pattern can be obtained by selecting the **Secondary** checkbox and entering the secondary dash length and gap length. For example, in Figure 9.1 path (a) has a solid line; path (b) has a dash pattern with an offset of 0bp, dash length of 10bp and gap length of 5bp; path (c) is the same as path (b) except that the dash pattern has an offset of 10bp; path (d) has no offset, a primary pair of dash length 10bp and gap length 5bp, and a secondary pair of dash length 1bp and gap length 5bp which gives a dash-dot pattern.

![Figure 9.1: Example dash patterns: (a) solid line; (b) dash length 10bp and gap length 5bp; (c) dash length 10bp, gap length 5bp and 10bp offset; (d) primary dash length 10bp with gap length 5bp and secondary dash length 1bp with gap length 5bp.](image)

### 9.3.3 Cap Style

The cap style can be one of: butt, round or square. (See Figure 9.2.) Note that the cap is affected by whether the path is open or closed. In Figure 9.3(a) the path is an open path where the end points happen to coincide; in Figure 9.3(b) the path is a closed path.

See also:

- §11.1 Step-by-Step Example: A House
Figure 9.2: Cap styles: (a) butt, (b) round, (c) square. Note that the round and square caps protrude from the start and end vertices.

Figure 9.3: The cap style is affected by whether the path is open or closed: (a) butt cap applied to an open path; (b) butt cap applied to a closed path.
9.3.4 Join Style

The join style can be one of: mitre, round or bevel. (See Figure 9.4.) If a mitre join style is selected, you can also specify the mitre limit, which must be a value greater than or equal to 1.0.

![Figure 9.4: Join styles: (a) mitre, (b) round, (c) bevel.](image)

9.3.5 Markers

The start, mid and end markers are placed on the start, mid-point and end vertices, respectively. Some of the markers require a size, some of them are dependent on the line width and some of them require a size as well as being dependent on the line width.

Markers on existing paths can be set using the menu item Edit → Path → Line Styles → All Styles, and clicking on the Select button next to the appropriate marker label. This will open up the marker dialog box. Alternatively, if the start, mid and end markers all need to be the same, the menu item Edit → Path → Line Styles → All Markers can be used to set them all at the same time.

Enabling or Disabling a Marker

To enable a marker, select the Use Marker radio button, or to disable a marker, select the No Marker radio button. Selecting the Use Marker radio button will enable the marker type selector.

Marker Types

Marker types are divided into six categories: arrow style markers, partial arrow markers, data point style markers, bracket style markers, decorative markers and cap style markers. Note that the cap style markers do not replace the line cap style, but are in addition to the line cap style. However the cap style markers generally look best in combination with the butt cap line style.

Available markers are listed in Table 9.1 (arrow style markers), Table 9.2 (partial arrow markers), Table 9.3 (data point style markers), Table 9.4 (bracket style markers), Table 9.5 (cap style markers) and Table 9.6 (decorative markers).
Table 9.1: Available marker styles and dependencies for arrow style markers. (Line width=2bp, marker size=8bp, butt cap style.) Markers are shown in red to distinguish them from the line.

<table>
<thead>
<tr>
<th>Marker</th>
<th>Size?</th>
<th>Line Width Dependent?</th>
<th>Centred on Vertex?</th>
<th>Sample</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pointed</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Pointed 60</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Pointed 45</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Cusp</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>LaTeX</td>
<td>N/A</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Alt LaTeX</td>
<td>N/A</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Triangle Open</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Triangle</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Equilateral Filled</td>
<td>Required</td>
<td>Independent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Equilateral Open</td>
<td>Required</td>
<td>Independent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Hooks</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
</tbody>
</table>

Table 9.2: Available marker styles and dependencies for partial arrow style markers. (Line width=2bp, marker size=8bp, butt cap style.) Markers are shown in red to distinguish them from the line.

<table>
<thead>
<tr>
<th>Marker</th>
<th>Size?</th>
<th>Line Width Dependent?</th>
<th>Centred on Vertex?</th>
<th>Sample</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hook Up</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Hook Down</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Half Pointed Up</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Half Pointed Down</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Half Pointed 60 Up</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Half Pointed 60 Down</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Half Pointed 45 Up</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Half Pointed 45 Down</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Half Cusp Up</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Half Cusp Down</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
</tbody>
</table>
Table 9.3: Available marker styles and dependencies for data point style markers. (Line width=2bp, marker size=8bp, butt cap style.) Markers are shown in red to distinguish them from the line.

<table>
<thead>
<tr>
<th>Marker</th>
<th>Size?</th>
<th>Line Width Dependent?</th>
<th>Centred on Vertex?</th>
<th>Sample</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dot Filled</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="sample1" alt="Sample" /></td>
</tr>
<tr>
<td>Dot Open</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="sample2" alt="Sample" /></td>
</tr>
<tr>
<td>Box Filled</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="sample3" alt="Sample" /></td>
</tr>
<tr>
<td>Box Open</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="sample4" alt="Sample" /></td>
</tr>
<tr>
<td>Cross</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="sample5" alt="Sample" /></td>
</tr>
<tr>
<td>Plus</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="sample6" alt="Sample" /></td>
</tr>
<tr>
<td>Star</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="sample7" alt="Sample" /></td>
</tr>
<tr>
<td>Asterisk</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="sample8" alt="Sample" /></td>
</tr>
<tr>
<td>Open 5 Pointed Star</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="sample9" alt="Sample" /></td>
</tr>
<tr>
<td>Filled 5 Pointed Star</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="sample10" alt="Sample" /></td>
</tr>
<tr>
<td>Open 6 Pointed Star</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="sample11" alt="Sample" /></td>
</tr>
<tr>
<td>Filled 6 Pointed Star</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="sample12" alt="Sample" /></td>
</tr>
<tr>
<td>Triangle Up Filled</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="sample13" alt="Sample" /></td>
</tr>
<tr>
<td>Triangle Up Open</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="sample14" alt="Sample" /></td>
</tr>
<tr>
<td>Triangle Down Filled</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="sample15" alt="Sample" /></td>
</tr>
<tr>
<td>Triangle Down Open</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="sample16" alt="Sample" /></td>
</tr>
<tr>
<td>Rhombus Filled</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="sample17" alt="Sample" /></td>
</tr>
<tr>
<td>Rhombus Open</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="sample18" alt="Sample" /></td>
</tr>
<tr>
<td>Pentagon Filled</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="sample19" alt="Sample" /></td>
</tr>
<tr>
<td>Pentagon Open</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="sample20" alt="Sample" /></td>
</tr>
<tr>
<td>Hexagon Filled</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="sample21" alt="Sample" /></td>
</tr>
<tr>
<td>Hexagon Open</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="sample22" alt="Sample" /></td>
</tr>
<tr>
<td>Octagon Filled</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="sample23" alt="Sample" /></td>
</tr>
<tr>
<td>Octagon Open</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="sample24" alt="Sample" /></td>
</tr>
<tr>
<td>Filled Semicircle</td>
<td>Required</td>
<td>Independent</td>
<td>No</td>
<td><img src="sample25" alt="Sample" /></td>
</tr>
<tr>
<td>Open Semicircle</td>
<td>Required</td>
<td>Independent</td>
<td>No</td>
<td><img src="sample26" alt="Sample" /></td>
</tr>
</tbody>
</table>
9.3.5 MARKERS

Table 9.4: Available marker styles and dependencies for bracket style markers. (Line width=2bp, marker size=8bp, butt cap style.) Markers are shown in red to distinguish them from the line.

<table>
<thead>
<tr>
<th>Marker</th>
<th>Size?</th>
<th>Line Width Dependent?</th>
<th>Centred on Vertex?</th>
<th>Sample</th>
</tr>
</thead>
<tbody>
<tr>
<td>Square Bracket</td>
<td>N/A</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Bar</td>
<td>N/A</td>
<td>Dependent</td>
<td>Yes</td>
<td></td>
</tr>
<tr>
<td>Round Bracket</td>
<td>N/A</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Brace</td>
<td>N/A</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Alt Square</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Alt Bar</td>
<td>Required</td>
<td>Dependent</td>
<td>Yes</td>
<td></td>
</tr>
<tr>
<td>Alt Round</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Alt Brace</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
</tbody>
</table>

Table 9.5: Available marker styles and dependencies for cap style markers. (Line width=10bp, marker size=5bp, butt cap style.) The cap style markers are designed to be flush against the line, so they are only clearly visible for thick lines. Markers are shown in red to distinguish them from the line.

<table>
<thead>
<tr>
<th>Marker</th>
<th>Size?</th>
<th>Line Width Dependent?</th>
<th>Centred on Vertex?</th>
<th>Sample</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rectangle Cap</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Round Cap</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Triangle Cap</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Inverted Triangle Cap</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Chevron Cap</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Inverted Chevron Cap</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Fast Cap</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Inverted Fast Cap</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Ball Cap</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
</tbody>
</table>

Continued on Next Page
9.3.5 MARKERS

Continued from Previous Page

<table>
<thead>
<tr>
<th>Marker</th>
<th>Size?</th>
<th>Line Width Dependent?</th>
<th>Centred on Vertex?</th>
<th>Sample</th>
</tr>
</thead>
<tbody>
<tr>
<td>Leaf Cap</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Double Leaf Cap</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Triple Leaf Cap</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Club Cap</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Forward Triple Leaf Cap</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Backwards Triple Leaf Cap</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Forward Double Leaf Cap</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Backwards Double Leaf Cap</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Bulge Cap</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Cutout Bulge Cap</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
</tbody>
</table>

Marker Size

The Size box will be enabled for only the resizeable markers. This box can be used to vary the marker size, but some markers also depend on the line width, so the size box is only meant as a general guide.

Repeating Markers

Markers can be doubled or tripled by selecting the Double or Triple radio boxes. To go back to a single marker, select the Single radio box. Figure 9.5 illustrates single, double and triple repeat markers for a path with a LaTeX style end arrow. Note that the
Table 9.6: Available marker styles and dependencies for decorative markers. (Line width=2bp, marker size=8bp, butt cap style.) Markers are shown in red to distinguish them from the line.

<table>
<thead>
<tr>
<th>Marker</th>
<th>Size?</th>
<th>Line Width Dependent?</th>
<th>Centred on Vertex?</th>
<th>Sample</th>
</tr>
</thead>
<tbody>
<tr>
<td>Circle</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td><img src="image1" alt="Circle" /></td>
</tr>
<tr>
<td>Diamond</td>
<td>N/A</td>
<td>Dependent</td>
<td>No</td>
<td><img src="image2" alt="Diamond" /></td>
</tr>
<tr>
<td>Circle Open</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td><img src="image3" alt="Circle Open" /></td>
</tr>
<tr>
<td>Diamond Open</td>
<td>N/A</td>
<td>Dependent</td>
<td>No</td>
<td><img src="image4" alt="Diamond Open" /></td>
</tr>
<tr>
<td>Scissors Up Filled</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td><img src="image5" alt="Scissors Up Filled" /></td>
</tr>
<tr>
<td>Scissors Down Filled</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td><img src="image6" alt="Scissors Down Filled" /></td>
</tr>
<tr>
<td>Scissors Up Open</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td><img src="image7" alt="Scissors Up Open" /></td>
</tr>
<tr>
<td>Scissors Down Open</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td><img src="image8" alt="Scissors Down Open" /></td>
</tr>
<tr>
<td>Right Heart Filled</td>
<td>Required</td>
<td>Independent</td>
<td>No</td>
<td><img src="image9" alt="Right Heart Filled" /></td>
</tr>
<tr>
<td>Right Heart Open</td>
<td>Required</td>
<td>Independent</td>
<td>No</td>
<td><img src="image10" alt="Right Heart Open" /></td>
</tr>
<tr>
<td>Heart Filled</td>
<td>Required</td>
<td>Independent</td>
<td>No</td>
<td><img src="image11" alt="Heart Filled" /></td>
</tr>
<tr>
<td>Heart Open</td>
<td>Required</td>
<td>Independent</td>
<td>No</td>
<td><img src="image12" alt="Heart Open" /></td>
</tr>
<tr>
<td>Snowflake</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="image13" alt="Snowflake" /></td>
</tr>
<tr>
<td>Star Chevron Open</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="image14" alt="Star Chevron Open" /></td>
</tr>
<tr>
<td>Star Chevron Filled</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="image15" alt="Star Chevron Filled" /></td>
</tr>
</tbody>
</table>
9.3.5 MARKERS

Markers are placed along the gradient vector which means that they may not lie on the actual path. (See Figure 9.6.)

(a) (b) (c)

Figure 9.5: Repeat markers: (a) single, (b) double, (c) triple.

Figure 9.6: Repeat markers are placed along the gradient vector.

Reversing Markers

Markers can be reversed by selecting the Reversed checkbox. (See Figure 9.7.)

(a) (b) (c)

Figure 9.7: Reversed markers: (a) single reversed, (b) double reversed, (c) triple reversed.

Composite Markers

A marker can be combined with another marker by selecting the Composite checkbox which will enable the secondary marker tab. If the Overlay checkbox is selected, the primary and secondary markers will be positioned so that their origins coincide, otherwise the secondary marker will be offset from the primary marker (see also Marker Offset below). Figure 9.8 shows two examples of composite markers: in Figure 9.8(a) the start and end markers are formed from a pointed arrow primary marker of size 5bp and a composite bar secondary marker, while in Figure 9.8(b) the start and end markers are formed from an open semicircle primary marker of size 5bp with an overlaid reversed filled semicircle secondary marker of size 5bp.

Marker Orientation

If the Auto Orientation box is checked, the marker will be rotated so that the marker’s x-axis lies along the path’s gradient vector (start markers point in the opposite direction). If this box is not checked, the marker will be rotated according to the angle specified (in degrees) in the box next to the Auto Orientation box.
9.3.5 MARKERS

Figure 9.8: Examples of composite markers: (a) a bar primary marker with a pointed secondary marker of size 5bp; (b) an open semicircle primary marker of size 5bp overlaid with a reversed filled semicircle secondary marker of size 5bp.

Marker Offset

If the Auto Offset box is checked, the marker’s offset from the vertex will be computed automatically. (The primary marker will be placed with its origin coinciding with the vertex, but the secondary marker will be offset from the primary marker according to whether any duplicate markers have been specified and according to the line width.) If this box is not checked, the marker will be offset according to the length specified in the adjoining box. Examples: in Figure 9.9(a) both the start and end markers have been set to the \LaTeX style marker with an offset of $-10\text{bp}$, and in Figure 9.9(b) both the start and end markers are composite markers formed from a bar primary marker and a pointed secondary marker, where the secondary marker’s offset has been set to $2\text{bp}$. Note that setting the secondary marker’s offset to 0 is equivalent to using the overlay function.

Note that markers are placed along the path’s gradient vector, so the marker may not necessarily lie on the path. For example, in Figure 9.10, a marker with offset $10\text{bp}$ has been placed at the end of a Bézier curve. The marker’s offset has moved it along the gradient vector, away from the curve.

Figure 9.9: Disabling the marker auto offset: (a) a negative offset makes the marker protrude off the end of the line; (b) the secondary marker has an offset of $2\text{bp}$ so that it is only slightly behind the primary marker.

Repeat Gap

If the Auto Repeat Gap box is checked, the gap between repeat markers is given by $7$ times the line width. If this box is not selected, the gap will be given by the length specified in the adjoining box. For example, in Figure 9.11(a) a line has an end marker with a triple arrow with the auto repeat function selected. Since the line width is $1\text{bp}$, the gap between the markers is $7\text{bp}$. In Figure 9.11(b) the line width is $2\text{bp}$, so the gap
between the markers is 14bp. In Figure 9.11(c), the line width is 1bp and the repeat gap has been set to 10bp and in Figure 9.11(d) the line width is 2bp again with a repeat gap of 10bp.

![Figure 9.11: Repeat gap: (a) line width of 1bp and auto repeat gap; (b) line width of 2bp and auto repeat gap; (c) line width of 1bp and repeat gap set to 10bp; (d) line width of 2bp and repeat gap set to 10bp.](image)

**Marker Colour**

If the Colour As Path box is checked, the marker will have the same colour as the path. If you want the marker to have a specific colour, you should check the Specific Colour box, which will enable the colour panel. Note that if the marker has been assigned a specific colour, it will remain unchanged if you change the line colour of the path, otherwise it will change with the path. For example, Figure 9.12 shows a path with a transparent line colour and blue start, mid and end markers.

![Figure 9.12: Marker colour may be independent of the line colour: this path has a transparent line colour and blue start, mid and end markers.](image)

Primary and secondary marker colour settings are independent of each other. For example, in Figure 9.13 the start and end markers are composite markers formed from a filled yellow pentagon primary marker and an open pentagon secondary marker. The secondary marker colour is set to the line colour, so if the line colour is changed the pentagon outline will change accordingly, but the filled pentagon will remain yellow.
9.3.6 Winding Rule

The winding rule describes how a path is filled (if it has a fill colour). The winding rule can be either even-odd or non-zero. Figure 9.14 illustrates the difference between the two winding rules. A path was constructed with a gap between the outer and inner rectangles. Figure 9.14(a) shows the effect using the even-odd winding rule and Figure 9.14(b) shows the effect using the non-zero winding rule. The winding rule is also used when extracting the parameters for \texttt{parshape} and \texttt{shapepar}.

Figure 9.14: Winding rules (arrows indicate direction of path): (a) even-odd, (b) non-zero.

See also:
- §11.3 Step-by-Step Example: Cheese and Lettuce on Toast

9.4 Text Colour

The text colour can be one of the following:

- **Transparent** No colour. A transparent text area is not painted on the canvas, but it does have a bounding box. When exporting to a \LaTeX{} document, transparent text areas have their text set in the argument of \texttt{\textbackslash phantom}.

- **Colour** A single colour. This can be specified as RGB (red green blue), CMYK (cyan magenta yellow black), HSB (hue saturation brightness) or grey scale. The alpha value changes the opacity (maximum value is solid, zero is completely transparent, and a value in between produces a semi-transparent effect.

- **Gradient** A two-tone gradient is used for the outline. This requires a start colour and an end colour. The shading may be linear or radial: if linear, you need to specify a direction using one of the direction buttons; if radial, you need to specify the starting location using one of the buttons provided.

\texttt{FlowframT}k can’t implement paint shadings for text when using one of the \LaTeX{}-related export functions. You can choose how \texttt{FlowframT}k should treat text paint shadings via the TeX Configuration Settings.
Note that the colours you see on the screen may not exactly match colours produced by your printer due to the non-invertible mapping between colour spaces.

The colours are specified as integer values between 0 and 100, or between 0 and 359 in the case of hue. You can type in the number in the appropriate box, or use the slider bars, or you can click on one of the predefined colour buttons.

9.5 Text Style

The text style consists of the font attributes and (if you are exporting to a \LaTeX file) an anchor. The current text styles can be set via the Settings → Styles menu. The style for existing text areas or text-paths can be set via the Edit → Text → Font Style submenu.

9.5.1 Font Family

Use Edit → Text → Font Style → Family to change just the font family for selected text areas or text-paths. To change the current font family to apply to new text areas, use Settings → Styles and select the tab labelled Font.

The drop-down list labelled Font Family (see Figure 9.15) provides a list of locally available fonts. You can select the required font from this list.

When you select a font family, FlowframTk guesses at the appropriate \LaTeX font family declaration. This is used if you export your image as a \LaTeX file. If FlowframTk has guessed incorrectly, you can select a different command from the combo box on the right, or you can edit it if you require a font family declaration that is not listed. Alternatively you can clear the value (by deleting the family declaration) to use the current document font family.

Note that FlowframTk only guesses at a \LaTeX alternative when you select a new font family from the Font Family drop-down list. If there is a particular mapping that you always want, you can create a file called latexfontmap.prop in FlowframTk’s configuration directory. Each line in this file should be in the form:

\(\langle\text{font name}\rangle=\langle\text{LaTeX declaration}\rangle\)

where \(\langle\text{font name}\rangle\) is the name of the font family (e.g. URW Chancery L) and \(\langle\text{LaTeX}\)
9.5.2 FONT SIZE

A declaration is the code used to set the font in a \LaTeX{} document. Blank lines or lines starting with a hash (#) are ignored. For example, on my computer I have the font “URW Chancery L”. If I select this font, the \LaTeX{} equivalent will default to \texttt{\textit{rmfamily}}. However, it would be more appropriate for the \LaTeX{} declaration to select the PSNFSS chancery font. Therefore, I can use my favourite text editor to create a file called \texttt{latexfontmap.prop} with the line

\begin{verbatim}
URW Chancery L=\texttt{\textit{rmfamily}} \texttt{\textit{pzc}} \texttt{\textit{selectfont}}
\end{verbatim}

and save it in FlowframTk’s configuration directory. Next time I start FlowframTk, it will load this mapping and use it whenever I select “URW Chancery L” from the font name selector. Alternatively, you can use a regular expression. For example:

\begin{verbatim}
.*[Cc]hancery.*=\texttt{\textit{rmfamily}} \texttt{\textit{pzc}} \texttt{\textit{selectfont}}
\end{verbatim}

This will select \texttt{\textit{rmfamily}} \texttt{\textit{pzc}} \texttt{\textit{selectfont}} for any font that contains either “Chancery” or “chancery” in its name. It is however faster to use the exact name.

See also:

- §9.5.6 Anchor

9.5.2 Font Size

Use Edit → Text → Font Style → Size to change just the font size for selected text areas or text-paths. To change the current font size to apply to new text areas, use Settings → Styles and select the tab labelled Font.

You can enter the font size in the field labelled Font Size (see Figure 9.16).

When you specify a font size, FlowframTk guesses at the appropriate \LaTeX{} font size declaration. The normal size is taken from the value given in the Document Settings dialog box (unless you have unchecked the Use relative font size declarations checkbox in the \TeX/\LaTeX{} Settings Dialog). This is used if you export your image as a \LaTeX{} file. If FlowframTk has guessed incorrectly, you can select a different command from the combo box on the right, or you can edit it if you require a font size declaration that is not listed. Alternatively you can clear the value (by deleting the size declaration) to use the current document font size. Note that \texttt{\textit{veryHuge}}, \texttt{\textit{VeryHuge}} and

\footnote{This code should be in the form of a declaration (sets the font “from this point onwards”) not a text block command (a command that sets its argument in the given font)}
9.5.3 **FONT SERIES**

\texttt{\textbackslash \textit{\textquotesingle}\textendash \textit{\textquotesingle}Very\textit{\textquotesingle}Huge\textit{\textquotesingle}} are not standard commands, but are defined in the \texttt{a0poster} class file. \texttt{FlowframTk} will only select these commands if the normal font size is 25pt. Remember that if you want to use very large sizes in your \LaTeX{} document, you will need to use scalable fonts rather than the default Computer Modern.

Note that if you change the \texttt{\textbackslash \textit{\textquotesingle}\textbackslash \textit{\textquotesingle}normalsize\textit{\textquotesingle}} value, you will need to reselect the font size for each of the text area’s already present unless the checkbox marked Update all \LaTeX{} font size declarations in current image is selected in the Document Settings dialog box.

See also:

- §9.5.6 Anchor
- §3.2.9 Setting the Document Class and Normal Font Size
- §3.2.9 TeX Settings Dialog

### 9.5.3 Font Series

Use Edit $\rightarrow$ Text $\rightarrow$ Font Style $\rightarrow$ Series to change just the font series for selected text areas. To change the current font series to apply to new text areas, use Settings $\rightarrow$ Styles and select the tab labelled Font.

You can set the font series to medium (normal) or bold by selecting the appropriate item from the drop-down list labelled Font Series (see Figure 9.17).

![Figure 9.17: Setting the Font Series](image)

When you select a font series, \texttt{FlowframTk} guesses at the appropriate \LaTeX{} font series declaration. This is used if you export your image as a \LaTeX{} file. If \texttt{FlowframTk} has guessed incorrectly, you can select a different command from the combo box on the right, or you can edit it if you require a font series declaration that is not listed. Alternatively you can clear the value (by deleting the series declaration) to use the current document font series.

### 9.5.4 Font Shape

Use Edit $\rightarrow$ Text $\rightarrow$ Font Style $\rightarrow$ Shape to change just the font shape for selected text areas or text-paths. To change the current font shape to apply to new text areas, use Settings $\rightarrow$ Styles and select the tab labelled Font.

You can set the font shape to upright (normal) or italic by selecting the appropriate item from the drop-down list labelled Font Shape (see Figure 9.18).
9.5.5 TEXT TRANSFORMATION MATRIX

Select the font shape to use in FlowframTk

The \LaTeX\ command to set the required font shape is selected automatically, but can be edited as required.

Figure 9.18: Setting the Font Shape

When you select a font shape, FlowframTk guesses at the appropriate \LaTeX\ font shape declaration. This is used if you export your image as a \LaTeX\ file. If FlowframTk has guessed incorrectly, you can select a different command from the combo box on the right, or you can edit it if you require a font shape declaration that is not listed. Alternatively you can clear the value (by deleting the shape declaration) to use the current document font shape.

9.5.5 Text Transformation Matrix

In addition to scaling, rotating and shearing a text area, you can also directly modify the transformation matrix using Edit → Text → Transformation Matrix. The transformation matrix for a text area is applied relative to the top left corner of the canvas. The transformation matrix for a text-path is applied relative to the point along the underlying path where each character should be positioned.

Once a text area has been combined with a path to form a text-path, the text can only be transformed by editing the transformation matrix. For example, Figure 9.19 shows a text-path in edit mode (so that you can see the underlying path) with different values of the transformation matrix. In Figure 9.19(a), the transformation matrix is set to the identity matrix, shown in Figure 9.19(b). In Figure 9.19(c), the transformation matrix is set as shown in Figure 9.19(d), (the vertical translation has been set to 10, which is in terms of the storage unit). The text is no longer flush against the path. In Figure 9.19(e), the transformation matrix has been set as shown in Figure 9.19(f), (the horizontal shear element has been set to \(-1\)).

The transformation matrix can be reset via the Transform → Reset Matrix menu item. This will reset the scale and shear factors (but not the translation) for text areas, and will reset all elements for text-paths.

9.5.6 Anchor

For a text-path, the anchor is used to determine where the text should be positioned along the underlying path. Changing the anchor for a text-path will change the way it is displayed in FlowframTk (as illustrated in Figure 8.11 on page 67). For a text area, the anchor is only used when you export the image to a \LaTeX\ file and changing it will not change the way the text area is displayed in FlowframTk. The vertical anchor for text-paths is not supported when exporting to a \LaTeX\ file.

If you export your image to a \LaTeX\ file, the font used in the document is unlikely
Figure 9.19: Text-path transformation matrix: (a) the text-path with transformation matrix shown in (b); (c) the text-path with transformation matrix shown in (d); (e) the text-path with transformation matrix shown in (f).
to completely match the font used in FlowframTk. As a result, text may appear wider or narrower in the resulting \LaTeX document than in the image displayed in FlowframTk. This may result in the text appearing as though it has shifted position. (Particularly when the text area contains \LaTeX commands.) To reduce this effect, you can specify what part of the text should be considered as the anchor. To illustrate this, consider the image shown in Figure 9.20. An image was created in FlowframTk containing some text bordered by a rectangle with an additional line along the text area’s baseline: Figure 9.20(a) shows how the image appears in FlowframTk. The font used is the generic serif font and the text takes up the entire box. The image was then exported to a \LaTeX file with various anchor settings. The \LaTeX document set the Roman font via:

\usepackage{mathptmx}

This is a slightly narrower font than the font used in FlowframTk, so the text no longer fills the box. In Figure 9.20(b), the anchor was set to (left, base); in Figure 9.20(c), the anchor was set to (centre, base); in Figure 9.20(d), the anchor was set to (right, base). Notice that the base line for the text remains as it was in FlowframTk, but the horizontal placement of the text varies.

In this example, the height of the text in the \LaTeX document is only slightly smaller than that of the font used by FlowframTk, so the vertical anchor setting does not make that much difference, but there is still a slight shift: in Figure 9.20(e), the anchor was set to (left, bottom); in Figure 9.20(f), the anchor was set to (left, centre); in Figure 9.20(g), the anchor was set to (left, top).

\begin{figure}[h]
\centering
\begin{tabular}{ccc}
(a) & (b) & (c) \\
Sample & Sample & Sample \\
(b) & (c) & (d) \\
Sample & Sample & Sample \\
(e) & (f) & (g) \\
Sample & Sample & Sample \\
\end{tabular}
\caption{The effect of converting from system fonts to \LaTeX fonts: (a) image in FlowframTk using the generic serif font. The image was then exported to a \LaTeX document with the anchor set to: (b) left, base; (c) centre, base; (d) right, base; (e) left, bottom; (f) left, centre; (g) left, top.}
\end{figure}

Note that in the above example, the \LaTeX document used a scalable font (via the \texttt{mathptmx} package). The default Computer Modern font is not scalable. It is therefore possible that the required size is not available, in which case \TeX will substitute the closest available font size. For example, in Figure 9.21, the image created in the previous example is again illustrated with anchor at (left, base). Figure 9.21(a) shows...
the original image in \texttt{FlowframTk} using the generic serif font; \textbf{Figure 9.21}(b) shows the image exported to a \LaTeX{} document that uses the \texttt{mathptmx} package; \textbf{Figure 9.21}(c) shows the image exported to a \LaTeX{} document that uses the default Computer Modern font. The large font size (40) is not available in the Computer Modern font, so the closest available font size is used instead, which in this example has resulted in a significant change in size.

\begin{figure}[h]
\centering
\begin{tabular}{ccc}
(a) & (b) & (c) \\
\end{tabular}
\caption{The font used by the \LaTeX{} document may result in considerable differences from the original image: (a) image in \texttt{FlowframTk}; (b) image in \LaTeX{} document using \texttt{mathptmx} package; (c) image in \LaTeX{} document using non-scalable Computer Modern font.}
\end{figure}

As mentioned earlier, if a text area contains \LaTeX{} commands, this may also result in a horizontal or vertical shift. Consider an image that contains some maths. \textbf{Figure 9.22}(a) shows the image as it appears in \texttt{FlowframTk}. The red line path is aligned along the left edge and along the baseline of the text. The text area has been assigned the following alternative text to be used when exporting to a \LaTeX{} file:

\[ f(x) = \frac{(x-a_1)^2}{a_2} \]

\textbf{Figure 9.22}(b) shows how the image appears in a \LaTeX{} document when the anchor is set to (left, base), and \textbf{Figure 9.22}(c) shows how the image appears in a \LaTeX{} document when the anchor is set to (left, bottom).

The default anchor is (left, base). This can be changed using the \texttt{Edit \rightarrow Text \rightarrow Font Style \rightarrow Anchor} menu. The sample panel will display a small red dot to indicate the position of the anchor. If you enable the \texttt{automatic anchor update facility}, the anchor will be changed when you \texttt{align} groups containing text areas.

Note that this difference in font size between the image viewed in \texttt{FlowframTk} and the \LaTeX{} alternative means that exporting to an encapsulated \LaTeX{} document can cause the text to be clipped. (This also applies to the export functions that use the export to encapsulated \LaTeX{} document function as an intermediate step, such as the export to PDF function.)

Note that if the text area is transformed then the anchor will have the same transformation. See, for example, \textbf{Figure 9.23}.

See also:

- §3.2.9 \TeX{} Settings Dialog
- §11.4 Step-by-Step Example: An Artificial Neuron
- §11.9 Step-by-Step Example: A House With No Mouse
$f(x) = (x-a_1)^2/a_2$

$\frac{(x-a_1)^2}{a_2}$

$\frac{(x-a_1)^2}{a_2}$

Figure 9.22: Text area containing maths: (a) image in FlowframTk; (b) image as it appears in a $\LaTeX$ document with anchor set to (left, base); (c) image as it appears in a $\LaTeX$ document with the anchor set to (left, bottom); (d) text area contents.
Figure 9.23: The text area’s transformation matrix will also be applied to the anchor: (a) original image in FlowframTk. The image was then exported to a \LaTeX file with anchor: (b) left, base; (c) centre, base; (d) right, base.
10 \TeX/L\LaTeX

This chapter covers functions that are specific to \TeX or \LaTeX users. These functions can be obtained via the \TeX/L\LaTeX menu. The only functions that are relevant to Plain \TeX users are those relating to \texttt{\parshape} and \texttt{\shapepar/\Shapepar}. The \texttt{flowfram} package is a \LaTeX 2e package. Although the \texttt{pgf} package is available for \TeX formats other than \LaTeX, \texttt{FlowframTk} currently only exports images using \LaTeX syntax.

10.1 Adding Commands to the Preamble

The export to document functions (and the export functions that use the export to encapsulated document function as an intermediate step) create a complete \LaTeX document, including the document class and preamble. The \texttt{pgf}, \texttt{geometry} and \texttt{ifpdf} packages are automatically added to the preamble, and the \texttt{pgf decorations.text} library is also loaded, in case the image contains any text-paths. \texttt{FlowframTk} also defines a command called \texttt{\jdroutline} that’s used for any outline text areas (but not text-paths, as outline text-paths are not supported by the \LaTeX-related export functions.) The other command automatically defined in the preamble is \texttt{\jdrimagebox}, which is used in case the image turns out to be slightly larger than calculated. (This could be caused by rounding errors, or the difference in fonts, as discussed in §9.5.6 Anchor.) The \texttt{pgfpicture} environment is placed inside the argument of \texttt{\jdrimagebox} to prevent spurious blank pages occurring.

In addition \texttt{\pdfinfo} is added with the creation date and optionally a title if the \texttt{Add \pdfinfo to exported \LaTeX documents} option is selected in the \TeX/L\LaTeX Settings dialog. (The title is obtained from the image description, see §5.4 Image Description.)

It may be that you want to add some extra command definitions to the preamble, or perhaps you want to load other packages. There are two ways to do this. The first method is to create a file called \texttt{preamble.tex} with the required commands and save it in the configuration directory. The contents of this file will be inserted into the preamble whenever you use an export to \LaTeX document function (including those export functions that use \LaTeX as an intermediate step). For example, my \texttt{preamble.tex} file contains the following:

\begin{verbatim}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{lmmodern}
\end{verbatim}

This ensures my images always use scalable fonts and I don’t need to map any accented characters, such as é, to \LaTeX commands. This method is applied to any image exported to a \LaTeX document.

The second method is to set preamble code for a given image. For example, if an image has a text area that contains, say, \texttt{\boldsymbol} then the preamble needs to load the \texttt{amsmath} package. This only applies to this particular image, not to all images, so instead of adding \texttt{\usepackage{amsmath}} to \texttt{preamble.tex}, it can be added to the image’s preamble using the \TeX/L\LaTeX → Preamble menu item. This opens the preamble editor, shown in Figure 10.1.
If you have the text-mode or maths-mode mappings set in the TeX/LaTeX Configuration Dialog, any mappings that have an associated package will automatically add that package to the image’s preamble whenever the mapping is applied. (Note that if you later edit the LaTeX alternative text to remove the command inserted by the mapping, the package won’t be removed from the preamble as there’s no guarantee it’s not required by another text area or text-path.)

The image’s preamble code is stored in JDR/AJR files, but not for versions less than 1.8, so make sure you use the latest file version when you save your image. (This is done automatically if you use File → Save.)

If you use the export to package or document class functions, the image preamble code will be inserted before the option declarations, which allows you to add extra options, if required. (Remember that you can use \AtEndOfPackage, \AtEndOfClass or \AtBeginDocument if you need to add code that can’t be used before the option declarations.) Any instances of \usepackage will be replaced by \RequirePackage. Note that the preamble.tex file isn’t used by the export to package or document class functions.

See also:

- §3.2.9 TeX Settings Dialog
- §4 TeX Editor Settings

### 10.2 Computing the Parameters for \parshape

\TeX\’s \parshape command can be used to change a standard rectangular shaped paragraph into a non-rectangular shape. The \parshape command has the following format:
\parshape=(n) (i_1) (l_1) \ldots (i_n) (l_n)

where \((i_1)\) is the indent for the first line and \((l_1)\) is the length of the first line, etc. This command should be placed at the start of the paragraph, and is only applied to that paragraph. If there are more than \((n)\) lines in the paragraph, the specification for the \((n)\)th line will be used until the end of the paragraph. If there are less than \((n)\) lines in the paragraph, the shape will be truncated. See \textit{The \LaTeX{}book} [1] for further details.

Since each line in the paragraph is constructed from only indent and line width information, only certain types of shapes can be specified by a \parshape. If you imagine horizontal scan lines passing through the shape, each scan line should not be able to intersect the boundary of the shape more than twice.

Before you use \texttt{FlowframTk} to determine the parameters for \parshape, you must first ensure that you have set the normal font size to the value used in your document. See, for example, Figure 11.79 (in section 11.7) which illustrates what happens when you fail to do this.

To determine the parameters for a \parshape, create your shape as a single path. Select this path, and use the menu item \TeX{}/\LaTeX{} \rightarrow Parshape. This will open up a dialog box in which you can specify whether you want to use the outline defined by the actual path, or whether you want to use the outline defined by the line style.

For example, Figure 10.2(a) shows a path which consists of a single line segment (shown in Figure 10.2(b)), but with a line thickness of 52bp, butt cap and an equilateral triangle start marker of size 80bp. If you select the Use Path option, \texttt{FlowframTk} will attempt to construct the parameters from the actual path (ignoring the line style) which it will not be able to do, as the path has no area. If you select the Use Outline option, \texttt{FlowframTk} will construct the parameters from the outline as seen on the screen. These parameters can be saved to a file, and used in a \TeX{} or \LaTeX{} document to create a shaped paragraph (Figure 10.2(c)).

Another example is shown in Figure 10.3. In this example, the path was constructed using the ellipse tool. If you select the Use Path option, \texttt{FlowframTk} will compute the parameters used to create the paragraph shown in Figure 10.3(b). In this example, you will not be able to use the Use Outline option as this will attempt to create an annulus defined by the path’s border, which can’t be done by \parshape (but can be done by \shapepar, although it is not recommended for such a narrow line width).

Whilst the parameters are being computed, the horizontal scan lines used by \texttt{FlowframTk} will appear on screen, and if successful, a dialog box will appear for you to save the \parshape command to a file. You can then input this file at the start of the appropriate paragraph in your \TeX{} or \LaTeX{} document. For example, if you save the \parshape command to a file called, say, myparshape.tex, then if you are using plain \TeX{} you would need to do:

\input{myparshape}

This is the start of the paragraph...

or if you are using \LaTeX{} you would need to do:

\input{myparshape}\%

This is the start of the paragraph...

You may want to suppress the paragraph indentation using \texttt{\noindent}:

\input{myparshape}\%

\noindent This is the start of the paragraph...
An example bit of text shaped like an arrow. It’s too thin for long words, but gives you an idea of what can be done. It can be tricky to get just the right amount of text to get the shape ok.

This example has an elliptical shape. The parameters were constructed from the definition of the path, not the outline defined by the line style of the path. The paragraph indentation was suppressed at the start using \noindent to help keep the desired shape. Again it needs to have just the right amount of text to fill the entire shape, unlike paragraphs created using \shapepar which expand or shrink to fit the shape.
10.3 Computing the Parameters for \shapepar or \Shapepar

The distance between the scanlines is given by the value of \baselineskip for the normal font size. For example, if the normal font size is 10pt, \baselineskip will be 12pt, and this will be the distance used between the scanlines. It is therefore important that you set the value for the normal font size before using this function.

See also:

- §3.2.9 Setting the Document Class and Normal Font Size
- §10.4.3 Defining a Frame

10.3 Computing the Parameters for \shapepar or \Shapepar

The \parshape command is fairly limited. You need the right amount of text in the paragraph to get the shape right, and you can’t have cut out sections. These two things can be overcome using the \shapepar or \Shapepar commands defined in the shapepar package. The syntax for these commands is complex and those interested should read the shapepar documentation. As with \parshape, the shape is constructed using horizontal scan lines. If you want gaps to appear in your shape, make sure to set the winding rule to even-odd. If in doubt, give the path a fill colour; the area that is filled will contain the text of the paragraph, and the area that isn’t filled won’t.

FlowframTk defaults to using \Shapepar rather than \shapepar, but you can change this in the TeX/LaTeX Configuration Dialog.

To determine the parameters for \Shapepar/\shapepar, create your shape as a single path. Select this path, and use the menu item TeX/LaTeX → Shapepar. As with \parshape, a dialog box will open allowing you to select whether you want to use the path itself to define the shape or whether you want to use the path’s outline to define the shape. For example, Figure 10.4(a) shows a path with a 40bp line width. The \shapepar parameters were constructed first from the path (Figure 10.4(b)) and then from the outline (Figure 10.4(c)).

As with the parshape function, the horizontal scan lines used by FlowframTk will appear on screen, and if successful, a dialog box will appear for you to save the \Shapepar/\shapepar command to a file. You can then input this file at the start of the appropriate paragraph in your \TeX or \LaTeX document. For example, if you save the command to a file called, say, myshapepar.tex, then if you are using plain \TeX you would need to do:

\input myshapepar
This is the start of the paragraph...

or if you are using \LaTeX you would need to do:

\input{myshapepar}%
This is the start of the paragraph...

Remember to include the shapepar package:

- \input shapepar.sty (plain \TeX)
- \usepackage{shapepar} (\LaTeX)

See also:
This example has a circular shape and uses the \shapepar command defined in the \shapepar package. The parameters were constructed from the path. Since this uses \shapepar rather than \parspace, the shape will expand or shrink to fit the text. The resulting paragraph will therefore not necessarily be the same size as the original path.

Here is a little bit of text as an example. In this example, the parameters came from the path. The lines are quite thin so \TeX has some problems finding good line breaks.

Figure 10.4: Shapepar example: (a) the path; (b) parameters constructed from the path and included in a \LaTeX document to produce a shaped paragraph; (c) parameters constructed from the path’s outline and included in a \LaTeX document to produce a shaped paragraph.
10.4 Creating Frames for Use with the \texttt{flowfram} Package

\texttt{FlowframTk} can be used to help construct frames for use with the \texttt{flowfram} package.\footnote{The \texttt{flowfram} package can be downloaded from CTAN.} If you are unfamiliar with this package, please ensure you read the user manual (ffuserguide.pdf).

### 10.4.1 The \texttt{flowfram} Package: A Brief Summary

The \texttt{flowfram} package is a \LaTeX\ 2ε package that allows the user to construct frames in a document, such that the document text flows from one frame to the next in the order that the frames were defined. The mechanism is much the same as that used to create the columns when using the standard two column mode, but the columns are of arbitrary width, height and position.

Imagine that you have a number of rectangular sheets of transparent paper. You start writing on the first sheet until it’s filled, then you put it aside and start writing on the next until that one’s filled as well, and so on. When you’ve filled all the sheets, pick up the first one and glue it onto your page in your desired location, then pick up the next one and glue that onto the page, and so on. If you’ve glued one sheet down so that it overlaps another, the text on the top sheet will obscure the text on the lower sheet.

There are three types of frame defined by the \texttt{flowfram} package: “flow” frames which are the main type of frame. These are the frames in which the document text is placed and they are analogous to the transparent sheets of paper example described above. The other two types of frame are called “static” and “dynamic”. The contents of these frames has to be set explicitly using one of the commands or environments provided by the \texttt{flowfram} package.

The contents of the static frames are typeset once (when the contents are set) and it remains unchanged until the user explicitly resets the contents. (Static frames have an associated box defined via \texttt{\newbox} in which the contents are stored.) The contents of the dynamic frames are re-typeset on each page for which the frame is defined. (The contents are stored in a macro rather than in a box.)

So, for example, if on page 1 of your document, you set the contents of a static frame to contain the command \texttt{\thepage}, the contents of that frame will always display a 1 (no matter what page it appears on), since that was the value of \texttt{\thepage} when the contents were set. If, on the other hand, you use a dynamic frame, the contents will be re-typeset on every page, so it will display the relevant page number.

Each frame has an associated label which uniquely identifies it for a given frame type, and the frame can optionally have a border. Frames also have an associated page list indicating on which pages the frame should appear. The page list can be one of the keywords \texttt{all}, \texttt{odd}, \texttt{even} or \texttt{none}, or it can be a comma separated list of
10.4.2 Defining the Typeblock

The typeblock is the main area of the page where the text goes. The dimensions of the typeblock are given by the \textwidth and \textheight lengths. It's possible to define frames that are positioned outside of the typeblock, but the typeblock provides a frame of reference and, unless otherwise instructed, the page header and footer will be placed above and below the typeblock according to \LaTeX's standard page layout design.

Note that the twoside class option will typically shift the typeblock on the even (verso) pages (via the \evensidemargin length) whereas the oneside class option won't. Different classes have different default settings. For example, the article and report classes default to oneside but the book class defaults to twoside. This setting also affects the running headers and footers.

In FlowframTk, you specify the typeblock using the \TeX/\LaTeX \rightarrow Flow Frames \rightarrow Set Typeblock menu item. This opens up a dialog box in which you can enter the margins between the paper edge and the typeblock. You can either type the lengths into the supplied fields or, if you have a path selected, you can get FlowframTk to calculate the margins for a typeblock that fits the path's bounding rectangle by clicking on the Compute Margins From Selected Path button. (This button is disabled if no path is selected.)
For example, Figure 10.5(a) shows a path that has been created using the rectangle tool on the Tschichold grid. This was then selected and the Typeblock dialog was opened. The Compute Margins From Selected Path button was clicked which then filled in the values for the margins.

It's possible you might want to round the left and top margins to the nearest unit. In which case you can do so by editing the Left and Top fields. Additionally, you might want to adjust the right margin so that the typeblock width is rounded to, say, the nearest whole mm or whole or half pc. To do this, type in the required value in the Adjust width to nearest: field (for example 1pc) and click on the Adjust Width button. For example, I changed the left margin to 66pt and the top margin to 94pt. The Adjust width to nearest: was already set to 1pc, so I left it at that and clicked on the Adjust Width button. This filled in the right and bottom margins as shown in Figure 10.5(c).

You can also adjust the bottom margin so that the typeblock height is rounded to the nearest baselineskip or another value such as 1in. To round to the nearest baselineskip, make sure the Baselineskip button is selected otherwise make sure the Other button is selected and enter the required amount in the field. Then click on the Adjust Height button. For example, in Figure 10.5(d) the bottom margin has been adjusted to ensure the typeblock height is rounded to the nearest baselineskip.

Note that rounding errors may occur caused by the conversion between units. If you later change the normalsize, you may need to readjust the typeblock height.

Finally, if you use the twoside class option, you can get FlowframTk to adjust the value of \evensidemargin. Even Page Shift is the difference between \evensidemargin and \oddsidemargin. If the value in the Even Page Shift field is non-zero, when you export to a class or package, FlowframTk will add the commands:

```
\setlength{\evensidemargin}{\oddsidemargin}
\addtolength{\evensidemargin}{⟨h-shift⟩}
```

where ⟨h-shift⟩ is the length specified in the Even Page Shift field. If you specify a zero length, \evensidemargin won’t be adjusted, but the typeblock may not be displayed correctly when you display even pages in FlowframTk. Remember that \evensidemargin is ignored if you use the oneside class option.

If you find it a bit complicated to work out the appropriate shift, you can use the Compute button, which will work out the shift assuming a symmetric page layout. For example, in Figure 10.5(e) I clicked on Compute and it altered the value in the Even Page Shift field.

Once you have set the typeblock, it will appear on the screen as a light grey rectangle, labelled “typeblock”. In Figure 10.6 I removed the path I had used to calculate the typeblock using Edit → Cut). The typeblock is slightly smaller than the path as a result of the adjustments made.

### 10.4.3 Defining a Frame

An object can be identified as a flow, static or dynamic frame as follows: select the object (it should be the only object selected) then select the TeX/LaTeX → Flow Frames → Set Frame menu item. This will open up a dialog box in which you can specify the frame’s attributes. Initially only the Type field is enabled (as shown in Figure 10.7) since all the other fields aren’t valid for type None.
10.4.3 DEFINING A FRAME

(a) Figure 10.5: Setting the typeblock: (a) a rectangle has been drawn on a Tschichold grid; (b) the margins computed from the selected rectangle; (c) the top and left margins were manually rounded to the nearest point by the user and then the adjust width function was used which changed the right margin; (d) the adjust height function was used to change the bottom margin; (e)
10.4.3 DEFINING A FRAME

Figure 10.6: The typeblock is shown as a light grey rectangle: (a) verso; (b) recto

Make sure you set the typeblock before you set any frames. If you later adjust the typeblock, you may need to readjust the even shifts for all frames that may be displayed on verso pages.

The Frame Type

The frame’s type is specified using the drop-down list labelled Type. There is a choice of: Flow, Static, Dynamic or None. None indicates that the object has no associated flowframe data, which means that the object will not be saved if the image is exported to a \LaTeX\ package or class.

The Frame Label

Each frame is assigned a label so that it can be referenced in the document. Each label must be unique for its given frame type. To assign a label to the selected frame, enter it in the box marked Label.

There are four dynamic frame labels that have a special meaning for \texttt{FlowframTk}: header, footer, evenheader and evenfooter. These indicate that the frame should be converted into the page header or footer frame (analogous to the \texttt{flowfram} package’s \texttt{makedfheaderfooter} command). If you use any of these labels, when you export to a package or class file, \texttt{FlowframTk} will modify \LaTeX{}’s standard page style mechanism to hide the header and footer frames when you use the empty page style, hide just the header when you use the plain page style and hide just the footer when you use the headings page style. If you only define a header frame but no footer frame, \texttt{FlowframTk} will switch on the headings page style. If you only define a footer frame but no header frame, \texttt{FlowframTk} will switch on the plain page style. If you define both a header and a footer frame, \texttt{FlowframTk} will switch to its own custom page style called \texttt{flowframtk} that puts \texttt{\leftmark} or \texttt{\rightmark} in the
10.4.3 DEFINING A FRAME

Figure 10.7: Frame Attributes Dialog Box
header and thepage in the footer. This custom page style is only defined if you have a header or footer frame. *These labels only have a special significance for dynamic frames.*

The evenheader and evenfooter labels are provided in case you want to have a different frame for even pages. This will typically only be necessary if you want a different border or frame dimensions for the header or footer on even pages, as the even page horizontal shift is usually sufficient.

### The Frame Border

The Border drop-down list allows you to specify whether the frame has a border. If the option As Shown is set, then the object will be drawn as the frame’s border. If the option None is set, then the frame will not be given a border, and the object will be used only as an indication of the frame’s width, height and location (and possibly shape, see §10.4.4 The Frame Shape).

Note that all text areas are considered to be a part of the frame’s background, not the frame’s contents, and will only appear if the border As Shown setting is applied. Likewise for bitmaps. The border is not available for non-standard paragraph shapes.

### The Page List

You can specify the page list on which the frame is defined, using the Pages combo box. Either select one of: All, None, Odd or Even, or you can type in a comma separated list of pages or page ranges (e.g. 1-10,12,14,>20). The page references are as described in §10.4.1 The flowfram Package: A Brief Summary. Use the flowframe pages setting: section of the TeX/LaTeX Configuration Dialog to specify whether the page list uses absolute or relative numbers.

### Margins

The frame may have margins between the border and the area in which the contents are typeset. The margins are usually only relevant if you have specified the As Shown border option. The margins are not available for non-standard paragraph shapes.

### Alignment

You can change the vertical alignment of the contents of a static or dynamic frame using the Alignment drop-down list. This can be one of: Top, Middle or Bottom, which correspond to the settings valign=t, valign=c and valign=b, respectively, provided by \setdynamicframe and \setstaticframe. This facility is not available for flow frames.

### Even Shift

By default, the frame location on even pages is the same relative to the type-block as on odd pages. You can override this by specifying a shift to apply to the location when the frame is displayed on an even page. *However, this setting only*
10.4.4 **THE FRAME SHAPE**

*has an effect if you use the twoside class option.* This is typically the default for classes such as book, but not for classes such as article or report. Typically, only the horizontal shift may be needed for two-sided documents, but if for some reason you require a vertical shift that option is provided. In most cases, the horizontal shift is used to create a symmetric page layout (by which I mean the frame locations are symmetric not the frame borders). For convenience, there’s a button labelled Compute Symmetric X Shift that will work out the appropriate horizontal shift to create a symmetric layout, given the current frame position and typeblock margins. If you later move the object or modify the margins you will need to update the horizontal shift.

If the typeblock has an even page shift, remember to take this into account when setting the even shift for the frames. You can check the frame’s position on even pages using the display page dialog.

**Contents**

As described in §10.4.1 The flowfram Package: A Brief Summary, the contents of static and dynamic frames need to be explicitly set using commands or environments provided by the flowfram package. For your convenience, FlowframTk provides a way for you to specify the contents and will use the appropriate commands when you export to a package or class file. To add or edit the contents, click on the Edit button, which will open FlowframTk’s little TeX editor (as also used by the set preamble function). **Note that you can’t use verbatim text in the contents.**

If your frame has been assigned the Dynamic type and has been given one of the special dynamic labels header, footer, evenheader or evenfooter, as described above, setting the contents has a different effect. The code you provide in the contents is inserted into the header or footer to enable you to modify the formatting. Note that you shouldn’t use commands like \thepage, as that will be done automatically. It’s best to stick to declarations, such as \bfseries, although the final command may be a text-block command, such as \textbf, as it is typically followed by \thepage or the header mark.

Once an object has been identified as a frame, a grey rectangle will appear on the screen indicating the area in which the contents of the frame will be typeset, along with the frame’s type, identification label and page list.

Note that if the object is a group, the frame information will be applied to the whole group. This means you can construct a frame border by grouping several objects, however, if you later ungroup this object, you will lose the frame information.

### 10.4.4 The Frame Shape

The text in flow frames is typeset using the standard rectangular format, but the contents of static or dynamic frames can be shaped using either \parshape or \shapepar. If you have selected a path, you can enable this by selecting either Parshape or Shapepar from the Shape drop-down list. **Note that the shape option is not available for any other type of object.**

If you use the Parshape or Shapepar options, it will only check if a set of valid parameters can be extracted from the path when you export the image as a \LaTeX package.
10.4.5 SCALE OBJECT TO FIT TYPEBLOCK

(Otherwise it would have to re-evaluate the parameters every time you edit the path.) Note, however, that the paragraph shape in your document may not exactly match the shape you created in FlowframTk:

\parshape:

- If there are not enough words in the paragraph to fill the shape, the shape will be truncated.
- If there are too many words in the paragraph, the dimensions of the final line of the shape will be repeated for each subsequent line.

\shapepar:

- If there are not enough words in the paragraph to fill the shape, the shape will shrink.
- If there are too many words in the paragraph, the shape will expand.

To illustrate this, consider the layout shown in Figure 10.8. There are six identical circles arranged in two rows. Each circle has been identified as a static frame. Their bounding boxes can be seen as light grey rectangles. The top three circles have all been assigned a shape given by \parshape, while the bottom three circles have been assigned a shape given by \shapepar.

This layout was exported as a \LaTeX package based on the flowfram package, and was included into a document. Each of the static frames were filled with a varying amount of text. The leftmost circles do not have enough text to fill the designated area, while the rightmost circles have too much text. (See Figure 10.9.)

Note that when you use a non-standard paragraph shape, you can no longer specify the margins. Since the paragraph shape is defined by the path, the margins don’t have any meaning. If you want a border effect, you can make a slightly larger object behind, and set the border of the larger object to As Shown and the border of the smaller object to None, but remember that the overall effect will depend on the amount of text contained in the frame.

10.4.5 Scale Object to Fit Typeblock

In addition to the scaling function described in §8.18 Scaling Objects, if you have set the typeblock, you can scale selected objects so that they fit the typeblock area using the TeX/LaTeX → Flow Frames → Scale to Fit Typeblock menu item. Note that this may change the aspect ratio of the scaled objects.

10.4.6 Only Displaying Objects Defined on a Given Page

It is possible to display only those frames that are defined on a given page using the TeX/LaTeX → Flow Frames → Display Page dialog box. You can select to display those frames that are defined on all pages or just those that are defined on odd or even pages or you can specify a particular page number by selecting the Page radio button and entering the relevant page number in the text field. If you specify “0”, only those frames that have the None page setting will be displayed. Note that objects that have
Figure 10.8: Layout containing six circles. All circles have been identified as static frames. The top three circles have been assigned a shape given by \texttt{parshape}. The bottom three circles have been assigned a shape given by \texttt{shapepar}. 

not been assigned flowframe data will always be displayed. The title bar will indicate how many objects have been hidden.

It’s generally best to apply transformations or edits with the All Pages setting on. If you move an object when the verso (even) page is displayed, the object’s recto position will be moved by the same amount. The only way to have a different verso position is to apply an even page shift in the TeX/LaTeX → Flow Frames → Set Frame dialog (or to apply an even page shift to the typeblock).
11 Step-by-Step Examples

The examples in this section illustrate various aspects of FlowframTk.

§11.1 A House
Illustrates the basics: how to create filled rectangles and a closed line path.

§11.2 Lettuce on Toast
Illustrates editing paths.

§11.3 Cheese and Lettuce on Toast
Illustrates merging paths.

§11.4 An Artificial Neuron
Illustrates line styles, text areas and justifying. Also illustrates how to specify different text to use when exporting to a LaTeX file.

§11.5 Bus
Illustrates path functions, and using the shapepar function.

§11.6 A Poster
Illustrates how to use FlowframTk to create frames for use with the flowfram package.

§11.7 A Newspaper
Illustrates how to use FlowframTk to create non-standard shaped frames for use with the flowfram package.

§11.8 A Brochure
Illustrates how to use FlowframTk to create recto/verso header and footer frames for use with the flowfram package.

§11.9 A House With No Mouse
Illustrates how to create and edit pictures without using the mouse.

§11.10 A Lute Rose
Illustrates how to design a lute rose using a symmetric shape and rotational patterns.

11.1 A House

This example illustrates the basics. The aim is to create a simple image of a house (shown in Figure 11.3).

1. The main part of the house will be constructed from a rectangle, so select the rectangle tool.

2. Let’s make it a yellow brick house, so use Settings → Styles to select a yellow fill colour.

3. Click where you want the bottom left hand corner to go, and move (not drag) the mouse to the opposite corner (Figure 11.1(a)). Click to complete the rectangle. You will only see the fill colour once the rectangle has been completed (Figure 11.1(b)).
4. Next do the roof. Let’s make the roof using a triangle. For this you will need to use the **closed line path tool**. Select this tool using either the closed line button or the **Tools → Closed Line** menu item.

5. Let’s make it a red roof, so use **Settings → Styles** to select a red **fill colour**.

6. Click on each of the three vertices that form the triangle (Figure 11.2(a)). To complete the path, double click when you click on the third vertex, or click on the third vertex and then press **Enter**, or use the finish path button. You will only see the fill colour once the path has been completed (Figure 11.2(b)).

7. Lastly comes the door and windows. These are all rectangles, so follow the same procedure as above. Let’s make the door black and the windows white. Remember to set the fill colour before creating the rectangles (Figure 11.3).
11.2 LETTUCE ON TOAST

To save the picture, select the File → Save As menu item (Figure 11.4).

To include the image in a \LaTeX document, select the File → Export menu item, and save it as a \LaTeX file (click on the File of Type drop-down list and select pgf environment (*.tex, *.ltx), and name the file e.g. house.tex Figure 11.5.) Remember to use the pgf package:

\usepackage{pgf}

and to include the image later in the document use \input, e.g.:

\begin{figure}
\centering
\input{house}
\caption{A House}
\end{figure}

11.2 Lettuce on Toast

This example illustrates how to edit paths. The aim is to create the picture illustrated in Figure 11.11.
11.2 LETTUCE ON TOAST

1. Let’s start with the toast first. To begin create a rectangle with a brown fill colour. (If you are using the CMYK model, you can get brown from 0% Cyan, 81% Magenta, 100% Yellow and 60% Black. If you are using the RGB model, you can get brown from 40% Red, 8% Green and 0% Blue.) Create the rectangle shown in Figure 11.6.

![Figure 11.6: Lettuce on Toast Example — Brown Rectangle](image)

2. Bread quite often has a curved top, so let’s edit the rectangle so that the top is slightly curved. To do this, select the rectangle, and then either click on the edit path button or select the Edit → Path → Edit Path menu item. This will display the path in edit mode (Figure 11.7(a)). Select the top segment, this will then be highlighted in red (Figure 11.7(b)).

![Figure 11.7: Lettuce on Toast Example — editing the rectangle: (a) edit mode; (b) select top segment](image)

3. Use the edit path popup menu to convert the line segment to a curve (Figure 11.8).

4. The segment now has two extra control points, these need to be moved to change the curvature (Figure 11.9(a)). Click anywhere outside the control points to exit the edit path mode (Figure 11.9(b)). Note that if you have the grid lock enabled,
5. To make the lettuce, select the closed curve tool, and set the fill colour to green. Make a rough outline of the lettuce leaf, clicking on each vertex, and double-click to close the path. Then, if necessary, edit the path to modify the control points (Figure 11.10).

6. Set the fill colour to transparent, and using the open curve tool, add in some paths to give the lettuce leaf some creases and edit as appropriate (Figure 11.11).

To save the picture, select the File → Save As menu item, and enter the filename. To include the image in a LaTeX document, select the File → Export menu item, and save it as a LaTeX file (click on the File of Type drop-down list and select pgf.
11.3 CHEESE AND LETTUCE ON TOAST

This example illustrates how to merge paths. It extends the previous example Lettuce on Toast. The aim is to create the image shown in Figure 11.15.

1. Load the image you created in the lettuce on toast example, using the File → Open menu item, or clicking on the load image button.

2. To create the slice of cheese, select the rectangle tool, and set the fill colour to yellow. Make a rectangle, as illustrated in Figure 11.12.

3. This slice of cheese is going to have holes in it, and we need to be able to see the lettuce and toast through the holes. Since this is not a uniform colour, we can’t just, say, put green ellipses on top of the cheese as this won’t look right. Instead, we are going to create some ellipses, and then merge them into the yellow rectangle. To do this, first select the ellipse tool, and create some ellipses on top of the yellow rectangle (Figure 11.13).

4. Now select all the ellipses you created in the previous step and the yellow rectangle (Figure 11.14(a)) and merge them using the Transform → Merge Paths menu item (Figure 11.14(b)). If the ellipses remain filled, check to make sure you
11.4 An Artificial Neuron

This example illustrates setting line styles and adding text. The final image looks best as a \texttt{pgf} picture included in a \LaTeX{} document, as then you can use maths fonts.

1. Select the \texttt{rectangle tool}, and create a rectangle, as shown in Figure 11.16.

2. Select the \texttt{ellipse tool}, and create a circle, as shown in Figure 11.17.

Figure 11.12: Cheese and Lettuce on Toast Example — A Filled Rectangle

Figure 11.13: Cheese and Lettuce on Toast Example — Adding Ellipses

have the \texttt{winding rule} set to even-odd. (Alternatively, you can use the \texttt{Transform → Subtract Paths} menu item, in which case you don’t need to worry about the winding rule.)

Figure 11.14: Cheese and Lettuce on Toast Example — merging paths: (a) paths selected; (b) paths merged into a single path.

\section{11.4 An Artificial Neuron}

This example illustrates setting line styles and adding text. The final image looks best as a \texttt{pgf} picture included in a \LaTeX{} document, as then you can use maths fonts.

1. Select the \texttt{rectangle tool}, and create a rectangle, as shown in Figure 11.16.

2. Select the \texttt{ellipse tool}, and create a circle, as shown in Figure 11.17.
11.4 AN ARTIFICIAL NEURON

Figure 11.15: Cheese and Lettuce on Toast Example — Completed Image

Figure 11.16: Artificial Neuron Example — Adding a Rectangle

Figure 11.17: Artificial Neuron Example — Adding a Circle
3. To make the logistic function symbol, select the open curve tool, and do a single segment (Figure 11.18(a)). Then use the edit path tool to adjust the curvature, as shown in Figure 11.18(b). (If you have enabled the grid lock, you may find it easier to disable it while you are editing the curvature control points.)

![Figure 11.18: Artificial Neuron Example — creating a sigmoidal curve: (a) adding an open curve segment; (b) edit segment to adjust curvature.](image)

4. Next set the current line style to have an end arrow. Note that lines with end markers look best with a butt cap style, so this should also be set. This can be done as follows:

   Use the `Settings → Styles` menu item to display the current styles dialog box. Select the tab labelled `Line Style` to display the line style panel. Select `Butt` from the drop-down list labelled `Cap Style` (see Figure 11.19). Next select the button labelled `Select` located on the same row as `End Marker` to open the end marker dialog box (illustrated in Figure 11.20). Select the radio button labelled `Use Marker`. This will enable the marker chooser panel. Select the tab labelled `Arrows` and select `Pointed 60`. Select Okay to close the end marker dialog box and select Okay to close the styles dialog box.

5. Select the open line tool, and add in the arrows as illustrated in Figure 11.21.

6. Use `Settings → Styles` to open the current styles selector, and set the font family to “Serif” and the font size to 10pt, and then press Okay. Select the maths tool, and add in the text, as illustrated in Figure 11.22. (I’ve used the Superscripts and Subscripts block in the symbol selector to insert the subscripts.)

   Since I have the maths tool with the maths-mode mappings on, the \LaTeX\ alternative text automatically has the maths shift characters inserted and the Unicode subscripts have been converted to _1 etc. You can see the \LaTeX\ alternative text if you select the text area and use `Edit → Text → Edit text`. This will open up the edit text dialog box shown in Figure 11.23.

   Now select all of the text on the left ($x_1$, $x_2$ and $x_n$) and use `Edit → Text → Font Style → All Styles` dialog box to change the horizontal anchor parameter to `Right`. (Note that you will not see any difference to the image in FlowframTk.)
Figure 11.19: Artificial Neuron Example — Setting the Current Line Style

Figure 11.20: Artificial Neuron Example — End Marker Dialog Box

Figure 11.21: Artificial Neuron Example — Adding Arrows

Figure 11.22: Artificial Neuron Example — Adding Text
11.4 AN ARTIFICIAL NEURON

7. Select the maths tool and start a text area in the rectangle. I want to use a capital sigma to indicate a summation, and as I don’t know the magic combination of characters to access that symbol, I used the Insert Symbol dialog box. To do this, either use the popup menu and select Insert Symbol, or press the Ins key. The required symbol can now be selected from the dialog box (illustrated in Figure 11.24). This is the summation symbol (U+2211) from the Mathematical Operators block, not the Greek capital sigma from the Mathematical Alphanumeric Symbols block.

![Figure 11.24: Artificial Neuron Example — Insert Symbol Dialog Box](image)

8. Use the Edit → Text → Font Style → All Styles to change the font size to 25 and change both the anchor settings to Centre, see Figure 11.25. (You don’t need to change the anchor settings if you have the automatic anchor update setting enabled, as it will change when you justify the text area in step 9.)

As before, if you used the maths tool with the maths-mode mappings enabled, the \texttt{\LaTeX} alternative text should already be correctly set, but you can check by selecting the text area and using the Edit → Text → Edit text menu item to open the Edit Text dialog box (Figure 11.26(b)).

9. The $\Sigma$ would look much better if it was centred inside the rectangle. To do this select the $\Sigma$ and the rectangle, then group them either by clicking on the group objects button or by using the Transform → Group menu item. Then select the Transform → Justify → Centre menu item, and then the Transform → Justify → Middle menu item. The text area should now be centred inside the rectangle (Figure 11.27).

To include the image inside a \texttt{\LaTeX} document, save the image to a \texttt{\LaTeX} file using the File → Export menu item, and then include it in your document (assuming the file was called \texttt{neuron.tex}):
11.4 AN ARTIFICIAL NEURON

Figure 11.25: Artificial Neuron Example — Setting the Font Style

Figure 11.26: Artificial Neuron Example — setting the equivalent $\LaTeX$ symbol: (a) selected text; (b) setting $\LaTeX$ equivalent.

Figure 11.27: Artificial Neuron Example — Justifying Objects
11.5 Bus

This example illustrates how to:

- break a path
- create a path union
- subtract paths
- Use the `shapepar` function to create a shaped paragraph in a TeX or LaTeX document.

1. If you have not already done so, enable the grid lock via Settings → Grid → Lock Grid.

2. Use Settings → Configure TeX/LaTeX Settings to display the TeX/LaTeX Settings dialog box and set the normal font size to the value that you will be using in your document (see Figure 11.29). In my document, I have used 10pt.

3. To create the bus outline, start with the ellipse tool, and create a circle (Figure 11.30).

4. Select the circle, and select the edit path tool. The control point at the start of the path is always the first selected control point when you select the edit tool (Figure 11.31(a)). Select the second segment in the path (Figure 11.31(b)).
Figure 11.29: Bus Example — Setting the Normal Font Size

Figure 11.30: Bus Example — Create a Circle

Figure 11.31: Bus Example — Editing the Path
5. Break the path using the edit path popup menu and selecting Break path (Figure 11.32(a)). You should now have two separate semi-circles (Figure 11.32(b)). If you find that the circle has been split unevenly (i.e. you have a quadrant and a three-quarters of a circle) then you selected the wrong segment. Don’t panic, just select Edit → Undo and try again.

6. Exit edit path mode. Move and rotate the top semi-circle so that it looks like Figure 11.33.

7. Select the open line tool and add in the two lines as shown in Figure 11.34.

8. Select all paths and use Transform → Path Union. You should now have just a single path.

9. Select this new path, and use the edit path tool to give the front end of the bus a slightly curved outline, as shown in Figure 11.35. (You may find it easier to temporarily disable the grid lock while you edit the path.)
10. Add the windows, as shown in Figure 11.36.

Figure 11.35: Bus Example — Convert Line Segment to a Curve

Figure 11.36: Bus Example — Add Windows

11. This next operation assumes that you haven’t changed the stacking order. The main outline of the bus must be at the rear. To ensure this, select the bus outline and use the move to back function.

12. Select all paths, and apply Transform $\rightarrow$ Subtract Paths. Set the fill colour to red using the Edit $\rightarrow$ Fill Colour dialog box. The windows should appear as holes. See Figure 11.37.

Figure 11.37: Bus Example — Subtract Windows from Bus Outline and Set Fill Colour

13. Make sure that the bus is selected. Select the TeX/LaTeX $\rightarrow$ Shapepar menu item. A dialog box will appear: select the Use Path option and click Okay. Scan lines will appear as FlowframTk works out the parameters. Once completed a file dialog box will appear. Give the file a name, e.g. busshape.tex.

14. If you are using \LaTeX, create a document that looks something like:

\documentclass{article}
\usepackage{shapepar}
begin{document}
\input{busshape}\frenchspacing
The wheels on the bus go round and round...
end{document}

15. If you are using plain \TeX, create a document that looks something like:
\input shapepar.sty
\input busshape.tex
\frenchspacing
The wheels on the bus go round and round...
\bye

16. The resulting shaped paragraph is shown in Figure 11.38.

The wheels on the bus go round and round, round and round, round and round, round and round. The wheels on the bus go round and round all day long. The wipers on the bus go swish swish swish, swish swish swish, swish swish, swish swish, swish swish. The wipers on the bus go swish swish swish all day long. The horn on the bus goes beep beep beep, beep beep beep, beep beep beep. The horn on the bus goes beep beep beep all day long. The conductor on the bus says “any more fares?” “any more fares?” “any more fares?” “any more fares?” The conductor on the bus says “any more fares?” all day long. The mummies on the bus go natter natter natter, natter natter natter, natter natter natter, natter natter natter. The mummies on the bus go natter natter natter all day long. The children on the bus make too much noise, too much noise, too much noise. The children on the bus make too much noise all day long. The dogs on the bus go woof woof woof, woof woof woof, woof woof woof, woof woof woof. The dogs on the bus go woof woof woof, woof woof woof, woof woof woof, woof woof woof. The dogs on the bus go woof woof woof, woof woof woof, woof woof woof, woof woof woof. The dogs on the bus go woof woof woof, woof woof woof, woof woof woof, woof woof woof.

Figure 11.38: Bus Example — Resulting Shaped Paragraph

11.6 A Poster

This example illustrates how to use Flowfram\Tk to help construct frames for use with the flowfram package. The aim is to create a \LaTeX\ 2E package based on the flowfram package that defines frames for use with a poster. For this example, I used the A4 landscape paper setting, but it can just as easily be applied to other paper sizes.

1. Set the grid to the unit of your choice using the Settings \rightarrow Grid \rightarrow Grid Settings dialog box. For example, I set the grid settings to major divisions of 1in, with 10 subdivisions. I also set the storage unit to 1in.
2. I recommend that you set the grid lock on (using Settings → Grid → Lock Grid), to help prevent having frames with slightly different widths, which will result in warnings from the flowfram package.

3. Set the typeblock, using the TeX/LaTeX → Flow Frames → Set Typeblock menu item. I used 1in margins. You should now see the typeblock appear as a light grey rectangle on the page. (Note that you can not select or move the typeblock, you can only modify it using the TeX/LaTeX → Flow Frames → Set Typeblock dialog box.) See Figure 11.39.

4. Select the rectangle tool, and create the rectangles shown in Figure 11.40. The top rectangle is going to be the title frame, the two tall rectangles on the left will be flow frames containing the main text for the poster, and the two short rectangles on the right will be dynamic frames that will contain a table and a figure. (To ensure that the two tall rectangles are the same size, you may prefer to use the copy and paste function.)

5. Switch to the select tool, and add a bitmap using Bitmap → Insert Bitmap, to give the poster a logo, and move it to the location shown (Figure 11.41).

6. Garish posters are not recommended, but to illustrate how to liven up the poster, set the fill colours for the rectangles using the Edit → Fill Colour dialog box. I also added two extra smaller rectangles on top of the right hand rectangles, to give a double border effect (Figure 11.42).

7. Select the top rectangle and the bitmap, and group them. Select the bottom right hand rectangles (green) and group them. Select the middle right hand rectangles (magenta) and group them.

8. Select the top group, and select the TeX/LaTeX → Flow Frames → Set Frame menu item. This will open up the dialog box shown in Figure 11.43. Set the
Figure 11.40: Poster Example — Adding Rectangles

Figure 11.41: Poster Example — Adding a Bitmap
type to Static, and call it “title”. Set the margins as desired. (I used 0.1in for all the margins, but you may want to use different values to ensure that the logo is inside the margins so that the frame’s text doesn’t overlap the image.)

9. Click on the Edit button to open the mini \TeX editor and type in the following:

\title{A Sample Poster}
\author{Nicola Talbot}
\maketitle
\thispagestyle{empty}

as shown in Figure 11.44. (Since \maketitle sets the page style to plain, this sets it to empty as page numbers aren’t appropriate here.)

To close the editor either click on the “Okay” button (the one with the green tick) or press Shift-Enter.

10. Similarly, make the left hand rectangle a flow frame with label “left” and the middle rectangle a flow frame with label “middle”. (Flow frames can’t be assigned contents, so the Edit button will now be disabled.)

11. Make the two remaining groups dynamic frames with labels “figure” and “table”. For these two, I used larger margins (0.2in) to compensate for the double border (Figure 11.45).

Again use the mini \TeX editor to set the contents. The “figure” frame’s contents are:

\begin{staticfigure}
\centering
Insert figure here!
11.6 A POSTER

Figure 11.43: Poster Example — assigning frame information. (Note that the shape option is not available because the selected object is a group not a path.)

Figure 11.44: Poster Example — Adding Contents to a Static Frame
The “table” frame’s contents are:

\begin{statictable}
\caption{A Sample Table}
\label{tab:sample}
\centering
Insert table here!
\par
\end{statictable}

Figure 11.45: Poster Example — Frame Information Assigned

12. Use the menu item TeX/LaTeX \rightarrow Preamble to open the mini \TeX editor and add the following lines:

\RequirePackage[utf8]{inputenc}
\RequirePackage[T1]{fontenc}
\RequirePackage[lmodern]

as shown in Figure 11.46. (You can use \usepackage instead of \RequirePackage. Any instances of \usepackage will automatically be converted to \RequirePackage if the image is exported to a class or package.)

13. Use the menu item File \rightarrow Export to create a new \LaTeX package or class that defines these frames. Remember to select the Package (*.sty) file filter. I called my file poster.sty (Figure 11.47) which will create a package rather than a class.
11.6 A POSTER

Figure 11.46: Poster Example — Adding Preamble Information

\begin{verbatim}
\RequirePackage[utf8]{inputenc}
\RequirePackage[T1]{fontenc}
\RequirePackage{modern}
\end{verbatim}

Figure 11.47: Poster Example — Export Frame Information to a \LaTeX Package
14. Create a \LaTeX document that uses this package. Since I used A4 landscape paper, I’m going to use the \texttt{article} class file. If you use a larger size (e.g. A0), it would be more appropriate to use the \texttt{a0poster} class file.

I created the following file called \texttt{poster.tex}:

\begin{verbatim}
\documentclass{article}
\usetexexample{poster}
\begin{document}
This is the main body of the poster. This text will appear in the first of the two flow frames. Once it has reached the end of the first flow frame, it will then continue in the second flow frame.
% Lots of text omitted
\end{document}
\end{verbatim}

Alternatively, I can export to a class by using the \texttt{Class (*.cls)} filter in the export dialog. Then the start of my \texttt{poster.tex} file just uses this class:

\begin{verbatim}
\documentclass{poster}
\begin{document}
This is the main body of the poster. This text will appear in the first of the two flow frames. Once it has reached the end of the first flow frame, it will then continue in the second flow frame.
% Lots of text omitted
\end{document}
\end{verbatim}

This is actually more convenient than creating a package.

15. To make the poster a PDF document, do:

\begin{verbatim}
pdflatex poster.tex
\end{verbatim}

(Note that the \texttt{pgf} package is used to create the borders, so you will need to use a driver that understands the \texttt{\special} commands used by the \texttt{pgf} package, such as \texttt{PDFLaTeX} or \texttt{LaTeX} and \texttt{dvips}.) The final document is illustrated in Figure 11.48.
11.7 A NEWSPAPER

This example illustrates how to use FlowframTk to create a class or package based on the flowfram package, using non-standard shaped frames. The aim is to produce the document shown in Figure 11.78 on page 193.

1. In this example, my newspaper is going to be on A4 portrait paper, with a normal font size of 12pt, so the first thing to do is to select the paper size and orientation using Settings → Paper → A4 and Settings → Paper → Portrait, and set the value of the \font normal size font, using the Settings → Configure TeX/LaTeX Settings dialog box (see Figure 11.49). Select 12 from the drop-down list.

2. The 12pt font size has a corresponding \baselineskip of 14.5pt. For this example, it is more practical to have a grid that has intervals of this size, as it gives a guide as to how many lines there will be in each frame. Therefore I set the grid to have 145pt major divisions with 10 subdivisions. This means that each minor tick mark is at a distance of 14.5pt (one \baselineskip) from its neighbour. To do this set Settings → Grid → Grid Settings, and enter the values as shown in Figure 11.50.

3. To help reduce rounding errors, I’m also going to set the storage unit to 1pt. To do this set Settings → Configure Image Settings and change the storage unit in the Control Points tab, as shown in Figure 11.51.

4. Next set the typeblock. This nominally defines the paper margins, although it is possible to define frames outside this area. I used 58pt margins on all sides.

\footnote{This is of course only an approximate guide, as larger or smaller font sizes may be used in a frame, which will affect the total number of lines in the frame.}
11.7 A NEWSPAPER

Figure 11.49: Newspaper Example — Setting the \LaTeX Normal Font Size

Figure 11.50: Newspaper Example — Setting the Grid

Figure 11.51: Newspaper Example — Setting the Storage Unit
To do this, select TeX/LaTeX → Flow Frames → Set Typeblock which will display the dialog box shown in Figure 11.52. Enter the values shown and click on Okay or press Enter to continue. You should now see a pale grey rectangle displayed on the canvas denoting the typeblock.

5. The newspaper is going to have a static frame along the top of the typeblock that will contain the title of the paper. This isn’t going to have a border, but we will need to draw a rectangle to define the frame’s bounding box. So select the rectangle tool and draw a rectangle with opposing corners at (58pt,58pt) and (536.5pt,145pt). You should now see something like Figure 11.53.

6. Switch to the select tool, and select this rectangle. Select TeX/LaTeX → Flow Frames → Set Frame and enter the values shown in Figure 11.54(a). Note that the Border field has been set to None. The frame contents should be:

\begin{center}
\bfseries\Huge
Fairy Tale Times
\end{center}
\hfill Issue 2. 7 December 2005.

This can be set by clicking on the Edit button, which will open the mini \TeX editor, shown in Figure 11.54(b).

7. Below the title, there will be two columns each with its own heading. I am going to make separate frames for the headings, and since the headings will be in a larger font, I shall give their frames a height of twice the \baselineskip. Select the rectangle tool, and make two rectangles with opposing corners at:

- (58pt, 159.5pt) and (290pt, 188.5pt)
- (304.5pt, 159.5pt) and (536.5pt, 188.5pt)

You should now see something like Figure 11.55.

8. Switch to the select tool, and select the left hand frame, and assign the flowframe data shown in Figure 11.56. The frame contents contains the section command:

\section{Killer Wolf on the Loose}
11.7 A NEWSPAPER

Figure 11.53: Newspaper Example — Title Frame

Figure 11.54: Newspaper Example — Assigning Flowframe Data to Title Frame: (a) frame setup; (b) setting the frame contents
Figure 11.55: Newspaper Example — Left and Right Heading Frames Added

Figure 11.56: Newspaper Example — Assigning Flowframe Data to Left Heading Frame
This is again set using the Edit button to open the \TeX editor.

9. Do the same for the right hand rectangle, but call it rightheading. The frame contents contains the section command:

\section{Tragic Wall Accident}

10. The left hand column is going to angle around underneath the right hand column, as it will have more text in it. Select the closed line tool and make a polygon with vertices at (58pt, 203pt), (58pt, 507.5pt), (536.5pt, 507.5pt), (536.5pt, 420.5pt), (290pt, 420.5pt) and (290pt, 203pt) as shown in Figure 11.57.

![Figure 11.57: Newspaper Example — Added L Shaped Frame](image)

11. Switch to the select tool, and select this L shaped polygon, and assigned the flowframe data shown in Figure 11.58. Note that the Alignment field has been set to Top to ensure that if there is insufficient text to fill the frame, all blank space will go at the bottom of the frame, and thus help to keep the frame’s shape. I used Parshape rather than Shapepar to define the frame’s shape as I don’t want it to shrink and grow to fit the text.
The frame contents are quite long. You can either set the text in FlowframTk or use one of flowfram’s commands in the document. Here’s the full text:

The authorities are warning of a killer wolf on the loose. He has so far devoured an old grandmother and two pig brothers. He is described as being furry with big eyes and big teeth.

On Monday this week he broke into a house, and devoured an old lady. He then disguised himself as the old lady in order to deceive her granddaughter. Luckily for the little girl a woodsman arrived in time to rescue her. Parents are being cautioned not to let their children wander about on their own, and to remind them not to talk to strangers.

The next day the wolf struck again, this time targeting two pig brothers who had most incautiously made their dwellings on the cheap using inadequate materials. The wolf also made an attempt on the third pig brother, but was unable to break into his house.

Police are appealing to the public for witnesses, and remind people to keep their doors securely fastened at all times.

‘‘Always ask to see identification,’’ said one police advisor, ‘‘and invest in improving the general security of your property.’’

12. I’m going to illustrate the story in the right hand column. The image egg.png is supplied with the flowfram package but is also available in the examples sub-directory of FlowframTk’s installation directory. Use Bitmap → Insert Bitmap to insert the bitmap on the canvas. This will initially appear in the top left hand corner of the canvas. Move it over to the location shown in Figure 11.59, ei-
11.7 A NEWSPAPER

ther by dragging it or by using Edit → Move By and specifying a horizontal (x) displacement of 472.8pt and a vertical (y) displacement of 206pt.

Figure 11.59: Newspaper Example — Added Image

13. Set the flowframe data shown in Figure 11.60 to this bitmap. Note that you must set the Border setting to As Shown, otherwise the bitmap will not appear in the document.

14. Next comes the right hand frame. This is a polygon with a stepped area that goes around the bitmap. Select the closed line tool, and construct a polygon with vertices at: (304.5pt, 203pt), (304.5pt, 406pt), (536.5pt, 406pt), (536.5pt, 290pt), (478.5pt, 290pt), (478.5pt, 261pt), (464pt, 261pt), (464pt, 232pt), (478.5pt, 232pt) (478.5pt, 217.5pt), (493pt, 217.5pt) and (493pt, 203pt) as shown in Figure 11.61.

15. Switch to the select tool, select this polygon and assign the flowframe data shown in Figure 11.62. Note that the Shape field has been set to Parshape and the Alignment field has been set to Top. Again, the contents of the frame are quite long and can either be set using FlowframTk or using on of flowfram’s commands in the document. I’m going to set the contents using FlowframTk, as above. The text is as follows:
Figure 11.60: Newspaper Example — Assigning Flowframe Data to Bitmap

Figure 11.61: Newspaper Example — Added Right Hand Polygon
An egg person tragically fell from a six foot wall yesterday afternoon and was smashed to pieces. The king’s cavalry rushed to the scene, but regretted that they were unable to help him.

Humpty Dumpty was believed to be sitting on the wall when he fell. Police have ruled out foul play, but are advising people not to play on high walls, particularly those vulnerable members of the population suffering from eggshell syndrome.

Exclusive interview with one of the King’s men on page 6.

---

16. I’m going to add an L-shaped segment between the left and right blocks to clearly delineate them. Switch to the open line tool, and construct a path with vertices at: (297.25pt, 159.5pt), (297.25pt, 413.25pt) and (536.5pt, 413.25pt) as shown in Figure 11.63.

17. Switch to the select tool, select this new path and assign the flowframe data shown in Figure 11.64. Make sure that you have set the Border field to As Shown.

18. Next comes a horizontal divider to separate the top two columns from the bottom columns (which will be created later). Select the open line tool, and construct a line with end points at: (58pt, 514.75pt) and (536.5pt, 514.75pt) as shown in Figure 11.65.

19. Switch to the select tool, select this line and assign the flowframe data shown in Figure 11.66.

20. Next comes another header frame. Select the rectangle tool, and construct a rectangle with opposing corners at: (58pt, 522pt) and (536.5pt, 551pt) as shown in Figure 11.67.
11.7 A NEWSPAPER

Figure 11.63: Newspaper Example — Added L Shaped Divider

Figure 11.64: Newspaper Example — Assigning Flowframe Data to L Shaped Divider
11.7 A NEWSPAPER

Figure 11.65: Newspaper Example — Added Horizontal Divider

Figure 11.66: Newspaper Example — Assigning Flowframe Data to Horizontal Divider
Figure 11.67: Newspaper Example — Added Lower Header
21. Switch to the select tool, select this rectangle, and assign the flowframe data as shown in Figure 11.68. The frame contents is another sectioning command:

\section{Relief as Missing Sheep Finally Return Home}

Figure 11.68: Newspaper Example — Assigning Flowframe Data to Lower Header

22. At the bottom of the page, I want to have two columns, with the text flowing from the left hand column into the right hand column. This means that these frames need to be flow frames. Select the rectangle tool, and construct two rectangles with opposing corners at:

- \((58\text{pt}, 565.5\text{pt})\) and \((290\text{pt}, 783\text{pt})\)
- \((304.5\text{pt}, 565.5\text{pt})\) and \((536.5\text{pt}, 783\text{pt})\)

as shown in Figure 11.69.

23. Switch to the select tool, select the left lower rectangle and assign the flowframe data shown in Figure 11.70. Similarly for the right hand lower rectangle.

24. I also want to have an image in the lower left hand frame. This is going to be slightly more complicated as flow frames can not be assigned a shape like the static and dynamic frames. The image I’m going to use is called sheep.png and is provided with the flowfram package, but it is also available in the examples subdirectory of FlowframTk’s installation directory. Use Bitmap → Insert Bitmap to insert this image, and then either drag it with the mouse or use the Edit → Move By dialog box to move it by \((50\text{pt}, 556\text{pt})\) to the location shown in Figure 11.71.

25. Assign this bitmap the flowframe data shown in Figure 11.72.

26. As it stands, any text in the left flow frame will overlap the sheep image, so I’m going to construct a new polygon to go around the sheep image. This polygon will not form a frame, but will be used to construct the parameters of the \parshape command, which can then be input at the start of the flow frame. To do this, select the closed line tool, and construct a polygon with vertices at: \((116\text{pt}, 565.5\text{pt})\), \((116\text{pt}, 580\text{pt})\), \((101.5\text{pt}, 580\text{pt})\), \((101.5\text{pt}, 609\text{pt})\), \((58\text{pt},\)
Figure 11.69: Newspaper Example — Added Lower Left and Right Rectangles

Figure 11.70: Newspaper Example — Assigning Flowframe Data to Lower Left Rectangle
Figure 11.71: Newspaper Example — Added Sheep Bitmap

Figure 11.72: Newspaper Example — Assigning Flowframe Data to Sheep Bitmap
Figure 11.73: Newspaper Example — Added Polygon Defining Text Region
27. Select this polygon, and select the \TeX/LaTeX → Parshape menu item. This will open the dialog box shown in Figure 11.74(a). Select the Use Path option and click Okay. Save to a file named sheepcutout.tex (Figure 11.74(b)).

![Parshape dialog](image)

(a) ![Export dialog](image)

(b)

Figure 11.74: Newspaper Example — computing \parshape parameters: (a) select “Use Path” option; (b) export dialog.

28. Open the preamble editor using \TeX/LaTeX → Preamble and set the preamble code as follows:

\begin{verbatim}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{lmodern}
\AtBeginDocument{%
  % suppress section numbering
  \setcounter{secnumdepth}{0}
  % set the paragraph indentation for static
  % and dynamic frames
  \setlength{\sdfparindent}{\parindent}
}\end{verbatim}

(See Figure 11.75.)

29. Construct a rectangle with opposing corners at: (551.0, 797.5) and (580.0, 826.5) as shown in Figure 11.76.

30. Following the same procedure as before, select this new rectangle and make it a dynamic frame with the label “footer” and middle alignment. Then click on the Compute Symmetric X Shift button to calculate the horizontal shift for even pages. Set the contents to just \itshape (see Figure 11.77).

31. Save the image as newspaper.jdr and then select the File → Export menu item. Select the Class (*.cls) filter, and save as newspaper.cls.

32. Use your favourite text editor to create a file called news.tex that looks like:
Figure 11.75: Newspaper Example — Setting the Preamble Code
Figure 11.76: Newspaper Example — Constructing the Footer Frame
Figure 11.77: Newspaper Example — Assigning the Footer Frame Data
There was much celebration yesterday morning when Little Bo Peep’s sheep finally returned home. They had been missing for more than a week.

‘‘I just didn’t know where to find them,’’ the shepherdess stated, ‘‘but I was told to leave them alone and they’d come home.’’

This file is also available in the examples subdirectory of FlowframTk’s installation directory.

33. The included images are PNG files, which means that if you are not using PDFLaTeX you will have to convert them to Encapsulated Postscript (EPS) to use LaTeX and dvips. Run news.tex through LaTeX, e.g.

```
pdflatex news
```

The resulting document is shown in Figure 11.78.

Things to note:

- You may have noticed that I had the page list for all my frames set to All. Naturally if you want more pages in your document, you will need to change this. However on your final page you will need to specify an open ended range. For example, if you have a 4 page document, then at least one flow frame defined on page 4 should have a page list like >3. This is because the flowfram package looks ahead for the next flow frame before it ships out the page. If there are no more flow frames defined, it will automatically create a new flow frame, and you may end up with an unwanted page.

- The twoside class option is required to ensure the footer frame’s horizontal shift is implemented on even pages. Since this example only has one page, there’s no noticable difference.

- If you use FlowframTk to create \parshape’d paragraphs for your document, you must make sure that the normal font size setting in FlowframTk’s Document Settings dialog box is the same as that used by your document, otherwise it will affect the shape of the paragraph. Likewise, if your paragraph contains larger or smaller than normal lines this will also adversely affect the paragraph shape, and you will need to adjust the shape of the path accordingly.

Since I exported to a class rather than a package, the class file correctly sets the normal font size to match the setting used by the image, and I’m only using
There was much celebration yesterday morning when Little Bo Peep’s sheep finally returned home. They had been missing for more than a week.

“I just didn’t know where to find them,” the shepherdess stated, “but I was told to leave them alone and they’d come home.”

Unusual advice perhaps, but it seems to have worked as they did indeed come home. Eye witnesses reported that their tails were wagging behind them. “I’m just so happy they’ve come home,” Little Bo Peep said in a press conference yesterday afternoon. The sheep themselves made no comment, and police are still trying to determine what happened to them. The big bad wolf is reportedly helping them with their inquiries.

Police are appealing to the public for witnesses, and remind people to keep their doors securely fastened at all times.

“Always ask to see identification,” said one police advisor, “and invest in improving the general security of your property.”
normal sized text in my paragraphs with no displayed material, so I don’t need to worry about it. However, if I had exported to a package, newspaper.sty, which was then included in the document using:

```latex
\documentclass[twoside,12pt]{article}
\usepackage{newspaper}
```

\begin{document}
\% set the paragraph shape
\input{sheepcutout}
\% suppress paragraph indentation
\noindent
There was much celebration yesterday morning when Little Bo
\% etc

Then the paragraph shape will go wrong if the document normal size doesn’t match the image’s normal size setting (see Figure 11.79).

![Figure 11.79: The normal font size setting affects paragraph shapes: (a) both the L\TeX document and FlowframTk have been set to use a normal size font of 12pt — the paragraph follows the correct shape; (b) the L\TeX document used 12pt as the normal font size, but FlowframTk had the normal font size set to 10pt — the paragraph has too many narrow lines and spills over the bottom of the frame.](image)

11.8 A Brochure

This example illustrates how to use FlowframTk to create a class that loads the flowfram package. The aim is to produce a two-sided document with different recto and verso headers and footers.

1. For this example I’m going to start with the Tschichold grid. Use Settings → Grid → Grid Settings to open the grid dialog box. Select the Tschichold tab and set the Major Divisions to 100pt, as shown in Figure 11.80. Make sure that the grid lock is on (Settings → Grid → Lock Grid).

2. Use Settings → Configure Te\LaTeX Settings to open the Te\LaTeX Settings dialog and select the Document Settings tab. Set the Normal Font Size to 10pt,
as shown in Figure 11.81, and make sure the Use default class radio button is selected.

3. Set the image storage unit to pt using Settings → Configure Image Settings dialog box, as shown in Figure 11.82.

4. Select the rectangle tool (either via Tools → Rectangle or Ctrl-R) and draw the rectangle with three of its vertices on the diagonals, as shown in Figure 11.83. With the grid lock on, you are limited to only fourteen tick marks.

5. Switch to the select tool (Tools → Select or Ctrl-P) and select the rectangle. The open the Typeblock dialog using TeX/LaTeX → Flow Frames → Set Typeblock. Click on the Compute Margins From Selected Path button. (If this button is disabled, close the dialog and check that the rectangle has been selected.) This will fill the margins, but it looks a bit untidy with all those decimal places and since a pt is so small such precision seems unnecessary so round the Left and Top margins to the nearest pt (66pt and 94pt, respectively). Make sure the Adjust width to nearest: field is set to 1pc and click on the Adjust Width button. This should alter the Right field. Make sure the Baselineskip radio button is selected and click on the Adjust Height button. Finally, click on the Compute button to calculate the even page shift. The settings should now be as shown in Figure 11.84. Click on the okay button to apply these settings and close the dialog.

6. The typeblock is slightly smaller than the rectangle so, making sure the rectangle is still selected, use the menu item TeX/LaTeX → Flow Frames → Scale to Fit Typeblock to scale the rectangle so that it’s the same size as the typeblock. Then use the TeX/LaTeX → Flow Frames → Set Frame menu item to open the Set Frame dialog. Set the Type to Flow, set the Label to “main” and set the Border to None, as shown in Figure 11.85. The margins and shifts should all be zero and the page list All.

7. Now use Settings → Grid Settings to switch the grid to a rectangular grid with 100pt major divisions and use the ellipse tool (Tools → Ellipse or Ctrl-E) to create a circle with a 100pt radius, as shown in Figure 11.86.
If you change the storage unit, all coordinates in the current frame will be converted to the new storage unit. This may take a while if you have a large or complex image, so it’s generally best to set the storage unit before you start your image. The storage unit is independent of the grid unit. Some settings, such as line width or font size, are independent of the storage unit.
Figure 11.83: Brochure Example — Draw a Rectangle
8. Switch to the select tool (Tools → Select or Ctrl-P), select the circle and switch to edit path mode (Edit → Pathedit or Ctrl-I). Use the popup menu to remove a segment and convert two segments into lines so that the path is now an arc as shown in Figure 11.87.

9. Exit the edit path mode and move the path to the bottom right edge of the canvas, as shown in Figure ??

10. Use Edit → Fill Colour to change the fill colour to orchid (68% red, 36% green, 100% blue) and use Edit → Path → Line Colour to change the line colour to transparent. The arc should now appear as shown in Figure 11.89.

11. Make sure the arc is still selected and open the Set Frame dialog using TeX/LaTeX → Flow Frames → Set Frame menu item. Set the Type to Dynamic, set the Label to “footer”, set the Border to As Shown, set the Pages to Odd and set the Alignment to Middle. Set the Left and Top margins to 40pt and the Right and Bottom margins to 10pt. Next, click on the Edit button to open the mini TeX editor and enter:

\textbf{\color{white}\Huge}

as shown in Figure 11.90(a). Click on the okay button to close the editor and return to the Set Frame dialog, which should now look like Figure 11.90(b).

12. Click okay to apply the new settings and close the dialog. The image should now appear as shown in Figure 11.91.

13. Copy (Edit → Copy or Ctrl-C) and paste (Edit → Paste or Ctrl-V) the arc to create a duplicate. The duplicate should now be the only object selected. Use Transform
Figure 11.85: Brochure Example — Setting the Main Flow Frame
Figure 11.86: Brochure Example — Draw a Circle
Figure 11.87: Brochure Example — Change the Circle into an Arc
Figure 11.88: Brochure Example — Move the Arc to the Bottom Right Corner
Figure 11.89: Brochure Example — Apply a Fill Paint to the Arc
Figure 11.90: Brochure Example — Setting the odd footer: (a) entering the frame contents; (b) the frame settings.
Figure 11.91: Brochure Example — Arc is Now an Odd Footer
→ Scale to open the Scale Selection dialog and set the Scale X field to $-1$, as shown in Figure 11.92. Click on the okay button and this should flip the duplicate arc.

![Figure 11.92: Brochure Example — Flipping the Duplicate Arc](image)

14. With the duplicate arc still selected, use TeX/LaTeX → Flow Frames → Set Frame to open the Set Frame dialog box again. Set the Label to “evenfooter”, set the Pages to Even, set the Left margin to 10pt and the Right margin to 40pt. The dialog should now appear as shown in Figure 11.93.

![Figure 11.93: Brochure Example — Setting the Even Footer](image)

15. Use TeX/LaTeX → Flow Frames → Display Page to open the Display Frames dialog and select the Even Pages radio button, as shown in Figure 11.94.
11.8 A BROCHURE

The canvas should now look as shown in Figure 11.95. The “footer” frame is no longer displayed as it’s only defined on odd pages.

16. Move the “evenfooter” frame to the bottom left corner, so that it now appears as shown in Figure 11.96.

17. Use TeX/LaTeX → Flow Frames → Display Page to open the Display Frames dialog again and select the All Pages radio button and click on the okay button. The canvas should now look like Figure 11.97. The “evenfooter” frame now appears in a different location, but that’s just its odd page position. Since the page list is set to even pages only, it won’t actually be displayed in the location in the document.

18. Use the closed-line tool (Tools → Closed Line) and create the path shown in Figure 11.98. The co-ordinates are: (310,0), (360,50), (600,50) and (600,0).

19. Switch to the select tool (Tools → Select) and select this new polygon. Set the fill and line colour to orchid and transparent, as done earlier for the arc. Then use TeX/LaTeX → Flow Frames → Set Frame to open the Set Frame dialog again. Set the Type to Dynamic, set the Label to “header”, set the Pages to Odd, set the Border to As Shown, set the Alignment to Middle, set the Left to 50pt and set the remaining margins to 10pt. Then click on the Edit button to open the editor, and set the contents to:

\bfseries\Large

as shown in Figure 11.99(a). Click on the okay button to go close the editor and go back to the Set Frame dialog, which should now look like Figure 11.99(b).

20. Click on the okay button to apply these settings and close the dialog. Keep the polygon selected and copy and paste it to create a duplicate, as shown in Figure 11.100.

21. Flip the duplicate using the same method as earlier (Transform → Scale) and, keeping the duplicate selected, use TeX/LaTeX → Flow Frames → Set Frame to open the Set Frame dialog again. Set the Label to “evenheader” and change the left margin to 10pt and the right margin to 50pt, as shown in Figure 11.101.

22. Use TeX/LaTeX → Flow Frames → Display Page to open the Display Frames dialog again and select the Even Pages radio button to switch to the even page view, as shown in Figure 11.102.

23. Move the “evenheader” frame to the top left corner of the canvas, as shown in Figure 11.103.
Figure 11.95: Brochure Example — Even Pages Display
Figure 11.96: Brochure Example — Moving the Even Footer
Figure 11.97: Brochure Example — “all pages” display mode shows all objects in their odd-page location.
Figure 11.98: Brochure Example — Adding a Closed Polygon
Figure 11.99: Brochure Example — Setting the odd header: (a) entering the frame contents; (b) the frame settings.
Figure 11.100: Brochure Example — Create a Duplicate Polygon
Figure 11.101: Brochure Example — Setting the Even Header
Figure 11.102: Brochure Example — Even Pages Display (Two Objects Hidden)
11.9 A HOUSE WITH NO MOUSE

As with the “evenfooter” frame, when you switch back to the “all pages” view, the frame will be displayed in its odd page position, but since the page list is set to even pages only, it won’t be displayed in the document at that location.

24. Save the image as brochure.jdr or brochure.ajr using the File → Save As menu item. Then use File → Export to open the Export dialog. Select the Class (*.cls) filter and export the image as brochure.cls.

25. Create a document that uses this new class. I’ve used the blindtext package to generate pages of dummy text for illustrative purposes:

```latex
\documentclass[twoside]{brochure}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{lmodern}
\usepackage{blindtext}
\begin{document}
\Blinddocument
\end{document}
```

A double-page spread view of the resulting document (pages 2 and 3) is shown in Figure 11.105.

11.9 A House With No Mouse

This example illustrates how to create and edit pictures without using the mouse.

1. For this example I’m going to use \texttt{bp} units, both for the grid and for the storage unit. To do this, use the menu mnemonics \texttt{Alt-S G G}. This will open up the Grid Settings dialog box shown in Figure 11.106. The Major Divisions field should already have the focus, but if not, you can do \texttt{Alt-M}. Set this value to 100. Press the \texttt{Tab} key to move to the unit drop-down list. Press the \texttt{b} key to select \texttt{bp}. Press \texttt{Tab} or \texttt{Alt-S} to select the Sub-Divisions field. Set this value to 10. Then press \texttt{Enter} or \texttt{Shift-Enter} to apply these settings and close the dialog box.

2. Use the menu mnemonics \texttt{Alt-S C} to open the Configure Image Settings dialog (Figure 11.107). If the Control Points tab isn’t already visible, you can do \texttt{Alt-C} to select it. Then do \texttt{Alt-U} to move the focus to the storage unit drop-down list. Press \texttt{b} to select \texttt{bp} or use the up/down cursor keys. If the focus is on a drop-down list you need to use \texttt{Shift-Enter} to apply these settings and close the dialog box. If you move the focus to another component, you can use \texttt{Enter} instead.

3. Make sure that you don’t have the grid lock on as some of the co-ordinates that this example uses lie between tick marks. \texttt{Shift-F2} or \texttt{Alt-S G L} toggles between setting the grid lock on and off.

4. Select the \texttt{rectangle tool}, using either \texttt{Ctrl-R} or \texttt{Alt-O R}.
11.9 A HOUSE WITH NO MOUSE

Figure 11.103: Brochure Example — Move Even Header

Figure 11.104: Brochure Example — All Pages View Again (All Frames Shown in their Odd Page Position)
11.9 A HOUSE WITH NO MOUSE

1.1 Heading on level 2 (subheading)


Figure 11.105: Brochure Example — Double-Page Spread View of Brochure
Figure 11.106: No Mouse Example — Grid Settings Dialog Box

Figure 11.107: No Mouse Example — Storage Unit
5. The rectangle forming the main part of the house will go from (100bp, 100bp) to (250bp, 200bp). To move the mouse either press F5 or use the menu mnemonic Alt-N G. This will open up the dialog box shown in Figure 11.108. Set the x field to 100bp and the y field to 100bp. (You can use the Tab key to move to the next focusable component, or you can use Alt-X to select the x field and Alt-Y to select the y field.) Then press Enter or Shift-Enter.

6. Press F4 to emulate a mouse click. This will anchor the rectangle at (100bp, 100bp). Then use either F5 or Alt-N G to display the Go To dialog box. Set the x field to 250bp and the y field to 200bp. Then press Enter or Shift-Enter.

7. To complete the rectangle, press either Enter or F4. (See Figure 11.109.)

8. Let’s make it a yellow brick house. To change the rectangle’s fill colour, we first need to switch to the select tool. To do this either use Ctrl-P or use the menu mnemonic Alt-O S.

9. To select the rectangle, use either F6 or Alt-N K. Alternatively, you can use Alt-N D which will show a dialog box with a drop-down list that you can use to select an object.

---

2Since there is only one object on the canvas, you could use any of the other select functions in the Navigate menu, but F6 is easier to type.
10. To change the fill colour use the menu mnemonic Alt-E L. This will open up the
dialog box shown in Figure 11.110.

![Figure 11.110: No Mouse Example — Set Fill Colour Dialog Box](image)

11. To select the Colour radio button, either do Alt-L or press Tab until the Colour
button has the focus, and then press Space.

12. The single colour selector will now be enabled. To change the colour to yellow,
you can do one of the following:

   • Press Tab until the yellow swatch is selected, and then press Space.
   • Press Alt-R to select the RGB panel and set the Red field to 100, the Green
     field to 100, the Blue field to 0 and the Alpha field to 100.
   • Press Alt-K to select the CMYK panel and set the Cyan field to 0, the Magenta
     field to 0, the Yellow field to 100, the Black field to 0 and the Alpha
     field to 100.

   Then press Enter or Shift-Enter to apply the fill colour and close the dialog box
   (see Figure 11.111).

13. Next we need to construct a triangle for the roof. The closed line path tool is
needed for this, so either use Ctrl+Shift-L or use the menu mnemonic Alt-O I.
11.9 A HOUSE WITH NO MOUSE

14. The triangle vertices will be at (80bp, 100bp), (175bp, 50bp) and (270bp, 100bp). Move to the first co-ordinate using either F5 or Alt-N G, and set the x field to 80bp and the y field to 100bp in the Go To dialog box. Press Enter or Shift-Enter to close the dialog box and move the mouse to the required location, and press F4 to set the first vertex.

15. Repeat the process for the second and third vertices, and press Enter to complete the path. The path will automatically close. (See Figure 11.112.)

16. Let’s make the roof red. First switch to the select tool using either Ctrl-P or Alt-O S.

17. Select the triangle using F6 or Alt-N K.

18. Open the fill colour dialog box using the menu mnemonic Alt-E L.

19. Use Alt-L to select the Colour radio button.

20. To set the colour to red either use the Tab key to move the focus to the red colour swatch and press Space or use Alt-R to select the RGB tab and set the Red field to 100, the Green and Blue fields to 0 and the Alpha field to 100.

21. Press Enter or Shift-Enter to set the fill colour and close the dialog box. (See Figure 11.113.)

22. Now for the windows: press Ctrl-R or use the menu mnemonic Alt-O R to select the rectangle tool.

23. Create four rectangles using the method described above with opposing vertices at:
   - Window 1: (120bp, 180bp), (145bp, 155bp)
   - Window 2: (120bp, 135bp), (145bp, 110bp)
11.9  A HOUSE WITH NO MOUSE

Figure 11.112: No Mouse Example — Completed Triangle

Figure 11.113: No Mouse Example — Triangle Fill Colour Set to Red
11.9 A HOUSE WITH NO MOUSE

- Window 3: (205bp, 135bp), (230bp, 110bp)
- Window 4: (205bp, 180bp), (230bp, 155bp)

See Figure 11.114.

![Figure 11.114: No Mouse Example — Windows Added](image)

24. To change the fill colour of the window rectangles, you will first need to switch to the select tool using either Ctrl-P or Alt-O S.

25. It’s more efficient to select all four of the window rectangles and change their fill colour simultaneously, rather than setting the fill colour individually. Since the four small rectangles are at the front of the stack, pressing Shift-F6 four times will select these four rectangles.

26. Now use the menu mnemonic Alt-E L to set the fill colour to white, following the same process as before to produce the image shown in Figure 11.115.

27. Now make a black rectangle with opposing corners at (160bp, 200bp) and (190bp, 160bp) using the same method as above, to produce the image shown in Figure 11.116.

28. To illustrate how to move objects using the keyboard, let’s now shift the house 100bp to the right and 50bp down. First make sure you are using the select tool. Then select all the objects using either Ctrl-A or Alt-E A.

29. Then either press F7 or use the menu mnemonic Alt-E M. This will open up the dialog box shown in Figure 11.117. Set the x field to 100bp and the y field to 50bp.

30. To illustrate how to edit a path using only the keyboard, let’s make the roof a bit shallower. First deselect all the objects using Ctrl+Shift-A or Alt-E D.

31. Press F6 repeatedly until the triangle is selected.
11.9  A HOUSE WITH NO MOUSE

Figure 11.115: No Mouse Example — Window Fill Colour Set

Figure 11.116: No Mouse Example — Completed House

Figure 11.117: No Mouse Example — Move Dialog Box
32. To enter edit mode, use either Ctrl-I or Alt-E H E. You should now see the path in edit mode. (See Figure 11.118.)

![Figure 11.118: No Mouse Example — Edit Mode](image)

33. Press F6 until the highest vertex is selected.

34. Press F3 to popup the edit path menu (Figure 11.119).

35. Press Alt-R to display the dialog box shown in Figure 11.120.

36. Set the y field to 120bp, and press Enter.

37. Press Ctrl-I to exit edit path mode. The image should now look like Figure 11.121.

38. To illustrate how to create a text area using the keyboard, let’s add a label. First select the text tool using either Ctrl-T or Alt-O T.

39. Press F5 or Alt-N G to display the Go To dialog box. Set the x field to 200bp and the y field to 100bp.

40. Press F4 to start the text area. You should now see a small pale rectangle with a cursor, as illustrated in Figure 11.122. Whilst this rectangle contains a cursor, you can type in text or press F3 to display the text area popup menu.

41. Type in the text House #1, then switch to the select tool (using Ctrl-P or Alt-O S.)

42. The text area contains one of \TeX’s special characters, namely the hash (#) character. This will cause a problem if you want to save your image as a pgfpicture environment if the auto escape special characters facility is not enabled. If so, you will need to modify the text area so that it has an alternative text to be used if the image is saved in a \LaTeX file. You can do this as follows:

   (a) Press F6 to select the text area.
11.9 A HOUSE WITH NO MOUSE

Figure 11.119: No Mouse Example — Edit Path Menu

Figure 11.120: No Mouse Example — Control Point Co-Ordinates Dialog Box

Figure 11.121: No Mouse Example — Editing Finished
(b) Press Ctrl+Shift-I or Alt-E X E to display the Edit Text dialog box. Select the Different button (either Tab to it and press Space or use Alt-D.) This will enable the alternate text field. Change the text to House \#1 (Figure 11.123).

(c) Press Enter or Shift-Enter to update the text area, and close the dialog box.

43. It would look better if the label was centred over the house. In order to use the align function, it is necessary to group all the objects that make up the house. This is done as follows:

44. Assuming you created all the objects in the same order as listing in this example, the text area should be at the front of the stack, then the door, the four windows, the roof and lastly the body of the house. You should still have the text area selected, and nothing else. If not, deselect all objects (Ctrl+Shift-A) and press F6 to select the text area.

45. Press F6 to deselect the text area and select the next object in the stack (the door).
46. Press Shift-F6 to add the next object to the selection. Keep pressing Shift-F6 until everything has been selected except the text area.

47. Press Ctrl-G or Alt-T G to group the selected objects.

48. Press Shift-F6 to add the text area to the selection.

49. Press Ctrl-G or Alt-T G to group the selected objects.

50. Use the menu mnemonic Alt-T J C to centre the objects.

51. Press Ctrl-U or Alt-T U to ungroup the objects. The image should now look like Figure 11.124. Note that the house had to be grouped and that group then grouped with the text area to ensure that the individual house components maintained their position relative to each other.

![Figure 11.124: No Mouse Example — Text is Now Centred](image)

52. If you want to save your image as a \textit{pgfpicture} environment, you will need to change the anchor settings to ensure that the text area in the \LaTeX\ file remains centred. (Otherwise font differences may cause the text to appear slightly off centre.) To do this:

   (a) Ensure that the text area is selected.
   (b) Use the menu mnemonic Alt-E X F A H to display the Horizontal Anchor Setting dialog box.
   (c) If the drop-down list doesn’t already have the focus, press Alt-A.
   (d) Press c or use the arrow keys to set the horizontal setting to Centre.
   (e) Press Enter or Shift-Enter to apply the settings and close the dialog box.

   (Note that you don’t need to do this if the Auto Adjust Anchor checkbox is selected in the \TeX/LaTeX\ Settings dialog as it will automatically update the anchor when you align the text area.)
11.10 A Lute Rose

This example illustrates how to use **symmetric shapes** and **patterns**. The aim is to design the lute rose (the decorative cover of a lute’s sound hole) shown in Figure 11.138. This example uses a radial grid. All co-ordinates \((r : \theta)\) are radial co-ordinates where \(r\) is the radius (bp) and \(\theta\) is the angle (degrees).

1. Set the paper size to A3 landscape using the Settings → Paper menu.

2. Use Settings → Grid → Grid Settings to select a radial grid with 100bp major division interval, 10 sub-divisions and 32 spokes. (See Figure 11.125.)

![Figure 11.125: Selecting a Radial Grid](image)

3. Create a path (using the open curve tool and the edit path tool) starting at \((20 : -170)\) containing three Bézier segments with control points:
   
   (a) \((145 : -145), (215 : -145), (200 : -170)\)
   
   (b) \((200 : 135), (200 : -115), (200 : 170)\)
   
   (c) \((210 : 150), (255 : 115), (200 : 100)\)
   
   (See Figure 11.126)

   ![Figure 11.126](image)

   Although the co-ordinates are being specified as radial co-ordinates, they are always stored as rectangular co-ordinates. This conversion may cause slight rounding errors.

4. In edit path mode, use the popup menu and select Path Symmetry → Has Symmetry (see Figure 11.127).

5. Using the edit path popup menu again, deselect Path Symmetry → Anchor Join (see Figure 11.128).

6. Still in edit path mode, move the control points governing the line of symmetry (coloured blue by default) to \((85 : -90)\) and \((215 : 90)\) (see Figure 11.129).
Figure 11.126: The Underlying Path

Figure 11.127: Give the Path Symmetry Using the Popup Menu

Figure 11.128: De-anchoring the End Control Using the Popup Menu
11.10 A LUTE ROSE

7. Select the last control point on the path (not including the line of symmetry) and select the edit path popup menu item Convert To Curve. This should add a curve segment that joins the underlying path with its reflection (see Figure 11.130). Note that this joining segment only has one curvature control to enforce symmetry.

8. Move the curvature control point on the join segment to \((200 : 0)\) (see Figure 11.131).

9. Leave edit path mode and, ensuring the path is still selected, use the Edit \(\rightarrow\) Path \(\rightarrow\) Line Styles \(\rightarrow\) All Styles menu item to change the path style to: 10bp pen width, round cap and round join (see Figure 11.132).

10. The path should now look like that shown in Figure 11.133.

11. Ensure that the path is selected. Use the Transform \(\rightarrow\) Pattern \(\rightarrow\) Set Pattern menu item. This should open the dialog box shown in Figure 11.134. Set the number of replicas to 11. Select the Rotational tab, and set the angle of rotation to 30 degrees.

12. The shape should now look like that shown in Figure 11.135.

13. Switch to edit path mode. You should now see an extra control point (coloured green by default). Move this control to \((0 : 0)\) (see Figure 11.136).

14. Leave path edit mode, select the ellipse tool and draw a circle around the pattern (see Figure 11.137).

15. Select the circle, set its fill colour to black and move the circle to the back of the stack. Select the pattern, and set its line colour to white. The image should now look as Figure 11.138.
Figure 11.131: Adjust the Curvature Control of the Join Segment
Figure 11.132: Change the Path Style
11.10 A LUTE ROSE

Figure 11.133: The Symmetric Path

Figure 11.134: Setting the Pattern
11.10 A LUTE ROSE

Figure 11.135: The Pattern

Figure 11.136: Move the Control Governing the Rotational Anchor

Figure 11.137: Add a Circle Around the Pattern

Figure 11.138: The Completed Lute Rose
A  JDR/AJR File Formats

FlowframTk has two native file formats that it can both read and write. The JDR (.jdr) format is binary written in the big-endian fashion. The AJR (.ajr) format is an ASCII format. The AJR format has less precision than the JDR format. The current version number for both formats is 1.8.

The first line of the ASCII AJR format must be:

AJR ⟨version⟩

where ⟨version⟩ is the version number. For example:

AJR 1.8

The version number must be followed by white space (such as a newline or space character).

The binary JDR format starts with a sequence of the three 16-bit Unicode characters “JDR” followed by the version string (not a decimal number) which is saved as an integer (the string length) followed by each character of the version string. In Java this is implemented using:

```java
dout.writeChars("JDR");
dout.writeInt(version.length());
dout.writeChars(version);
```

where `dout` is a `java.io.DataOutputStream` object and `version` is a `java.lang.String`.

The remainder of both the JDR and AJR formats have the same syntax but the data types are stored differently.

**integer**

The binary version writes 32-bit signed two's complement integers using the `writeInt(int)` method of the `java.io.DataOutputStream` class. The ASCII version writes the integer to the file followed by white space.

**byte**

The binary version writes 8-bit signed two’s complement bytes using the `writeByte(byte)` method of the `java.io.DataOutputStream` class. The ASCII version is the same as for the integer type, but the range of values is more limited.

**long**

The binary version writes 64-bit two’s complement integers using the `writeLong(long)` method of the `java.io.DataOutputStream` class. The ASCII version is the same as for the integer type.

**float**

The binary version writes single-precision 32-bit floating point values using the `writeFloat(float)` method of the `java.io.DataOutputStream` class. The ASCII version writes the number (possibly truncated) to the file followed by white space.

**double**

The binary version writes double-precision 64-bit floating point values using the `writeDouble(double)` method of the `java.io.DataOutputStream` class. The ASCII version is the same as for the float type.
**APPENDIX A. JDR/AJR FILE FORMATS**

```java
boolean
The binary version writes boolean values using the writeBoolean(boolean) method of the java.io.DataOutputStream class. The ASCII version writes the number 0 (false) or 1 (true) to the file followed by white space.

```char```
The binary version writes a single 16-bit Unicode character using the writeChar(int) method of the java.io.DataOutputStream class. The ASCII version writes the character followed by white space.

```string```
A string consisting of \(n\) 16-bit Unicode characters is written as an integer followed by the \(n\) characters of type `char`. For the binary format, this is equivalent to:

```java
dout.writeInt(text.length());
dout.writeChars(text);
```

where `dout` is a `java.io.DataOutputStream` object and `text` is a `java.lang.String`. For the ASCII format, the length is written as an integer followed by a single white space character. (Avoid using `println` for just \(n\) as the end-of-line character for some operating systems consists of two characters.) Then the string is written followed by white space. For example:

```java
out.print(String.format("%d %s ", text.length(), text));
```
or

```java
out.println(String.format("%d %s", text.length(), text));
```

(where `out` is a `java.io.PrintWriter` object.) As in the above example, a newline character can be used after the string, just not after the number.

A null or empty string is just written as the number 0. For example, for the binary version:

```java
dout.writeInt(0);
```
or for the ASCII version:

```java
out.print("0 ");
```
Transform-Matrix
A transformation matrix is saved as six `double` values representing the scale-x factor, the shear-y factor, the shear-x factor, the scale-y factor, the x-translation and the y-translation. For versions below 1.8, the translations are in terms of the `bp` PostScript unit, otherwise they are in terms of the storage unit.

Float-Array
An array of `float` values is stored as an `integer`\(\langle n\rangle\) indicating the length of the array (may be 0 for a null or empty array) followed by the \(\langle n\rangle\) `float` array elements.

Double-Array
An array of `double` values is stored as an `integer`\(\langle n\rangle\) indicating the length of the array (may be 0 for a null or empty array) followed by the \(\langle n\rangle\) `double` array elements.

Unit-Id
A unit identifier is stored as a `byte`. This may take one of eight values: 0 (pt), 1 (inch), 2 (cm), 3 (bp), 4 (mm), 5 (pc), 6 (dd) or 7 (cc).

Length
Lengths that are independent of the storage unit are stored as a `double` followed by the `unit-id`.

Angle
An angle is stored as a `double` followed by a `byte` indicating the unit where 0 represents radians and 1 represents degrees.

Paint
Colour data is stored as a `char` indicating the colour type \((\langle\text{col-id}\rangle)\). Available types are listed in Table A.1.

If \(\langle\text{col-id}\rangle\) is `T` (transparent) this ends the paint information. Otherwise \(\langle\text{col-id}\rangle\) is followed by the colour specifications \((\langle\text{colour-specs}\rangle)\).

### Table A.1: Available Colour Types

<table>
<thead>
<tr>
<th>Type</th>
<th>ID</th>
<th>Version</th>
</tr>
</thead>
<tbody>
<tr>
<td>Transparent</td>
<td>T</td>
<td>1.0 onwards</td>
</tr>
<tr>
<td>RGB</td>
<td>R</td>
<td>1.0 onwards</td>
</tr>
<tr>
<td>CMYK</td>
<td>C</td>
<td>1.0 onwards</td>
</tr>
<tr>
<td>Linear Gradient</td>
<td>G</td>
<td>1.0 onwards</td>
</tr>
<tr>
<td>Radial Gradient</td>
<td>D</td>
<td>1.3 onwards</td>
</tr>
<tr>
<td>Grey</td>
<td>Y</td>
<td>1.4 onwards</td>
</tr>
<tr>
<td>HSB</td>
<td>S</td>
<td>1.4 onwards</td>
</tr>
</tbody>
</table>

Rgb
RGB colour specs are saved as four `float` values in the range 0 to 1 (inclusive) representing the red, green, blue and alpha components.

cymk
CYMK colour specs are saved as five `float` values in the range 0 to 1 (inclusive) representing the cyan, magenta, yellow, black and alpha components.
APPENDIX A. JDR/AJR FILE FORMATS

HSB

HSB colour specs are saved as four float values representing the hue, saturation, brightness and alpha components. The hue value must lie in the range 0 (inclusive) to 360 (exclusive). The other values must lie in the range 0 to 1 (inclusive).

grey

Grey specs are saved as two float values in the range 0 to 1 (inclusive) representing the grey and alpha components.

linear-paint

Linear gradient paint specs are saved as the start paint, the end paint followed by an integer indicating the direction, which may be one of: 0 (North), 1 (North-East), 2 (East), 3 (South-East), 4 (South), 5 (South-West), 6 (West) or 7 (North-West). FlowframTk doesn’t support another gradient type as the start or end paint.

radial-paint

Radial gradient paint specs are saved as the start paint, the end paint followed by an integer indicating the starting location, which may be one of: 0 (North), 1 (North-East), 2 (East), 3 (South-East), 4 (South), 5 (South-West), 6 (West), 7 (North-West) or 8 (Centre). FlowframTk doesn’t support another gradient type as the start or end paint.

Spaces in any syntax specifications below are for clarity and ease of line breaking only and don’t form part of the specification (although white space may be acceptable at that point in the ASCII AJR format, according to the above data types).

1.

<table>
<thead>
<tr>
<th>JDR1.8 onwards</th>
</tr>
</thead>
<tbody>
<tr>
<td>⟨storage-id⟩</td>
</tr>
</tbody>
</table>

Regardless of whether or not the settings are saved in the file, as from JDR/AJR version 1.8 the storage unit ⟨storage-id⟩ is always present immediately after the version number and is used for all lengths described below (including coordinates) unless otherwise indicated. The unit is saved as a unit-id type, as described above.

Versions below 1.8 must have all lengths stored as PostScript points.

2.

⟨settings-id⟩

Next is a value ⟨settings-id⟩ indicating whether or not the FlowframTk settings are stored. In version 1.3 onwards, this value is a byte, and may take one of three values: 0 (no settings), 1 (all settings) or 2 (paper size only). In versions prior to 1.3, this value is a boolean value, where true indicates all settings and false indicates no settings.
3. The settings information is stored as follows when the \texttt{\langle settings-id \rangle} is 1:

\begin{itemize}
  \item JDR1.0–1.7
    \begin{itemize}
      \item \texttt{\langle show-grid \rangle \langle lock-grid \rangle \langle show-rulers \rangle \langle tool-id \rangle \langle normalsize \rangle \langle paper \rangle \langle grid \rangle}
    \end{itemize}
  \item JDR1.8 onwards
    \begin{itemize}
      \item \texttt{\langle show-grid \rangle \langle lock-grid \rangle \langle show-rulers \rangle \langle tool-id \rangle \langle paper \rangle \langle grid \rangle \langle point size \rangle \langle scale flag \rangle}
    \end{itemize}
\end{itemize}

If \texttt{\langle settings-id \rangle} is 2, just \texttt{\langle paper \rangle} is present.

3.1. \texttt{\langle show-grid \rangle} is a \texttt{boolean} variable indicating whether or not to display the grid.

3.2. \texttt{\langle lock-grid \rangle} is a \texttt{boolean} variable indicating whether or not to lock the grid.

3.3. \texttt{\langle show-rulers \rangle} is a \texttt{boolean} variable indicating whether or not to show the rulers.

3.4. \texttt{\langle tool-id \rangle} is an \texttt{integer} indicating which tool to select. For versions below 1.8, this must be an \texttt{integer} in the range 0 and 7 (inclusive). As from version 1.8, this must be in the range 0 and 8 (inclusive). Table A.2 indicates the ID for each tool.

\begin{table}[h]
\centering
\caption{Tool Identifiers}
\begin{tabular}{ll}
\hline
\textbf{ID} & \textbf{Tool} \\
0 & Select \\
1 & Open Line Path \\
2 & Closed Line Path \\
3 & Open Curve Path \\
4 & Closed Curve Path \\
5 & Rectangle \\
6 & Ellipse \\
7 & Text \\
7 & Maths (as from version 1.8) \\
\hline
\end{tabular}
\end{table}

3.5. For versions below 1.8, \texttt{\langle normalsize \rangle} is an \texttt{integer} indicating the \LaTeX\ normal font size. As from version 1.8, this value is stored later (see below) and isn’t governed by the settings flag.

3.6. The \texttt{\langle paper \rangle} specs are:

\begin{itemize}
  \item JDR1.0–1.2
    \begin{itemize}
      \item \texttt{\langle paper-id \rangle \langle width \rangle \langle height \rangle \langle portrait-flag \rangle}}
    \end{itemize}
\end{itemize}
APPENDIX A. JDR/AJR FILE FORMATS

JDR1.0–1.2

\langle paper-id \rangle \{ \langle width \rangle \langle height \rangle \}

JDR1.3 onwards

The paper size \langle paper-id \rangle is specified as a byte. For versions below 1.3, this must be a number in the range 0 to 18 (inclusive), otherwise it must be in the range 0 to 72 (inclusive). Table A.3 indicates the ID for each paper size, and Table A.4 shows additional values for version 1.3 onwards. If the paper size has an ID of 18 (user defined), then there must follow the paper \langle width \rangle (a \texttt{double} in \texttt{bp}) and \langle height \rangle (a \texttt{double} in \texttt{bp}). For versions prior to 1.3, the user defined setting must also be followed by \langle portrait-flag \rangle a \texttt{boolean} variable to indicate whether or not the orientation is portrait (true) or landscape (false). The paper dimensions are always stored in PostScript points (bp) and the unit id isn’t saved. (This is still true for version 1.8.)

Table A.3: Paper Size Identifiers

<table>
<thead>
<tr>
<th>ID</th>
<th>Paper Size</th>
<th>ID</th>
<th>Paper Size</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>A0 (portrait)</td>
<td>9</td>
<td>A0 (landscape)</td>
</tr>
<tr>
<td>1</td>
<td>A1 (portrait)</td>
<td>10</td>
<td>A1 (landscape)</td>
</tr>
<tr>
<td>2</td>
<td>A2 (portrait)</td>
<td>11</td>
<td>A2 (landscape)</td>
</tr>
<tr>
<td>3</td>
<td>A3 (portrait)</td>
<td>12</td>
<td>A3 (landscape)</td>
</tr>
<tr>
<td>4</td>
<td>A4 (portrait)</td>
<td>13</td>
<td>A4 (landscape)</td>
</tr>
<tr>
<td>5</td>
<td>A5 (portrait)</td>
<td>14</td>
<td>A5 (landscape)</td>
</tr>
<tr>
<td>6</td>
<td>letter (portrait)</td>
<td>15</td>
<td>letter (landscape)</td>
</tr>
<tr>
<td>7</td>
<td>legal (portrait)</td>
<td>16</td>
<td>legal (landscape)</td>
</tr>
<tr>
<td>8</td>
<td>executive (portrait)</td>
<td>17</td>
<td>executive (landscape)</td>
</tr>
<tr>
<td>18</td>
<td>user defined</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

JDR1.3 onwards

3.7. The \langle grid style \rangle has the syntax:

\langle unit \rangle \langle major \rangle \langle minor \rangle

where:

3.3.7.1. \langle unit \rangle is the \texttt{unit-id} used for the rulers and grid. (Restricted to: 0 (\texttt{\LaTeX pt}), 1 (inches), 2 (centimetres) or 3 (PostScript points).)

3.3.7.2. \langle major \rangle and \langle minor \rangle are integers representing the major grid divisions and the subdivisions, respectively.

JDR1.6 onwards

\langle grid-id \rangle \langle grid-specs \rangle

The \langle grid-id \rangle is a byte representing the grid style ID. This may be:
## Table A.4: Additional Paper Size Identifiers (JDR v1.3 onwards)

<table>
<thead>
<tr>
<th>ID</th>
<th>Paper Size</th>
<th>ID</th>
<th>Paper Size</th>
</tr>
</thead>
<tbody>
<tr>
<td>19</td>
<td>A6 (portrait)</td>
<td>46</td>
<td>A6 (landscape)</td>
</tr>
<tr>
<td>20</td>
<td>A7 (portrait)</td>
<td>47</td>
<td>A7 (landscape)</td>
</tr>
<tr>
<td>21</td>
<td>A8 (portrait)</td>
<td>48</td>
<td>A8 (landscape)</td>
</tr>
<tr>
<td>22</td>
<td>A9 (portrait)</td>
<td>49</td>
<td>A9 (landscape)</td>
</tr>
<tr>
<td>23</td>
<td>A10 (portrait)</td>
<td>50</td>
<td>A10 (landscape)</td>
</tr>
<tr>
<td>24</td>
<td>B0 (portrait)</td>
<td>51</td>
<td>B0 (landscape)</td>
</tr>
<tr>
<td>25</td>
<td>B1 (portrait)</td>
<td>52</td>
<td>B1 (landscape)</td>
</tr>
<tr>
<td>26</td>
<td>B2 (portrait)</td>
<td>53</td>
<td>B2 (landscape)</td>
</tr>
<tr>
<td>27</td>
<td>B3 (portrait)</td>
<td>54</td>
<td>B3 (landscape)</td>
</tr>
<tr>
<td>28</td>
<td>B4 (portrait)</td>
<td>55</td>
<td>B4 (landscape)</td>
</tr>
<tr>
<td>29</td>
<td>B5 (portrait)</td>
<td>56</td>
<td>B5 (landscape)</td>
</tr>
<tr>
<td>30</td>
<td>B6 (portrait)</td>
<td>57</td>
<td>B6 (landscape)</td>
</tr>
<tr>
<td>31</td>
<td>B7 (portrait)</td>
<td>58</td>
<td>B7 (landscape)</td>
</tr>
<tr>
<td>32</td>
<td>B8 (portrait)</td>
<td>59</td>
<td>B8 (landscape)</td>
</tr>
<tr>
<td>33</td>
<td>B9 (portrait)</td>
<td>60</td>
<td>B9 (landscape)</td>
</tr>
<tr>
<td>34</td>
<td>B10 (portrait)</td>
<td>61</td>
<td>B10 (landscape)</td>
</tr>
<tr>
<td>35</td>
<td>C0 (portrait)</td>
<td>62</td>
<td>C0 (landscape)</td>
</tr>
<tr>
<td>36</td>
<td>C1 (portrait)</td>
<td>63</td>
<td>C1 (landscape)</td>
</tr>
<tr>
<td>37</td>
<td>C2 (portrait)</td>
<td>64</td>
<td>C2 (landscape)</td>
</tr>
<tr>
<td>38</td>
<td>C3 (portrait)</td>
<td>65</td>
<td>C3 (landscape)</td>
</tr>
<tr>
<td>39</td>
<td>C4 (portrait)</td>
<td>66</td>
<td>C4 (landscape)</td>
</tr>
<tr>
<td>40</td>
<td>C5 (portrait)</td>
<td>67</td>
<td>C5 (landscape)</td>
</tr>
<tr>
<td>41</td>
<td>C6 (portrait)</td>
<td>68</td>
<td>C6 (landscape)</td>
</tr>
<tr>
<td>42</td>
<td>C7 (portrait)</td>
<td>69</td>
<td>C7 (landscape)</td>
</tr>
<tr>
<td>43</td>
<td>C8 (portrait)</td>
<td>70</td>
<td>C8 (landscape)</td>
</tr>
<tr>
<td>44</td>
<td>C9 (portrait)</td>
<td>71</td>
<td>C9 (landscape)</td>
</tr>
<tr>
<td>45</td>
<td>C10 (portrait)</td>
<td>72</td>
<td>C10 (landscape)</td>
</tr>
</tbody>
</table>
0 A rectangular grid. The \langlegrid-specs\rangle are:

\langleunit\rangle\langlemajor\rangle\langleminor\rangle

where
3.3.7.1. \langleunit\rangle is the \textit{unit-id} representing the grid unit.
3.3.7.2. \langlemajor\rangle is a \texttt{double} representing the major grid division (in terms of the grid unit).
3.3.7.3. \langleminor\rangle is an \texttt{integer} representing the grid subdivision.

1 A radial grid. The \langlegrid-specs\rangle are:

\langleunit\rangle\langlemajor\rangle\langleminor\rangle\langlespokes\rangle

where:
3.3.7.1. \langleunit\rangle is the \textit{unit-id}.
3.3.7.2. \langlemajor\rangle is a \texttt{double} representing the major grid division.
3.3.7.3. \langleminor\rangle is an \texttt{integer} representing the grid subdivision.
3.3.7.4. \langlespokes\rangle is an \texttt{integer} representing the number of spokes.

2 An isometric grid (Version 1.8 onwards.) The \langlegrid-specs\rangle are:

\langleunit\rangle\langlemajor\rangle\langleminor\rangle

where
3.3.7.1. \langleunit\rangle is the \textit{unit-id} representing the grid unit.
3.3.7.2. \langlemajor\rangle is a \texttt{double} representing the major grid division (in terms of the grid unit). This is the length of each side of the equilateral triangles that form the grid.
3.3.7.3. \langleminor\rangle is an \texttt{integer} representing the grid subdivision.

3 A Tschichold grid (Version 1.8 onwards.) The \langlegrid-specs\rangle are the same as for the rectangular grid.

JDR1.6 onwards

3.8.

\begin{itemize}
\item JDR1.8 onwards
\end{itemize}

\langlepoint\rangle\langlescale\rangle

As from JDR version 1.8, the \langlepoint\rangle is also saved as a \texttt{length}, followed by a \texttt{boolean} value \langlescale\rangle indicating whether the \texttt{control point} scaling is enabled.

JDR1.8 onwards

4.

\begin{itemize}
\item JDR1.8 onwards
\end{itemize}

\langlenormalsize\rangle\langlepreamble\rangle\langleclassname\rangle\langleabsolute\rangle
For version 1.8 onwards, the \LaTeX\ normal size value is always saved at this point, regardless of the \langle\text{settings-id}\rangle. In addition, from version 1.8, preamble text, document class and absolute pages setting are now saved.

4.1. The normal size value \langle\text{normalsize}\rangle is stored as an \text{integer}.

4.2. The preamble text \langle\text{preamble}\rangle is stored as a \text{string} and may be empty or null.

4.3. If the default document class setting is enabled, \langle\text{classname}\rangle is saved as an empty or null \text{string} otherwise the user specified \langle\text{classname}\rangle is saved.

4.4. The \langle\text{absolute pages flag}\rangle is saved as a \text{boolean} value, where true indicates \text{flowfram}'s \texttt{pages=absolute} option and false indicates \text{flowfram}'s \texttt{pages=relative} option.

JDR1.8 onwards

5. The \textit{objects} that constitute the image are now stored. When saving to a file, an outer grouping is implied that is not evident whilst using \textit{FlowframTk}. This means that there should always be a single group structure saved to file which contains all the \textit{objects} that constitute the picture. Each \textit{object} is then recursively stored. For example, if an image contains a \textit{path}, a \textit{group} and a \textit{text area}, in the \textit{JDR/AJR} file these three objects will be stored as a single group structure containing the three objects. If in \textit{FlowframTk} you explicitly \textit{group} all the objects, then in the \textit{JDR} file, the outermost implicit group will contain only one \textit{object} which will be this \textit{group}. It’s an error for the top-level object to be anything other than a \textit{group}.

Each \textit{object} has the following format:

\begin{verbatim}
JDR1.0 & 1.1
\langle id-char \rangle \langle object-specs \rangle \langle fflag \rangle \[ \langle flowframe-specs \rangle \]
\end{verbatim}

\begin{verbatim}
JDR1.0 & 1.1
\langle id-char \rangle \langle object-specs \rangle \langle fflag \rangle \[ \langle flowframe-specs \rangle \] \langle description \rangle
\end{verbatim}

JDR1.2 onwards

where \langle id-char \rangle is a \text{char} determining the object type:

\begin{verbatim}
JDR1.0–1.4
• G — group;
• P — path;
• T — text area;
• I — bitmap.
\end{verbatim}

JDR1.5

As versions 1.0–1.4. Additionally:
• X — text-path

JDR1.5 onwards

As version 1.5. Additionally:

• S — symmetric shape;
• R — rotational pattern;
• C — scaled pattern;
• L — spiral pattern.

JDR1.6 onwards

The object specifications \( \langle\text{object-specs}\rangle \) vary according to the object type and are described below. \( \langle\text{fflag}\rangle \) is a boolean value indicating whether or not this object has flowframe data associated with it. If true, then the flowframe specifications \( \langle\text{flowframe-specs}\rangle \) should follow (see below), otherwise \( \langle\text{flowframe-specs}\rangle \) should be omitted. Note that JDR version 1.2 and above contains the string \( \langle\text{description}\rangle \), which was omitted in earlier versions.

Recall from above that the image is stored with an implied outer grouping. The \( \langle\text{flowframe-specs}\rangle \) for this implicit group represents the image typeblock and the \( \langle\text{description}\rangle \) represents the image description.

The \( \langle\text{object-specs}\rangle \) are as follows:

1. Group data, \( \mathcal{G} \), is stored as:

   \[
   \langle n \rangle \langle \text{object data} \rangle^+ 
   \]

   where \( n \) is an integer indicating the number of objects within the group. There should then follow \( n \) lots of \( \langle\text{object data}\rangle \), where \( \langle\text{object data}\rangle \) is the data for each object within the group, and is as described above.

2. Path data, \( \mathcal{P} \), is stored as follows:

   - JDR1.0–1.2
     \[
     \langle \text{line paint} \rangle \langle \text{fill paint} \rangle \langle \text{line style} \rangle O|C \langle n \rangle \langle \text{segment data} \rangle^+ 
     \]
   - JDR1.3–1.5
     \[
     \langle \text{line paint} \rangle \langle \text{fill paint} \rangle \langle \text{line style} \rangle \langle \text{path specs} \rangle 
     \]
   - JDR1.6
     \[
     \langle \text{path style} \rangle \langle \text{path specs} \rangle 
     \]
JDR1.7 onwards

⟨path style⟩⟨path specs⟩⟨anchor info⟩

where ⟨line paint⟩ and ⟨fill paint⟩ are paint specifications and ⟨line style⟩ is the line style data (see below).

The ⟨path specs⟩ are

\[O|C\ ⟨n⟩ ⟨start point⟩ ⟨segment data⟩+\]

where the char value \(O\) or \(C\) indicates whether the path is open (\(O\)) or closed (\(C\)), \(⟨n⟩\) is an integer indicating the number of segments that constitute the path. This should be followed by \(⟨n⟩\) lots of ⟨segment data⟩ (described below).

Version 1.3 removed the redundancy present in earlier versions but requires that the starting point ⟨start point⟩ follows the number of segments (⟨n⟩). The starting point is stored as two double numbers. For versions below 1.8, these values are always in terms of the PostScript point \(bp\). As from version 1.8, they are in terms of the storage unit, as described above.

Version 1.7 added anchor information (⟨anchor info⟩). This comes after the above path specifications. Control points are indexed from 0 and include curvature control points. For example, a path that consists of a line segment followed by a Bézier segment has 5 control points: index 0 is the point at the start of the path (the start of the line segment), index 1 is the point at the join between the line segment and Bézier segment, indices 2 and 3 are the two curvature control points and index 4 is the end point. The anchor information is the list of integer indices for which the anchor is on. This list must be in ascending order of index and is terminated by \(-1\). Only control points occurring between a continuous join may be anchored.

For example, in the ASCII AJR version

\[3\ 6\ 9\ \ -1\]

indicates that control points 3, 6 and 9 have the anchor setting on. If no controls are anchored, the \(-1\) is still required.

2.1. Version 1.7 onwards stores the ⟨path style⟩ specification as

\⟨id⟩ ⟨specs⟩\n
where ⟨id⟩ is a byte indicating the path style. This may be 0 (basic stroke) or 1 (text-path stroke).

2.2.1.1. The basic stroke ⟨specs⟩ are:

\⟨line paint⟩ ⟨fill paint⟩ ⟨line style⟩\n
where ⟨line style⟩ is described below.
2.2.1.2. The text-path stroke \(\textit{specs}\) are:

\[
\langle\textit{line\ paint}\rangle\langle\textit{text-path\ style}\rangle
\]

where \(\textit{text-path\ style}\) is described below.
A path should only have a text-path stroke if it is the base path for a composite shape.

2.2. The \(\textit{line\ style}\) data has changed from file version 1.0 to 1.1 to take into account the inclusion of mid point markers, and is stored as follows:

<table>
<thead>
<tr>
<th>JDR1.0</th>
<th>JDR1.1 and above</th>
</tr>
</thead>
<tbody>
<tr>
<td>(\langle\textit{linewidth}\rangle\langle\textit{dash}\rangle\langle\textit{cap}\rangle\langle\textit{join}\rangle\langle\textit{mitre-limit}\rangle\langle\textit{winding}\rangle\langle\textit{start\ arrow}\rangle\langle\textit{end\ arrow}\rangle)</td>
<td>(\langle\textit{linewidth}\rangle\langle\textit{dash}\rangle\langle\textit{cap}\rangle\langle\textit{join}\rangle\langle\textit{mitre-limit}\rangle\langle\textit{winding}\rangle\langle\textit{start\ arrow}\rangle\langle\textit{mid\ marker}\rangle\langle\textit{end\ arrow}\rangle)</td>
</tr>
</tbody>
</table>

where:

2.2.2.1. \(\textit{linewidth}\) the line width stored as a float (below version 1.8) in PostScript points (bp). For version 1.8 onwards, the line width is stored as a length.

2.2.2.2. \(\textit{dash}\) is the dash pattern. This is stored as a float-array, optionally followed by the float offset. The array may be empty or null to indicate a solid line, otherwise it should have an even number of elements representing \(\textit{dash}\langle\textit{gap}\rangle\) pairs. The offset is only saved for a non-empty, non-null array.

The unit of measurement (not saved in the dash pattern specs) is bp for versions below 1.8 and the storage unit for version 1.8 onwards.

2.2.2.3. \(\textit{cap}\) is the cap style, stored as a byte. It may only have one of the following values: 0 (butt), 1 (round) or 2 (square).

2.2.2.4. \(\textit{join}\) is the join style, stored as a byte. It may only have one of the following values: 0 (mitre), 1 (round) or 2 (bevel).

2.2.2.5. \(\textit{mitre-limit}\) is the mitre-limit and should only be stored if the join style is a mitre. For versions below 1.8, the mitre-limit is stored as a float, otherwise it’s stored as a length.

2.2.2.6. \(\textit{winding}\) is the winding rule, stored as a byte. It may only have one of the following values: 0 (Even-Odd) or 1 (Non Zero).

2.2.2.7. \(\textit{start\ arrow}\) and \(\textit{end\ arrow}\) are the starting and ending arrow styles. The \(\textit{mid\ marker}\) is the style for the mid-point markers. Each marker type (start/mid/end) has the same format, but the file format varies as follows:

<table>
<thead>
<tr>
<th>JDR1.0</th>
<th>JDR1.1 and above</th>
</tr>
</thead>
</table>

\[
\langle\textit{id}\rangle\langle\textit{size}\rangle\langle\textit{is\ double}\rangle\langle\textit{is\ reversed}\rangle
\]

The \(\textit{mid\ marker}\) is the style for the mid-point markers. Each marker type (start/mid/end) has the same format, but the file format varies as follows:

<table>
<thead>
<tr>
<th>JDR1.0</th>
<th>JDR1.1 and above</th>
</tr>
</thead>
</table>

\[
\langle\textit{id}\rangle\langle\textit{size}\rangle\langle\textit{is\ double}\rangle\langle\textit{is\ reversed}\rangle
\]
where \( \langle id \rangle \) is a byte identifying the arrow type. This may be one of: 0 (none), 1 (pointed), 2 (triangle), 3 (circle), 4 (diamond), 5 (square), 6 (bar) or 7 (single). \( \langle size \rangle \) is float representing the arrow size. (Some arrows only have a fixed size, but a size must still be present.) \( \langle is double \rangle \) is a boolean value indicating whether the arrow head is a double arrow (true) or a single arrow (false). \( \langle is reversed \rangle \) is a boolean value indicating whether the arrow head has been reversed. The values \( \langle size \rangle \langle is double \rangle \langle is reversed \rangle \) are omitted if \( \langle id \rangle \) equals 0 (no arrow head).

\[
\langle id \rangle \langle marker data \rangle
\]

where \( \langle id \rangle \) is a byte identifying the marker type. If \( \langle id \rangle \) is 0, then \( \langle marker data \rangle \) should be omitted, otherwise it should be present. Valid \( \langle id \rangle \) values are listed in Table A.5.

The \( \langle marker data \rangle \) is stored as follows:

\[
\langle size \rangle \langle repeat \rangle \langle is reversed \rangle \langle orient data \rangle \langle colour data \rangle \langle overlay \rangle \langle composite data \rangle
\]

where:

- \( \langle size \rangle \) is a float representing the marker size (some markers will ignore this attribute, but it must still be present in the file.)
- \( \langle repeat \rangle \) is a byte identifying the repeat factor (a value of 1 indicates a single marker, a value of 2 indicates a double marker, a value of 3 indicates a triple marker.)
- \( \langle is reversed \rangle \) is a boolean value indicating whether or not the marker has been reversed.
- \( \langle orient data \rangle \) is the marker orientation data. This has the form \( \langle auto-orient \rangle \langle angle \rangle \) where \( \langle auto-orient \rangle \) is a boolean value indicating whether the marker should be oriented along the path. If \( \langle auto-orient \rangle \) is true, \( \langle angle \rangle \) should be omitted, otherwise \( \langle angle \rangle \) should be a float representing the orientation angle (in radians).
- \( \langle colour data \rangle \) is the marker paint where a transparent value indicates the colour should be derived from the path to which the marker is attached, and there is no provision for gradient paint markers.
- \( \langle overlay \rangle \) is a boolean value indicating whether to overlay composite markers.
- \( \langle composite data \rangle \) is the data for composite markers. This has the same format as the \( \langle marker data \rangle \). If the \( \langle composite data \rangle \) has a marker id of 0, then the marker is not a composite marker. Although the format allows for nested composite markers, FlowframTk’s marker settings dialog boxes do not allow for it.
### Table A.5: Marker IDs

<table>
<thead>
<tr>
<th>No.</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>No marker</td>
</tr>
<tr>
<td>1</td>
<td>Pointed</td>
</tr>
<tr>
<td>2</td>
<td>Triangle</td>
</tr>
<tr>
<td>3</td>
<td>Circle</td>
</tr>
<tr>
<td>4</td>
<td>Diamond</td>
</tr>
<tr>
<td>5</td>
<td>Square bracket</td>
</tr>
<tr>
<td>6</td>
<td>Bar</td>
</tr>
<tr>
<td>7</td>
<td>Single</td>
</tr>
<tr>
<td>8</td>
<td>Round bracket</td>
</tr>
<tr>
<td>9</td>
<td>Dot Filled</td>
</tr>
<tr>
<td>10</td>
<td>Dot Open</td>
</tr>
<tr>
<td>11</td>
<td>Box Filled</td>
</tr>
<tr>
<td>12</td>
<td>Box Open</td>
</tr>
<tr>
<td>13</td>
<td>Cross</td>
</tr>
<tr>
<td>14</td>
<td>Plus</td>
</tr>
<tr>
<td>15</td>
<td>Star</td>
</tr>
<tr>
<td>16</td>
<td>Triangle Up Filled</td>
</tr>
<tr>
<td>17</td>
<td>Triangle Up Open</td>
</tr>
<tr>
<td>18</td>
<td>Triangle Down Filled</td>
</tr>
<tr>
<td>19</td>
<td>Triangle Down Open</td>
</tr>
<tr>
<td>20</td>
<td>Rhombus Filled</td>
</tr>
<tr>
<td>21</td>
<td>Rhombus Open</td>
</tr>
</tbody>
</table>

### Table A.6: Additional Marker IDs (JDR 1.4)

<table>
<thead>
<tr>
<th>No.</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>22</td>
<td>Pentagon Filled</td>
</tr>
<tr>
<td>23</td>
<td>Pentagon Open</td>
</tr>
<tr>
<td>24</td>
<td>Hexagon Filled</td>
</tr>
<tr>
<td>25</td>
<td>Hexagon Open</td>
</tr>
<tr>
<td>26</td>
<td>Octagon Filled</td>
</tr>
<tr>
<td>27</td>
<td>Octagon Open</td>
</tr>
<tr>
<td>28</td>
<td>Pointed 60</td>
</tr>
<tr>
<td>29</td>
<td>Pointed 45</td>
</tr>
<tr>
<td>30</td>
<td>Hooks</td>
</tr>
<tr>
<td>31</td>
<td>Hook up</td>
</tr>
<tr>
<td>32</td>
<td>Hook Down</td>
</tr>
<tr>
<td>33</td>
<td>Half Pointed Up</td>
</tr>
<tr>
<td>34</td>
<td>Half Pointed Down</td>
</tr>
<tr>
<td>35</td>
<td>Half Pointed 60 Up</td>
</tr>
<tr>
<td>36</td>
<td>Half Pointed 60 Down</td>
</tr>
<tr>
<td>37</td>
<td>Half Pointed 45 Up</td>
</tr>
<tr>
<td>38</td>
<td>Half Pointed 45 Down</td>
</tr>
<tr>
<td>39</td>
<td>Cusp</td>
</tr>
<tr>
<td>40</td>
<td>Half Cusp Up</td>
</tr>
<tr>
<td>41</td>
<td>Half Cusp Down</td>
</tr>
<tr>
<td>42</td>
<td>Alt Single</td>
</tr>
<tr>
<td>43</td>
<td>Alt Single Open</td>
</tr>
<tr>
<td>44</td>
<td>Triangle Open</td>
</tr>
<tr>
<td>45</td>
<td>Circle Open</td>
</tr>
<tr>
<td>46</td>
<td>Diamond Open</td>
</tr>
<tr>
<td>47</td>
<td>Brace</td>
</tr>
<tr>
<td>48</td>
<td>Rectangle Cap</td>
</tr>
<tr>
<td>49</td>
<td>Chevron Cap</td>
</tr>
<tr>
<td>50</td>
<td>Fast Cap</td>
</tr>
<tr>
<td>51</td>
<td>Round Cap</td>
</tr>
<tr>
<td>52</td>
<td>Triangle Cap</td>
</tr>
<tr>
<td>53</td>
<td>Inverted Triangle Cap</td>
</tr>
<tr>
<td>54</td>
<td>Inverted Chevron Cap</td>
</tr>
<tr>
<td>55</td>
<td>Inverted Fast Cap</td>
</tr>
<tr>
<td>56</td>
<td>Alt Bar</td>
</tr>
<tr>
<td>57</td>
<td>Alt Round</td>
</tr>
<tr>
<td>58</td>
<td>Alt Square</td>
</tr>
<tr>
<td>59</td>
<td>Alt Brace</td>
</tr>
<tr>
<td>60</td>
<td>Open Semicircle</td>
</tr>
<tr>
<td>61</td>
<td>Filled Semicircle</td>
</tr>
<tr>
<td>62</td>
<td>Open 5 Pointed star</td>
</tr>
<tr>
<td>63</td>
<td>Filled 5 Pointed star</td>
</tr>
<tr>
<td>64</td>
<td>Asterisk</td>
</tr>
<tr>
<td>65</td>
<td>Scissors Down Filled</td>
</tr>
<tr>
<td>66</td>
<td>Scissors Up Filled</td>
</tr>
<tr>
<td>67</td>
<td>Scissors Down Open</td>
</tr>
<tr>
<td>68</td>
<td>Scissors Up Open</td>
</tr>
<tr>
<td>69</td>
<td>Heart Right Filled</td>
</tr>
<tr>
<td>70</td>
<td>Heart Right Open</td>
</tr>
<tr>
<td>71</td>
<td>Heart Filled</td>
</tr>
<tr>
<td>72</td>
<td>Heart Open</td>
</tr>
<tr>
<td>73</td>
<td>Snowflake</td>
</tr>
<tr>
<td>74</td>
<td>Star Chevron Open</td>
</tr>
<tr>
<td>75</td>
<td>Star Chevron Filled</td>
</tr>
<tr>
<td>76</td>
<td>Star 6 Filled</td>
</tr>
<tr>
<td>77</td>
<td>Star 6 Open</td>
</tr>
<tr>
<td>78</td>
<td>Equilateral Filled</td>
</tr>
<tr>
<td>79</td>
<td>Equilateral Open</td>
</tr>
</tbody>
</table>

### Table A.7: Additional Marker IDs (JDR 1.6)

<table>
<thead>
<tr>
<th>No.</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>80</td>
<td>Ball Cap</td>
</tr>
<tr>
<td>81</td>
<td>Leaf Cap</td>
</tr>
<tr>
<td>82</td>
<td>Double Leaf Cap</td>
</tr>
<tr>
<td>83</td>
<td>Triple Leaf Cap</td>
</tr>
<tr>
<td>84</td>
<td>Club Cap</td>
</tr>
<tr>
<td>85</td>
<td>Forward Triple Leaf Cap</td>
</tr>
<tr>
<td>86</td>
<td>Back Triple Leaf Cap</td>
</tr>
<tr>
<td>87</td>
<td>Forward Double Leaf Cap</td>
</tr>
<tr>
<td>88</td>
<td>Back Double Leaf Cap</td>
</tr>
<tr>
<td>89</td>
<td>Cutout Bulge Cap</td>
</tr>
</tbody>
</table>
JDR1.4 onwards
For version 1.4 onwards the markers are stored as

\[ \text{〈id〉} \text{〈marker data〉} \]

where 〈id〉 is a byte identifying the marker type. If 〈id〉 is 0, then 〈marker data〉 should be omitted, otherwise it should be present. Valid 〈id〉 values are listed in Table A.5 and Table A.6. Additional markers listed in Table A.7 are also available for version 1.6 onwards.

The 〈marker data〉 is stored as follows:

\[ \text{〈size〉 (repeat) (is reversed) 〈orient data〉 〈colour data〉 〈overlay〉 [〈user offset flag〉 [〈user offset〉] [〈repeat offset flag〉 [〈repeat offset〉]]] (composite data) } \]

(spaces for syntax clarity) where: 〈user offset flag〉 [〈user offset〉] [〈repeat offset flag〉 [〈repeat offset〉]] are only specified if the 〈overlay〉 is false. Additionally, 〈user offset〉 and 〈repeat offset〉 are only specified if 〈user offset flag〉 or 〈repeat offset flag〉 are true, respectively.

- 〈size〉 is a float (bp unit implied) for versions below 1.8 and is a length for version 1.8 onwards.
- 〈repeat〉 is a byte identifying the repeat factor (a value of 1 indicates a single marker, a value of 2 indicates a double marker, a value of 3 indicates a triple marker.)
- 〈is reversed〉 is a boolean value indicating whether or not the marker has been reversed.
- 〈orient data〉 is the marker orientation data. This is as for versions 1.1–1.3 except that for version 1.8 onwards the orientation 〈angle〉 (if required) is stored as an angle.
- 〈colour data〉 is the marker paint as for versions 1.1–1.3.
- 〈overlay〉 is a boolean value indicating whether to overlay composite markers.

If the 〈overlay〉 is false:
- 〈user offset flag〉 is a boolean value indicating whether the marker offset is specified by the user (true) or determined automatically (false).
- 〈user offset〉 indicates the marker offset from the vertex. For versions below 1.8 this is stored as a float (bp unit implied) otherwise it’s stored as a length. This is only present if 〈user offset flag〉 is true.
- 〈repeat offset flag〉 is a boolean indicating whether the repeat offset (i.e. gap between repeat markers) is specified by the user (true) or determined automatically (false).
- 〈repeat offset〉 indicates the gap between repeat markers. For versions below 1.8 this is stored as a float (bp unit implied) otherwise it’s stored as a length. This is only present if 〈repeat offset flag〉 is true.

- 〈composite data〉 is the data for composite markers. This has the same format as the 〈marker data〉. If the 〈composite data〉 has
a marker id of 0, then the marker is not a composite marker. Although the format allows for nested composite markers, FlowframTk’s marker settings dialog boxes do not allow for it.

2.3. Each path segment \((\text{segment data})\) is stored as:

\[
\langle \text{id} \rangle \langle \text{specs} \rangle
\]

where \(\langle \text{id} \rangle\) is a \textit{char} representing the segment type. This can be one of: \(B\) (cubic Bézier), \(L\) (line) or \(M\) (move). For versions below 1.8, the co-ordinates are always \text{bp}. As from version 1.8, the co-ordinate unit is as specified by the storage unit described above.

2.2.3.1. Bézier segments are stored as follows:

\[
\begin{align*}
\text{JDR1.0–1.2} & : \langle c0x \rangle \langle c0y \rangle \langle c1x \rangle \langle c1y \rangle \langle c2x \rangle \langle c2y \rangle \langle c3x \rangle \langle c3y \rangle \\
\text{JDR1.3 onwards} & : \langle c1x \rangle \langle c1y \rangle \langle c2x \rangle \langle c2y \rangle \langle c3x \rangle \langle c3y \rangle
\end{align*}
\]

where \(\langle c0x \rangle\) and \(\langle c0y \rangle\) are the \(x\) and \(y\) co-ordinates of the starting point, \(\langle c1x \rangle\) and \(\langle c1y \rangle\) are the \(x\) and \(y\) co-ordinates of the first curvature control point, \(\langle c2x \rangle\) and \(\langle c2y \rangle\) are the \(x\) and \(y\) co-ordinates of the second curvature control point, and \(\langle c3x \rangle\) and \(\langle c3y \rangle\) are the \(x\) and \(y\) co-ordinates of the end point. Each value is stored as a \text{double}. The unit of measurement is \text{bp} for versions below 1.8, otherwise it’s the storage unit described above.

2.2.3.2. Line and move to (gap) segments are stored as follows:

\[
\begin{align*}
\text{JDR1.0–1.2} & : \langle x0 \rangle \langle y0 \rangle \langle x1 \rangle \langle y1 \rangle \\
\text{JDR1.3 onwards} & : \langle x1 \rangle \langle y1 \rangle
\end{align*}
\]

where \(\langle x0 \rangle\) and \(\langle y0 \rangle\) are the \(x\) and \(y\) co-ordinates of the starting point and \(\langle x1 \rangle\) and \(\langle y1 \rangle\) are the \(x\) and \(y\) co-ordinates of the end point. Each value is stored as a \text{double}. The unit of measurement is \text{bp} for versions below 1.8, otherwise it’s the storage unit described above.

3. Text area \((T)\) data is stored as follows:

\[
\begin{align*}
\text{JDR1.0–1.7} & : \langle \text{font-specs} \rangle \langle \text{transform} \rangle \langle \text{latex-flag} \rangle \langle \{ \text{latex-specs} \} \rangle \langle \text{text paint} \rangle \langle \text{text} \rangle \\
\text{JDR1.8 onwards} & : \langle \text{outline-flag} \rangle \langle \{ \text{fill paint} \} \rangle \langle \text{font-specs} \rangle \langle \text{transform} \rangle \langle \text{latex-flag} \rangle \langle \{ \text{latex-specs} \} \rangle
\end{align*}
\]
3.1. ⟨outline-flag⟩ is a boolean value that indicates whether or not the text should be rendered as an outline. If true, ⟨fill paint⟩ follows, which is the paint used to fill the interior. A transparent paint indicates the interior shouldn’t be filled.

3.2. ⟨font-specs⟩ has the syntax:

⟨family⟩ ⟨shape⟩ ⟨weight⟩ ⟨size⟩

The ⟨family⟩ must be a non-empty, non-null string indicating the name of the font (as used by FlowframTk, not when exported to a \TeX file, so it’s a system font rather than a \TeX font).

The ⟨shape⟩ is a byte indicating the font shape (0 for upright, 1 for emphasized, 2 for italic, 3 for slanted and 4 for smallcaps). Version 1.6 and below only permitted 0 or 1 for the shape. Although the file format allows five different shape styles, java.awt.Font only supports plain or italic, so when rendering on the canvas, FlowframTk treats emphasized, italic and slanted as Font.ITALIC and the other styles as Font.PLAIN. The Italic option in the font style dialogs actually sets the shape to type 1 (emphasized) rather than type 2.

The ⟨weight⟩ is a byte indicating the font weight (0 for medium, 1 for bold).

For versions below 1.8 the font size is a non-negative integer, otherwise it’s stored as a non-negative length.

3.3. ⟨transform⟩ is a transform-matrix indicating the text transformation relative to the top left corner of the canvas.

3.4. The ⟨latex-flag⟩ is a boolean value that indicates whether the \TeX-related attributes (⟨latex specs⟩) are saved. If true, the syntax for ⟨latex specs⟩ is

\[
\langle latex font specs \rangle \langle h-align \rangle \langle v-align \rangle \langle latex text \rangle
\]

The ⟨latex font specs⟩ are the \TeX font declarations: ⟨family⟩, ⟨weight⟩, ⟨shape⟩ and ⟨size⟩. Each attribute is stored as a string.

The ⟨h-align⟩ element represents the horizontal alignment and is stored as a byte that may be one of: 0 (left), 1 (centre) or 2 (right).

The ⟨v-align⟩ element represents the vertical alignment and is stored as a byte that may be one of: 0 (top), 1 (middle), 2 (baseline) or 3 (bottom).
APPENDIX A. JDR/AJR FILE FORMATS

The \LaTeX{} alternative text (\textit{\texttt{latex text}}) is a \texttt{string}. If empty or null, the \LaTeX{} alternative text should be considered equivalent to \texttt{⟨text⟩}.

4. Bitmap (I) information is stored as follows:

\texttt{⟨filename⟩ \langle latex-flag⟩ \langle [latex-bitmap-specs]⟩ \langle transformation⟩}

where:

4.1. \texttt{⟨filename⟩} is a non-empty, non-null \texttt{string} containing the file name. This may be a path relative to the JDR/AJR file for version 1.8 onwards.

4.2. If the \textbf{boolean} value \texttt{⟨latex-flag⟩} is true, it must be followed by \texttt{⟨latex-bitmap-specs⟩}

4.3. \texttt{⟨latex-bitmaps-specs⟩} has the following format:

\texttt{⟨lfilename⟩ ⟨imgcmd⟩}

where \texttt{⟨lfilename⟩} is a \texttt{string} containing the \LaTeX{} pathname for the bitmap. A null or empty value indicates it should be determined from \texttt{⟨filename⟩} (replacing the pathname separator with / if necessary). The image command is stored in the \texttt{string} \texttt{⟨imgcmd⟩} and may be empty or null.

4.4. \texttt{⟨transformation⟩} is a \texttt{transform-matrix}. The origin is the bottom left corner of the bitmap.

5. Composite Shapes

As from version 1.6, all \texttt{composite shapes} except \texttt{symmetric shape} (X, R, C and L) have \texttt{⟨object-specs⟩} in the form:

\texttt{⟨modifier specs⟩ ⟨underlying shape specs⟩}

For \texttt{symmetric shapes} (S) the syntax is:

\texttt{⟨underlying shape specs⟩ ⟨modifier specs⟩}

The \texttt{⟨underlying shape specs⟩} is the specification for the underlying shape in the form:

\texttt{⟨id-char⟩ ⟨object-specs⟩}

where \texttt{⟨id-char⟩} is as \texttt{above}, but limited to the shape IDs, so the text (T), bitmap (B) and group (G) IDs aren’t permitted here.

The underlying shape may be another \texttt{composite shape}. Descendent underlying shapes refer to the \texttt{composite shape’s} underlying shape and any descendent of that underlying shape if it is also a composite shape. The base underlying shape is the maximal descendent underlying shape and must be a path (P), in
which case ⟨id-char⟩ ⟨object-specs⟩ will be \( V \langle path \ style \rangle \langle path \ specs \rangle \langle anchor \ info \rangle \) (⟨anchor info⟩ is omitted below version 1.7).

Although the descendent underlying shapes may be another composite shape, they can’t share the same type as either their ancestor or descendent shapes. For example, a text-path may have a pattern as its underlying shape, but a pattern can’t have another pattern as its underlying shape.

The ⟨modifier specs⟩ are as follows:

5.1. Text-paths (Χ) are not available for versions below 1.5. The ⟨modifier specs⟩ are:

<table>
<thead>
<tr>
<th>JDR1.8 onwards</th>
<th>JDR1.6–1.8</th>
</tr>
</thead>
<tbody>
<tr>
<td>⟨outline-flag⟩ ⟨fill paint⟩ ⟨underlying shape specs⟩</td>
<td>⟨underlying shape specs⟩</td>
</tr>
</tbody>
</table>

For version 1.5 the ⟨object-specs⟩ are:

<table>
<thead>
<tr>
<th>JDR1.5</th>
</tr>
</thead>
<tbody>
<tr>
<td>⟨text paint⟩ ⟨line style⟩ ⟨path specs⟩</td>
</tr>
</tbody>
</table>

For version 1.5, the ⟨line style⟩ and ⟨path specs⟩ are as described earlier. The base path must have the text-path stroke (id 1) \( \langle path \ style \rangle \) jdr:pathtyle.

5.5.1.1. For this type of composite shape, the ⟨modifier specs⟩ are only present from version 1.8 and relate to the outline option ⟨outline-flag⟩ ⟨fill paint⟩, which is the same as for text-areas.

5.5.1.2. The ⟨text-path style⟩ is stored as:

\[ \langle font \ specs \rangle \langle transform \rangle \langle latex-flag \rangle \langle latex specs \rangle \langle text \rangle \]

where:

5.5.1.5.1.2.1. ⟨font specs⟩ are the same as for text areas.

5.5.1.5.1.2.2. ⟨transform⟩ is a transform-matrix indicating the text transformation relative to the underlying shape (see §8.9 Combining a Text Area and Path to Form a Text-Path).

5.5.1.5.1.2.3. The ⟨latex-flag⟩ is a boolean value that indicates whether the \LaTeX-related attributes (⟨latex specs⟩) are saved. If true, the syntax for ⟨latex specs⟩ is:

\[ \langle latex \ font \ specs \rangle \langle h-align \rangle \langle v-align \rangle \langle latex \ text \rangle \]
5.5.1.3. The \textit{text} is stored as a \texttt{string} and shouldn’t be empty or null.

5.2. Symmetric shapes ($\ominus$) are not available for versions below 1.6. For newer versions, the \texttt{(modifier specs)} are:

\[ \langle \textit{join anchored} \rangle \ [ \langle \textit{join segment} \rangle ] \ \langle \textit{symmetry x0} \rangle \ \langle \textit{symmetry y0} \rangle \ \langle \textit{symmetry x1} \rangle \ \langle \textit{symmetry y1} \rangle \ \langle \textit{closed} \rangle \ [ \langle \textit{close anchored} \rangle ] \ [ \langle \textit{closing segment} \rangle ] \]

where:

5.5.2.1. The \texttt{boolean} value \texttt{\langle join anchored \rangle} indicates whether or not the join between the original shape and its reflection is anchored.

5.5.2.2. \texttt{jdr:joinsegment} If the join isn’t anchored, \texttt{\langle join segment \rangle} is the information about the joining segment. This is omitted if \texttt{\langle join anchored \rangle} is true. The syntax for the join segment is:

\[ \langle \text{segment-id} \rangle \ [ \langle \text{segment specs} \rangle ] \]

where the \texttt{\langle segment-id \rangle} is a \texttt{char} indicating the segment type. This may be one of $m$ (gap), $l$ (line) or $c$ (Bézier curve).

5.5.2.5. The \texttt{(segment specs)} for both the gap ($m$) and line ($l$) segments is omitted.

5.5.2.5.2.1. The \texttt{(segment specs)} for the Bézier curve is:

\[ \langle cx \rangle \ \langle cy \rangle \]

where \texttt{\langle cx \rangle} and \texttt{\langle cy \rangle} are the $x$- and $y$-coordinates of the curvature control, respectively, and are each stored as a \texttt{double} (in terms of the PostScript point \texttt{bp} for versions below 1.8 and in terms of the storage unit otherwise).

5.5.2.3. The co-ordinates for the line of symmetry \texttt{(symmetry x0)} \texttt{(symmetry y0)} \texttt{(symmetry x1)} and \texttt{(symmetry y1)} are each stored as a \texttt{double} and are in terms of the PostScript point \texttt{bp} for versions below 1.8 otherwise are in terms of the storage unit.

5.5.2.4. The \texttt{boolean} value \texttt{\langle closed \rangle} indicates if the shape is closed.

5.5.2.5. If the shape is closed, the \texttt{(boolean) \langle close anchor \rangle} indicates whether or not the starting control is anchored to the line of symmetry (true indicates the anchor setting is on). If the shape isn’t closed, this value is omitted.
5.5.2.6. If the \(\text{close anchor}\) is false, the \(\text{closing segment}\) is the information about the segment used to close the shape. This has the same syntax as for the \(\text{join segment}\) described above. The \(\text{closing segment}\) data is omitted if \(\text{close anchor}\) is true.

5.3. **Rotational patterns** \(R\) are not available for versions below 1.6. For newer versions, the \(\text{modifier specs}\) are:

\[
\langle \text{shape-specs} \rangle \langle \text{anchor-x} \rangle \langle \text{anchor-y} \rangle \langle \text{angle} \rangle \langle \text{replicas} \rangle \langle \text{mode} \rangle \langle \text{show} \rangle
\]

where:

5.5.3.1. \(\text{shape-specs}\) are the underlying object’s specifications as described above.

5.5.3.2. \(\text{anchor-x}\) is a **double** representing the \(x\)-coordinate of the anchor point (in terms of the PostScript point \(\text{bp}\) for versions below 1.8, otherwise in terms of the storage unit).

5.5.3.3. \(\text{anchor-y}\) is a **double** representing the \(y\)-coordinate of the anchor point (in terms of the PostScript point \(\text{bp}\) for versions below 1.8, otherwise in terms of the storage unit).

5.5.3.4. \(\text{angle}\) is the angle of rotation and is stored as a **double** (in radians) for versions below 1.8, otherwise is stored as an **angle**.

5.5.3.5. \(\text{replicas}\) is an **integer** representing the number of replicas.

5.5.3.6. \(\text{mode}\) is a **boolean** variable, true if single-path mode.

5.5.3.7. \(\text{show}\) is a **boolean** variable, true if the underlying path is visible.

5.4. **Scaled patterns** \(C\) are not available for versions below 1.6. For newer versions, the specifications are:

\[
\langle \text{shape-specs} \rangle \langle \text{anchor-x} \rangle \langle \text{anchor-y} \rangle \langle \text{adjust-x} \rangle \langle \text{adjust-y} \rangle \langle \text{scale-x} \rangle \langle \text{scale-y} \rangle \langle \text{replicas} \rangle \langle \text{mode} \rangle \langle \text{show} \rangle
\]

where \(\text{shape-specs}\), \(\text{anchor-x}\), \(\text{anchor-y}\), \(\text{replicas}\), \(\text{mode}\) and \(\text{show}\) are as for the rotational pattern described above. Additionally:

5.5.4.1. \(\text{adjust-x}\) is a **double** representing the \(x\)-coordinate of the adjust control point (in terms of the PostScript point \(\text{bp}\) for versions below 1.8, otherwise in terms of the storage unit).

5.5.4.2. \(\text{adjust-y}\) is a **double** representing the \(y\)-coordinate of the adjust control point (in terms of the PostScript point \(\text{bp}\) for versions below 1.8, otherwise in terms of the storage unit).

5.5.4.3. \(\text{scale-x}\) is a **double** representing the \(x\)-scale factor.

5.5.4.4. \(\text{scale-y}\) is a **double** representing the \(y\)-scale factor.

5.5. **Spiral patterns** \(L\) are not available for versions below 1.6. For newer versions, the specifications are:

\[
\langle \text{shape-specs} \rangle \langle \text{anchor-x} \rangle \langle \text{anchor-y} \rangle \langle \text{adjust-x} \rangle \langle \text{adjust-y} \rangle \langle \text{angle} \rangle \langle \text{distance} \rangle \langle \text{replicas} \rangle \langle \text{mode} \rangle \langle \text{show} \rangle
\]
where \(<\text{shape-specs}>\), \(<\text{anchor-x}>\), \(<\text{anchor-y}>\), \(<\text{adjust-x}>\), \(<\text{adjust-y}>\), \(<\text{replicas}>\), \(<\text{mode}>\) and \(<\text{show}>\) are as for scaled patterns, described above. Additionally:

5.5.5.1. \(<\text{angle}>\) is the spiral angle parameter and is stored as a \text{double} (in radians) for versions below 1.8, otherwise is stored as an \text{angle}.

5.5.5.2. \(<\text{distance}>\) is a 64-bit double representing the spiral distance parameter.

Flow frame data is stored as follows:

\begin{verbatim}
JDR1.0–1.1
\langle\text{type}\rangle[\langle\text{border}\rangle\langle\text{label}\rangle\langle\text{pages}\rangle]\langle\text{top}\rangle\langle\text{bottom}\rangle\langle\text{left}\rangle\langle\text{right}\rangle
\end{verbatim}

\begin{verbatim}
JDR1.2
\langle\text{type}\rangle[\langle\text{border}\rangle\langle\text{label}\rangle\langle\text{pages}\rangle]\langle\text{top}\rangle\langle\text{bottom}\rangle\langle\text{left}\rangle\langle\text{right}\rangle[\langle\text{shape}\rangle]
\end{verbatim}

\begin{verbatim}
JDR1.3–1.7
\langle\text{type}\rangle[\langle\text{border}\rangle\langle\text{label}\rangle\langle\text{pages}\rangle]\langle\text{top}\rangle\langle\text{bottom}\rangle\langle\text{left}\rangle\langle\text{right}\rangle[\langle\text{shape}\rangle\langle\text{v-align}\rangle]
\end{verbatim}

\begin{verbatim}
JDR1.8 onwards
\langle\text{type}\rangle[\langle\text{border}\rangle\langle\text{label}\rangle\langle\text{pages}\rangle]\langle\text{top}\rangle\langle\text{bottom}\rangle\langle\text{left}\rangle\langle\text{right}\rangle[\langle\text{shape}\rangle\langle\text{v-align}\rangle\langle\text{contents}\rangle]\langle\text{even-x-shift}\rangle\langle\text{even-y-shift}\rangle]
\end{verbatim}

where:

1. The frame \langle\text{type}\rangle is stored as a \text{byte}. This may only take one of the following values: 0 (static), 1 (flow), 2 (dynamic) and 3 (typeblock). There should only be one typeblock and this should belong to the outermost implicit group.

2. If \langle\text{type}\rangle is not equal to 3 (i.e. is not the typeblock), the following information should also be saved:

   2.1. a \text{boolean} value (\langle\text{border}\rangle) indicating whether or not the frame should have a border;

   2.2. the identification label (\langle\text{label}\rangle) stored as a \text{string};

   2.3. the page list (\langle\text{pages}\rangle) should be stored as a \text{string}.

3. The margins \langle\text{top}\rangle \langle\text{bottom}\rangle \langle\text{left}\rangle and \langle\text{right}\rangle are each stored as a \text{float} (in terms of the PostScript point \text{bp}) for versions below 1.8 and are stored as a \text{double} (in terms of the storage unit) otherwise.

4. (Version 1.2 onwards.) If the frame type is either 0 (static frame) or 2 (dynamic frame) \langle\text{shape}\rangle is a \text{byte} indicating the paragraph shape. This may be one of: 0 (standard shape), 1 (use \textbackslash parshape) or 2 (use \textbackslash shapepar). This value should be omitted if the frame type is 0 or 2.
5. (Version 1.3 onwards.) If the frame type is either 0 (static frame) or 2 (dynamic frame) \( v\text{-align} \) is a byte that represents the vertical alignment. This may be one of: 0 (top), 1 (centre) or 2 (bottom). This value should be omitted if the frame type is 0 or 2.

6. (Version 1.8 onwards.) If the frame type is either 0 (static frame) or 2 (dynamic frame) \( \text{contents} \) is a string with the frame’s contents. This may be an empty or null string. This value should be omitted if the frame type is 0 or 2.

7. (Version 1.8 onwards.) The horizontal even page shift \( \text{even-x-shift} \) is stored as a double.

8. (Version 1.8 onwards.) The vertical even page shift \( \text{even-y-shift} \) is stored as a double. This value is omitted for the typeblock (type 3).
B  Multilingual Support

All the language dependent information is stored in the `lib/resources` subdirectory of the installation directory. If you want all the menus, tooltips etc in another language, you will need to translate the dictionary file (found in `lib/resources/dictionaries/`). This has a `⟨key⟩=⟨value⟩` format. Only the `⟨value⟩` text should be translated. Note that each `⟨key⟩=⟨value⟩` pair must be contained on a single line, so if `⟨value⟩` contains a lot of text, take care if your text editor likes to break lines automatically. Some of the values contain \1, \2, etc. These represent values that are substituted at runtime. The sequence \n indicates a line break needs to be inserted when displaying the string at runtime. (This only works if the text is used in a multi-line component.)

There are three keys (`about.translator`, `about.translator_info` and `about.translator_url`) which can be used to identify yourself as the translator. If the `about.translator` value is set, the information will be displayed in the Help → About dialog box.

The dictionary file should be named `flowframtk-⟨language⟩-⟨country⟩.prop` or `flowframtk-⟨language⟩.prop` (where `⟨country⟩` is an ISO-2 country identifier and `⟨language⟩` is an ISO-2 language identifier) and save it in the `resources/dictionaries/` subdirectory of FlowframTk’s installation directory. The easiest way to create this file is to copy an existing resource file, for example `flowframtk-en-GB.prop`, and replace all the text to the right of the equal signs. You will also need to add a line to the `resources/encodings.prop` file that specifies the file encoding. If you want to add your translation to the next version of FlowframTk, that’s great, but this can only be done if you assign a licence that’s compatible with FlowframTk’s licence. If you want to translate the manual, you need to download FlowframTk’s source code and create an alternative to the `flowframtk-en-GB.tex` or `flowframtk-en-US.tex` documents.

See also:

- §4 Language Settings
C Source Code

The source code is contained in the file *flowframtk-0.7-src.zip*, which is available from [http://www.dickimaw-books.com/apps/flowframtk/](http://www.dickimaw-books.com/apps/flowframtk/). The source code was written and tested running under Linux. Some of the helper scripts may not run on other operating systems. This archive contains the following directories:

- **flowframtk-0.7/bin**: scripts that load the required *jar* files into Java
- **flowframtk-0.7/doc**: documentation
- **flowframtk-0.7/lib**: required Java libraries
- **flowframtk-0.7/src**: the Java source code.
- **flowframtk-0.7/examples**: example images

In addition, the archive also contains the following files:

- **README**: important information about this distribution. Read this file before you try to compile the source.
- **BUGS**: list of known bugs
- **TODO**: list of things that need to be implemented
- **Makefile**: main makefile. Run “make all” to make all the applications
- **icons**: application icons.
- **CHANGES**: change log
- **DICT-CHANGES**: change log for dictionary

The documentation was written in **LATEX**, but shares the dictionary resource files (flowframtk-⟨lang⟩.prop) used by FlowframTk to ensure that the documentation uses the correct menu and dialog labels. In addition, the Java code relies on the **LATEX** documentation to provide the files required by the helpset (via **LATEX2HTML** and some helper Perl scripts). The labels used in the **LATEX** source are also used in the Java code to identify the context dependent information required by the help buttons in many of the dialog boxes.

C.1 Java Source

Requirements:


The Java source is contained in subdirectories of `flowframtk-0.7/src:`
flowframtk/src/jdr/
This contains the source code for jdr.jar. This deals with all the information that constitutes an image as well as methods to save and load images. The code that deals with parsing PostScript code (used by eps2jdr) is still experimental.

flowframtk/src/jdrresources
This contains the source code for jdrresources.jar. This deals with application resources (such as the dictionary).

flowframtk/src/flowframtk
This contains the source code for flowframtk.jar. This deals with the GUI part of FlowframTk.

flowframtk/src/jdrview
This contains the source code for jdrview.jar. This deals with the GUI part of Jdrview.

flowframtk/src/jdrinfo
This contains the source code for jdrinfo.jar. I wrote this to detect the file format version numbers for my sample JDR/AJR files.

flowframtk/src/*2*
These directories contain the source code for the command line converters that together form jdruits.

C.2 \LaTeX Source

The \LaTeX source is contained in flowframtk-0.7-src/doc/manual The manual is currently only available in English. The manual requires the file flowframtk-0.7/doc//version.tex which is created by the main makefile flowframtk-0.7/Makefile. If you are not using make, you will need to create this file, which should simply contain the line:

\version{0.7}

The documentation consists of the following files:

Makefile The documentation makefile. Just running “make” will make the PDF version and the Java helpset.

Makefile-lang Creates the documentation for either en-GB or en-US, depending on the value of the environment variable APPLANG.

flowframtk-main.tex The main contents of the manual for FlowframTk (i.e. this document).

flowframtk-(lang).tex The driver files (containing the \documentclass command) for the FlowframTk manual.

accelerators.tex The contents of Table 2.1. This file is input by flowframtk-main.tex.

preamble.tex The main bulk of the preamble for jpgdraw-main.tex and jdrview-main.tex.
C.2 \LaTeX\ SOURCE

\texttt{jdrview-main.tex} The main contents of the manual for Jdrview.

\texttt{jdrview-\langle lang\rangle.tex} The driver files (containing the \texttt{\documentclass} command) for the Jdrview manual.

\texttt{jdrutils-main.tex} The main contents of the manual for the command line converters, such as jdr2tex.

\texttt{jdrutils-\langle lang\rangle.tex} The driver files (containing the \texttt{\documentclass} command) for the jdrutils manual.

\texttt{flowframtk.sty} Style file used by the documentation.

\texttt{transdict.pl} This is a Perl script that converts the dictionary file to a file that \LaTeX\ can parse (\texttt{dictionary-\langle lang\rangle.tex}).

\texttt{flowframtk.perl} This is the \LaTeX2HTML version of \texttt{flowframtk.sty}. This also creates temporary files used by makehelpset to assist generating the helpset. Note that \texttt{flowframtk.sty} loads the \texttt{glossaries} package, but \texttt{flowframtk.perl} doesn’t load the equivalent \texttt{glossaries.perl} as \texttt{flowframtk.perl} uses popup windows to display the glossary terms instead of linking them to the glossary section.

\texttt{fixpaths} This removes the path names to the images used by the HTML files that form the helpset. This is needed as the HTML files and the images are moved to a different location.

\texttt{makehelpset} This is a Perl script that assists making the helpset. It uses the files generated by \texttt{flowframtk.perl} to create the map and index files required by the JavaHelp utility \texttt{jhindexer}.

\texttt{Makefile.jhindexer} The Makefile used to generate the helpset.

\texttt{images-\langle lang\rangle/} Images specific to this particular language set. Images used by both US and UK manuals are stored in \texttt{../sharedimages/}
D  Troubleshooting

1. My settings aren’t remembered.
   Check which option is selected in the Startup Settings tab of the Configure Image Settings dialog. This should be set to Use settings from previous instance if you want the settings remembered from the last time you quit the application. Also check the When loading: option in the JDR/AJR Settings tab. If this is set to Apply all settings stored in the file then any settings stored in an image that you load will override the current settings.

2. Sometimes the canvas doesn’t get correctly redrawn after I’ve loaded an image from a file.
   This is a known bug. Use F11 to force a redraw.

3. Sometimes lines don’t show up.
   If you have a thin line and the magnification is small or you have low resolution, the line may be too thin to show up on your display. Try either using a thicker line style or increasing the magnification.

4. When I try clicking on the canvas to add a new point, nothing happens.
   Make sure that you are actually clicking and not dragging. (Some touch sensitive mouse pads can mistake a click for a move or drag.) Make sure that you have selected the correct tool.

5. I tried to select and drag a point, but another point moved.
   When you select the new point, make sure it’s highlighted before you try dragging it. The click to select operation is separate to the drag operation.

6. I tried changing the line/text style but nothing happened.
   Remember to use the Edit → Path and Edit → Text submenus to change the styles for existing objects, and use Settings → Styles for all subsequent new objects.

7. I tried to create a package based on the flowfram package, but it didn’t define some (or all) of my frames.
   Remember to identify each object as a flow frame, a dynamic frame or a static frame. Any object that hasn’t been thus identified will not be written to the sty file.

8. When I exported to a package or class, flowfram complained the option “hide” or “hidethis” isn’t available.
   Upgrade to at least version 1.16 of the flowframtk package.

9. When I exported to a package or class, flowfram complained that I couldn’t use \Shapepar.
   Upgrade to at least version 1.16 of the flowframtk package.

10. I got an error that \Shapepar isn’t defined.
    Upgrade to the latest version of the shapepar package.
11. I get an error when I try to \LaTeX a \texttt{pgfpicture} environment created by \texttt{FlowframTk}.
Remember to include the \texttt{pgf} package. \texttt{FlowframTk} was tested using version 3.0 of the \texttt{pgf} package. It may not work with earlier versions.

\section*{D.1 Known Bugs}

If for some reason you are unable to access the save dialog box, you can do an emergency save by pressing F11. This will save all currently open images to a subdirectory in the \texttt{configuration directory}. (This works for most, but not all windows used by \texttt{FlowframTk}.)

1. Occasionally bits of the screen don’t get repainted. Use F11 to force a redraw.

2. Occasionally the message window doesn’t automatically close when there are no new warning messages.

3. Occasionally the \texttt{java.awt.*} or \texttt{javax.swing.*} classes throw a \texttt{NullPointerException}.
Bibliography


Glossary

**AJR**

FlowframTk’s native ASCII format. Files in this format should have the extension `.ajr`. This format is primarily provided to assist conversion to and from JDR files or for version control. 1, 5, 7, 8, 16, 39, 40, 42, 51, 237, 245

**backmost object**

The first object to be painted on the canvas. 4, 54, 71, 84, 89, 90, 93

**bitmap**

A raster graphics image. 18, 25, 39, 51, 68, 70, 103, 142, 164, 245, 254

**bounding box**

The smallest rectangle that encompasses the object. 27, 54, 73, 77, 81, 82, 120

**bp**

\(\TeX\)'s “big point”. This is the same as a PostScript point. 72bp = 1in. 8, 31, 43, 103, 109, 117, 122, 123, 229

**canvas**

The white area on which you construct your picture. 4, 10, 11, 13, 16, 23, 31, 37, 38, 40, 41, 43, 47, 51, 54, 57, 124, 137, 173, 177, 198, 207, 253

**checkbox**

A GUI element with two states: on (true) and off (false). 21, 23, 51, 82, 109, 117, 122, 123, 229

**combo box**

A GUI element similar to a drop-down list, but can be edited if the required value is not in the list. 121–124, 142

**composite shape**

A shape that is described by an underlying shape and a means of transforming it, such as apply symmetry or replicas. 27, 68, 254, 255

**construction mode**

Any of the tools except the select tool. 4, 43

**control point**

The points that define a path. Line segments and gaps have two control points, at the start and end, cubic Bézier segments have four control points: one at the start of the segment, one at the end of the segment, and two others that define the curvature of the segment. Adjacent segments share a common control point. When a path is under construction, or is being edited, the control points are shown as orange or red squares. Composite paths also have control points that govern how the full path is created from the underlying shape. The composite
control points are coloured differently to the standard path controls. 1, 3, 4, 10, 13, 16, 25, 45, 56–58, 60–63, 66, 67, 84, 95, 100, 103, 150, 151, 159, 230, 232, 244

control point index

Each control point defining a given path or composite shape has an index relative to the initial control point (at the start of the path). Use F6 (in edit path mode) to cycle through the points in increasing order of index. 57

drop-down list

A GUI element that allows a user to choose one value from a list. When inactive, it only displays the selected value. When activated (usually by pressing an arrow button to on one side) it displays a list of all available values from which the user can select the required value. 20, 121, 123, 140, 142, 143, 149, 151, 155, 171, 216, 220, 229

frontmost object

The last object to be painted on the canvas. 4, 54, 71, 224

grid

Tick marks located at regular intervals on the canvas. The grid can be locked so that new points will be placed at the tick nearest the specified position. 4, 7, 10, 57

group

A collection of objects treated as a single entity. 5, 23, 54, 56, 57, 63, 72, 73, 77, 82, 103, 107, 143, 245, 246

Java

A platform-independent object-orientated language. 1

JavaHelp

An optional package of the JRE enabling applications to use a native browser to display help topics. 3, 261, 263

JDR

FlowframTk’s native binary format. Files in this format should have the extension .jdr. 1, 5, 7, 8, 16, 39, 40, 42, 51, 237, 245

object

A path, text area, text-path, bitmap or group. 4, 5, 11, 13, 27, 38, 40, 54–57, 63, 71–73, 75, 77, 81, 82, 84, 138, 140, 142–144, 146, 198, 245, 246, 264

path

**path attributes**
The line colour, fill colour and line styles for the path.  43

**pattern**
A composite shape formed by repeatedly applying a given transformation on a
shape. Each pattern has a specified number of replicas. The underlying shape
may or may not be visible. The pattern mode determines whether the underlying
path and replicas are drawn in one go (single mode) or whether they are drawn
independently of each other (multi-mode). Transformations (rotating, scaling
and shearing) are applied to the path not to the text.  77, 84, 89, 90, 93, 94, 103,
230, 255

**popup menu**
A menu whose items vary depending on the context. These menus are usually
invoked with the secondary mouse button. In FlowframTk it is also possible to
invoke popup menus using F3.  47, 54, 56, 57, 62, 63, 150, 161, 198, 226

**pt**
\[ \text{$\TeX$'s point. Not to be confused with bp (a PostScript point).} \]  72.27pt=1in.  8,

**raster graphics**
Representing images as a collection of pixels. Also called a bitmap.  51, 56

**recto**
the “front” side of a leaf of paper (the right or odd-numbered page).  11, 146,
147, 194

**rotational pattern**
A pattern where the replicas are created by rotating the underlying path. In
addition to the control points defining the underlying shape, rotational patterns
also have a control point that governs the point of rotation.  147, 246, 257

**rulers**
The two panels containing the horizontal and vertical rulers.  8, 10, 31, 38, 241

**scaled pattern**
A pattern where the replicas are created by scaling the underlying path. In addi-
tion to the control points defining the underlying shape, scaled patterns also have
two control points governing the scale anchor and the scale direction.  246, 257

**shape**
Either a path, text-path or a composite shape.  58, 62, 84, 89, 90, 93, 103, 232

**spiral pattern**
A pattern where the replicas are created by rotating and translating the underlying
path so that the replicas are aligned along a spiral. In addition to the control
points defining the underlying shape, spiral patterns also have two control points
that govern the anchor and offset.  246, 257
Glossary

stacking order
The order in which objects are painted on the canvas. To determine the reverse stacking order, deselect all objects, then use F6 to cycle through the stack starting from the frontmost object. Reverse this list to obtain the stacking order. Note that the frontmost object is the last object in the stack, not the first. 4, 5, 54, 71, 81, 84, 137, 162, 224, 228, 232

status bar
The status bar is the horizontal panel positioned along the bottom of FlowframTk’s main window. 8, 10, 38

storage unit
The length unit used when storing co-ordinates. The default unit is bp (PostScript point) but may be changed in the configuration dialog. 13, 61, 124, 171, 195, 216, 239, 240

symmetric shape
A composite shape that is formed by the underlying shape added to its reflection in a line a symmetry. Depending on how it’s created, the symmetric shape may be drawn as a single shape, or the underlying shape and its reflection may be drawn independently of each other. The line of symmetry has two control points that can be adjusted to change the overall shape. 67, 147, 230, 246, 254, 256

text area
An object consisting of a single line of text. The text may be moved, scaled, rotated, sheared or converted to a path. 3, 10, 20, 21, 23, 38, 41, 43, 47, 56, 63, 66–68, 70–73, 75, 77, 82, 95, 103, 105, 107, 108, 120–124, 126, 127, 130, 131, 142, 155, 157, 226, 228, 229, 245, 252

text-path
A composite object formed by combining a path and a text area to create a text along a path effect. The underlying path is only visible when editing the text-path object using the edit path function. Transformations (rotating, scaling and shearing) are applied to the path not to the text. 23, 41, 43, 57, 58, 61, 63, 66–68, 72, 73, 75, 77, 84, 89, 93–95, 100, 103, 105, 107, 108, 121–124, 130, 131, 246–248, 255

toolbars
The two panels containing buttons, the horizontal toolbar is positioned at the top of FlowframTk’s main window, the vertical toolbar is positioned along the left edge of the main window. 7, 8, 10, 31, 38, 43

vector graphics
A means of describing images through the use of points, lines and curves. 1, 51

verso
the “back” side of a leaf of paper (the left or even-numbered page). 11, 137, 140, 146, 147, 194
Acronyms

Graphical user interface (GUI)
An application with windows and buttons in which the user can point and click with the mouse. 1, 262

Java Standard Edition SDK (JDK)
A development environment for building applications, applets and components using the Java programming language. 261

Java Runtime Environment (JRE)
Allows end-users to run Java applications. The JRE can be downloaded from http://java.sun.com/j2se/. 1, 2, 7, 39, 51

Java Virtual Machine (JVM)
Also known as the Java Runtime Environment. 7

Multiple-document interface (MDI)
A main (parent) window containing child windows allowing you to process several documents in parallel. 37

Scalable vector graphics (SVG)
A Modularized language for describing two-dimensional vector and mixed vector/raster graphics in XML. 1, 18, 21, 40, 41, 51